Subject: [Tls-reg-review] Request to register value in TLS bar registry

From: Евгений Алексеев <[email-masked]>
Date: Wed, 09 Jan 2019 16:16:08 +0300

Hello!

We would like to ask IANA to assign numbers  in accordance with  the IANA Considerations section of the "GOST Cipher Suites for Transport Layer Security (TLS) Protocol Version 1.2" document ( https://tools.ietf.org/html/draft-smyshlyaev-tls12-gost-suites-04#section-9 ).

-- 
Best regards,
Evgeny Alekseev

---

From: Yoav Nir <[email-masked]>
Date: Wed, 9 Jan 2019 20:39:34 +0200

Hi, Evgeny.

We’ll give the answer in a few days. First, I’d like to ask a few clarifying questions:
If I understand correctly, the Kuznyechik ciphers in this document is the new GOST algorithms, right?
I have noticed that this is only for TLS 1.2.  Why not TLS 1.3?
Section 10 mentions that there are existing implementations that use the value {0x00,0x81} for TLS_GOSTR341112_256_WITH_28147_CNT_IMIT.  I see in the IANA registry <https://www.iana.org/assignments/tls-parameters/tls-parameters.xml#tls-parameters-4> that this value is free.  Do you want to re-use it? 

Thanks

Yoav

> On 9 Jan 2019, at 15:16, Евгений Алексеев <geni-cmc=[email-masked]> wrote:
> 
> Hello!
> 
> We would like to ask IANA to assign numbers in accordance with the IANA Considerations section of the "GOST Cipher Suites for Transport Layer Security (TLS) Protocol Version 1.2" document (https://tools.ietf.org/html/draft-smyshlyaev-tls12-gost-suites-04#section-9 <https://tools.ietf.org/html/draft-smyshlyaev-tls12-gost-suites-04#section-9>).
> 
> -- 
> Best regards,
> Evgeny Alekseev
> _______________________________________________
> tls-reg-review mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls-reg-review

---

From: Смышляев Станислав Витальевич <[email-masked]>
Date: Wed, 9 Jan 2019 19:52:11 +0000

Dear Yoav,

Thank you very much for your comments!
If you don't mind, I'll reply:
1) Yes, Kuznyechik is the new Russian cipher. It is defined in RFC 7801.
2) There's still work in progress on an AEAD mode to be standardized in Russia - and we can't have a TLS 1.3 cipher suite without an AEAD mode. Currently the MGM mode (see https://tools.ietf.org/html/draft-smyshlyaev-mgm-09) is being carefully studied and tends to be the one. Valery Smyslov waits for it also - to be able to work on IKEv2 and ESP with GOSTs.
That's why the current request (and the draft it refers to) is only about TLS 1.2 so far.
3) Unfortunately, there is a misleading statement in the current version of the draft (thank you for pointing to it, Yoav!): actually, {0x00, 0x81} is used for the older cipher suite from https://tools.ietf.org/html/draft-chudov-cryptopro-cptls-04#section-5. The existing implementations of TLS_GOSTR341112_256_WITH_28147_CNT_IMIT use the number {0xFF, 0x85}

Best regards,
Stanislav Smyshlyaev

9 янв. 2019 г., в 21:39, Yoav Nir <[email-masked]<mailto:[email-masked]>> написал(а):

Hi, Evgeny.

We'll give the answer in a few days. First, I'd like to ask a few clarifying questions:

  *   If I understand correctly, the Kuznyechik ciphers in this document is the new GOST algorithms, right?
  *   I have noticed that this is only for TLS 1.2.  Why not TLS 1.3?
  *   Section 10 mentions that there are existing implementations that use the value {0x00,0x81} for TLS_GOSTR341112_256_WITH_28147_CNT_IMIT.  I see in the IANA registry<https://www.iana.org/assignments/tls-parameters/tls-parameters.xml#tls-parameters-4> that this value is free.  Do you want to re-use it?

Thanks

Yoav

On 9 Jan 2019, at 15:16, Евгений Алексеев <geni-cmc=[email-masked]<mailto:geni-cmc=[email-masked]>> wrote:

Hello!

We would like to ask IANA to assign numbers in accordance with the IANA Considerations section of the "GOST Cipher Suites for Transport Layer Security (TLS) Protocol Version 1.2" document (https://tools.ietf.org/html/draft-smyshlyaev-tls12-gost-suites-04#section-9).

--
Best regards,
Evgeny Alekseev
_______________________________________________
tls-reg-review mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tls-reg-review

---

From: Смышляев Станислав Витальевич <[email-masked]>
Date: Wed, 9 Jan 2019 20:26:02 +0000

CC'ing Dmitry Belyavsky (in case he would like to add some other clarifications), who we discussed the IANA request for the GOST cipher suites with (in Bangkok).

Best regards,
Stanislav Smyshlyaev

9 янв. 2019 г., в 22:52, Смышляев Станислав Витальевич <[email-masked]<mailto:[email-masked]>> написал(а):

Dear Yoav,

Best regards,
Stanislav Smyshlyaev

Hi, Evgeny.

Thanks

Yoav

Hello!

---

From: Смышляев Станислав Витальевич <[email-masked]>
Date: Fri, 1 Feb 2019 07:28:00 +0000

Dear Yoav, Rich and Nick,

Do you have any additional questions about this request? Dmitry Belyavsky and I will be very happy to provide any clarifications, if needed.

Best regards,
Stanislav Smyshlyaev, Ph.D.
CISO, CryptoPro LLC

From: Смышляев Станислав Витальевич <[email-masked]>
Sent: Wednesday, January 9, 2019 11:26 PM
To: Yoav Nir <[email-masked]>
Cc: Евгений Алексеев <[email-masked]>; [email-masked]; Смышляева Екатерина Сергеевна <[email-masked]>; Коллегин Максим Дмитриевич <[email-masked]>; Алексеев Евгений Константинович <[email-masked]>; Белявский Дмитрий <[email-masked]>
Subject: Re: [Tls-reg-review] Request to register value in TLS bar registry

Best regards,
Stanislav Smyshlyaev

Best regards,
Stanislav Smyshlyaev

Thanks

Yoav

Hello!