Subject: Re: [Tls-reg-review] Application for the TLS code points

From: "Salz, Rich" <[email-masked]>
Date: Wed, 27 Mar 2019 17:19:49 +0000

Agreed.

From: Yoav Nir <[email-masked]>
Date: Wednesday, March 27, 2019 at 6:04 PM
To: "[email-masked]" <[email-masked]>
Subject: Re: [Tls-reg-review] Application for the TLS code points

Seems like a slam dunk to me.  Either of you think different?
Sent from my phone
________________________________
From: Wang Haiguang
Sent: Tue Mar 26 09:58:01 GMT+01:00 2019
To: "[email-masked]"
Cc: Sean Turner
Subject: [Tls-reg-review] Application for the TLS code points

Dear Rich, Yoav and Nick

This is Haiguang Wang from Huawei.

Currently we are working on a personal draft named as draft-wang-tls-raw-public-key-with-ibc-10.
We have made a presentation in IETF 104 yesterday. Attached is the our presentation slides and the draft that will be upload to the IETF meeting.

We need 4 code points for four IBS signature algorithms, so please review and let us know whether we can get the four code points for implementation and testing of the protocol.

enum {
...
/* IBS ECCSI signature algorithm */
eccsi_sha256 (TBD),
iso_ibs1 (TBD),
iso_ibs2 (TBD),
iso_chinese_ibs (TBD),
/* Reserved Code Points */
private_use (0xFE00..0xFFFF),
(0xFFFF)
} SignatureScheme;

Best regards.

Haiguang

________________________________

tls-reg-review mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tls-reg-review<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_tls-2Dreg-2Dreview&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=94aoJezYS7N6KwIBbCbGLYShnYg5kbXLV2EhxUUDXsA&s=vQD6o5E41PVuOQXIcFP7W1wSZL5hfYvmze8_bLtWIZA&e=>

---

From: Nick Sullivan <[email-masked]>
Date: Wed, 27 Mar 2019 18:52:44 +0100

All good.
On Wed, Mar 27, 2019 at 6:20 PM Salz, Rich <[email-masked]> wrote:

> Agreed.
>
>
>
> *From: *Yoav Nir <[email-masked]>
> *Date: *Wednesday, March 27, 2019 at 6:04 PM
> *To: *"[email-masked]" <[email-masked]>
> *Subject: *Re: [Tls-reg-review] Application for the TLS code points
>
>
>
> ------------------------------
>
> *From:* Wang Haiguang
> *Sent:* Tue Mar 26 09:58:01 GMT+01:00 2019
> *To:* "[email-masked]"
> *Cc:* Sean Turner
> *Subject:* [Tls-reg-review] Application for the TLS code points
>
>
>
> Dear Rich, Yoav and Nick
>
>
>
> Currently we are working on a personal draft named
> as draft-wang-tls-raw-public-key-with-ibc-10.
>
> We have made a presentation in IETF 104 yesterday. Attached is the our
> presentation slides and the draft that will be upload to the IETF meeting.
>
>
>
> We need 4 code points for four IBS signature algorithms, so please review
> and let us know whether we can get the four code points for implementation
> and testing of the protocol.
>
>
>
> enum {
>
> ...
>
> ------------------------------
>
>
> https://www.ietf.org/mailman/listinfo/tls-reg-review <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_tls-2Dreg-2Dreview&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=94aoJezYS7N6KwIBbCbGLYShnYg5kbXLV2EhxUUDXsA&s=vQD6o5E41PVuOQXIcFP7W1wSZL5hfYvmze8_bLtWIZA&e=>
>
> _______________________________________________
> https://www.ietf.org/mailman/listinfo/tls-reg-review
>