Subject: [Tls-reg-review] Application for the TLS code points

From: Wang Haiguang <[email-masked]>
Date: Tue, 26 Mar 2019 08:58:01 +0000

Dear Rich, Yoav and Nick

This is Haiguang Wang from Huawei.

Currently we are working on a personal draft named as draft-wang-tls-raw-public-key-with-ibc-10.
We have made a presentation in IETF 104 yesterday. Attached is the our presentation slides and the draft that will be upload to the IETF meeting.

We need 4 code points for four IBS signature algorithms, so please review and let us know whether we can get the four code points for implementation and testing of the protocol.

enum {
...
/* IBS ECCSI signature algorithm */
eccsi_sha256 (TBD),
iso_ibs1 (TBD),
iso_ibs2 (TBD),
iso_chinese_ibs (TBD),
/* Reserved Code Points */
private_use (0xFE00..0xFFFF),
(0xFFFF)
} SignatureScheme;

Best regards.

Haiguang

---

From: Yoav Nir <[email-masked]>
Date: Wed, 27 Mar 2019 18:03:59 +0100

Seems like a slam dunk to me.  Either of you think different? 

⁣Sent from my phone ​

-------- Original Message --------
From: Wang Haiguang <[email-masked]>
Sent: Tue Mar 26 09:58:01 GMT+01:00 2019
To: "[email-masked]" <[email-masked]>
Cc: Sean Turner <[email-masked]>
Subject: [Tls-reg-review] Application for the TLS code points

Dear Rich, Yoav and Nick

enum {
....

Best regards.

Haiguang

------------------------------------------------------------------------

_______________________________________________
tls-reg-review mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tls-reg-review

---

From: Yoav Nir <[email-masked]>
Date: Thu, 28 Mar 2019 06:03:32 +0100

Hi, Haiguang

We’ve discussed it, and you can get your code points.  However, there are a few things you need to do first:
The current draft in the datatracker is version -08, not -10. That version requests just one code point assignment, not 4.  Please submit the updated draft.
Even in the PDF version of the draft, the four code points appear in section 4, but they do not appear in section 8 (IANA Considerations).
The IANA considerations section is confusing.  It states that IANA is asked to assign an OID, and in the next bullet point says that this OID has already been assigned.  It’s not clear to me, and it won’t be clear to IANA what you want them to do.

So please get back to us after you submit a revised draft with a fixed section 8, and we will instruct IANA to make the assignment.

Hope this helps.

Yoav
(on behalf of the TLS review team)

> On 26 Mar 2019, at 9:58, Wang Haiguang <[email-masked]> wrote:
> 
> Dear Rich, Yoav and Nick
> 
> <draft-wang-tls-raw-public-key-with-ibc-10.pdf><slides-104-TLS-raw-public-key-IBC-10.pdf>_______________________________________________
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/tls-reg-review <https://www.ietf.org/mailman/listinfo/tls-reg-review>

---

From: Wang Haiguang <[email-masked]>
Date: Thu, 28 Mar 2019 08:34:17 +0000

Dear Yoav,

Thanks very much for the comments.

We will update the draft according to your suggestion and will upload the IETF data tracker soon.

Previously we have submit a version 9, but it seems that version is not the data tracker, so I am going to change the version number to 9 for next submission instead of a 10.

Best regards.

Haiguang
________________________________
From: Yoav Nir [[email-masked]]
Sent: Thursday, 28 March, 2019 1:03:32 PM
To: Wang Haiguang
Cc: [email-masked]; Sean Turner
Subject: Re: [Tls-reg-review] Application for the TLS code points

Hi, Haiguang

  1.  The current draft in the datatracker is version -08, not -10. That version requests just one code point assignment, not 4.  Please submit the updated draft.
  2.  Even in the PDF version of the draft, the four code points appear in section 4, but they do not appear in section 8 (IANA Considerations).
  3.  The IANA considerations section is confusing.  It states that IANA is asked to assign an OID, and in the next bullet point says that this OID has already been assigned.  It’s not clear to me, and it won’t be clear to IANA what you want them to do.

Hope this helps.

Yoav

On 26 Mar 2019, at 9:58, Wang Haiguang <[email-masked]<mailto:[email-masked]>> wrote:

Dear Rich, Yoav and Nick

enum {
...

Best regards.

Haiguang
<draft-wang-tls-raw-public-key-with-ibc-10.pdf><slides-104-TLS-raw-public-key-IBC-10.pdf>_______________________________________________
tls-reg-review mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tls-reg-review