Subject: [Tls-reg-review] Request to register value transparency_info(TBD) to the "TLS ExtensionType Values" registry

From: Paul Wouters <[email-masked]>
Date: Sat, 2 Mar 2019 13:07:52 -0500 (EST)

Hi,

For the 6962bis document we are requesting a value in the "TLS
ExtensionType Values" registry:

https://tools.ietf.org/html/draft-ietf-trans-rfc6962-bis-31#section-10.1

    10.1.  New Entry to the TLS ExtensionType Registry

    IANA is asked to add an entry for "transparency_info(TBD)" to the
    "TLS ExtensionType Values" registry defined in [RFC8446], setting the
    "Recommended" value to "Y", setting the "TLS 1.3" value to "CH, CR,
    CT", and citing this document as the "Reference".

As per https://tools.ietf.org/html/rfc8447#section-17 we are requesting
a review of this request by the designed Expert Pool for TLS.

Paul & Melinda

---

From: Yoav Nir <[email-masked]>
Date: Sat, 2 Mar 2019 22:35:33 +0200

Seems legit to me.

> On 2 Mar 2019, at 20:07, Paul Wouters <[email-masked]> wrote:
> 
> 
> Hi,
> 
> _______________________________________________
> tls-reg-review mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls-reg-review

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 4 Mar 2019 00:08:07 +0000

dityo

On 3/2/19, 3:35 PM, "Yoav Nir" <[email-masked]> wrote:

    Seems legit to me.

---

From: Yoav Nir <[email-masked]>
Date: Tue, 5 Mar 2019 00:16:29 +0200

Hi.

We’ve discussed this and we approve this assignment.

Yoav
(on behalf of the TLS expert pool)

> Begin forwarded message:
> 
> From: Paul Wouters <[email-masked]>
> Subject: [Tls-reg-review] Request to register value transparency_info(TBD) to the "TLS ExtensionType Values" registry
> Date: 2 March 2019 at 20:07:52 GMT+2
> To: [email-masked]
> Cc: Trans <[email-masked]>
> 
> 
> Hi,
>

---

From: Yoav Nir <[email-masked]>
Date: Tue, 5 Mar 2019 00:42:57 +0200

inline...

> On 5 Mar 2019, at 0:37, Amanda Baber via RT <[email-masked]> wrote:
> 
> Hi Yoav,
> 
> Should we assign a value from the 32-34 range, the 36-40 range, or the 52-65279 range?

I think 52.  There is no indication why the 32-34 range was not assigned, but it is at the end of several password extensions, so we might leave some room for more of those.  And we can leave 36-40 for some future alternate sessions tickets.

> 
> https://www.iana.org/assignments/tls-extensiontype-values
> 
> Do you want us to wait to make this assignment until the document is approved, or should we go ahead?

You can go ahead.

Thanks.

> 
> Best regards,
> 
> Amanda Baber
> Lead IANA Services Specialist
> 
> On Mon Mar 04 22:16:50 2019, [email-masked] wrote:
>> Hi.
>> 
>>> Subject: [Tls-reg-review] Request to register value
>>> transparency_info(TBD) to the "TLS ExtensionType Values" registry