Subject: Re: [Tls-reg-review] Application for the TLS code points

From: Wang Haiguang <[email-masked]>
Date: Fri, 12 Apr 2019 08:05:01 +0000

Dear Yoav,

I have updated the TLS-IBC draft, which is version -09, and has been uploaded to the data tracker.
Following is the link to the updated draft:
https://www.ietf.org/id/draft-wang-tls-raw-public-key-with-ibc-09.txt.

In the IANA section, I have removed the request for ECCSI OID as it has already been assigned.
For the code point, I added following content:

   The following TLS code points are required to be assigned:

   - Signature Scheme Registry: signature algorithm for
   eccsi_with_sha256, iso_ibs1, iso_ibs2, iso_chinese_ibs are required
   to be reserved.

Please let me know your comments.

Best regards.

Haiguang

From: Wang Haiguang
Sent: Thursday, March 28, 2019 4:34 PM
To: Yoav Nir <[email-masked]>
Cc: [email-masked]; Sean Turner <[email-masked]>
Subject: RE: [Tls-reg-review] Application for the TLS code points

Dear Yoav,

Thanks very much for the comments.

We will update the draft according to your suggestion and will upload the IETF data tracker soon.

Previously we have submit a version 9, but it seems that version is not the data tracker, so I am going to change the version number to 9 for next submission instead of a 10.

Best regards.

Haiguang
________________________________
From: Yoav Nir [[email-masked]]
Sent: Thursday, 28 March, 2019 1:03:32 PM
To: Wang Haiguang
Cc: [email-masked]<mailto:[email-masked]>; Sean Turner
Subject: Re: [Tls-reg-review] Application for the TLS code points
Hi, Haiguang

We've discussed it, and you can get your code points.  However, there are a few things you need to do first:

  1.  The current draft in the datatracker is version -08, not -10. That version requests just one code point assignment, not 4.  Please submit the updated draft.
  2.  Even in the PDF version of the draft, the four code points appear in section 4, but they do not appear in section 8 (IANA Considerations).
  3.  The IANA considerations section is confusing.  It states that IANA is asked to assign an OID, and in the next bullet point says that this OID has already been assigned.  It's not clear to me, and it won't be clear to IANA what you want them to do.

So please get back to us after you submit a revised draft with a fixed section 8, and we will instruct IANA to make the assignment.

Hope this helps.

Yoav
(on behalf of the TLS review team)

On 26 Mar 2019, at 9:58, Wang Haiguang <[email-masked]<mailto:[email-masked]>> wrote:

Dear Rich, Yoav and Nick

This is Haiguang Wang from Huawei.

Currently we are working on a personal draft named as draft-wang-tls-raw-public-key-with-ibc-10.
We have made a presentation in IETF 104 yesterday. Attached is the our presentation slides and the draft that will be upload to the IETF meeting.

We need 4 code points for four IBS signature algorithms, so please review and let us know whether we can get the four code points for implementation and testing of the protocol.

enum {
...
/* IBS ECCSI signature algorithm */
eccsi_sha256 (TBD),
iso_ibs1 (TBD),
iso_ibs2 (TBD),
iso_chinese_ibs (TBD),
/* Reserved Code Points */
private_use (0xFE00..0xFFFF),
(0xFFFF)
} SignatureScheme;

Best regards.

Haiguang
<draft-wang-tls-raw-public-key-with-ibc-10.pdf><slides-104-TLS-raw-public-key-IBC-10.pdf>_______________________________________________
tls-reg-review mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tls-reg-review

---

From: Yoav Nir <[email-masked]>
Date: Fri, 12 Apr 2019 12:58:20 +0300

Hi, Haiguang.

This is still not right. The word “reserved” in IANA registries means code points that are not to be assigned. For example, in this registry a lot of ranges are reserved for backward compatibility..

https://www.iana.org/assignments/tls-parameters/tls-parameters.xml#tls-signaturescheme <https://www.iana.org/assignments/tls-parameters/tls-parameters.xml#tls-parameters-16>

The way such IANA Considerations sections are usually phrased are something like the following:

> IANA is requested to assign 4 code points from the TLS SignatureScheme registry with the following descriptions:
> eccsi_sha256
> iso_ibs1
> iso_ibs2
> iso_chinese_ibs
> 
> For all of these entries the Recommended field should be N, and the Reference field should be this document.

Feel free to copy the above text.

Yoav

> On 12 Apr 2019, at 11:05, Wang Haiguang <[email-masked]> wrote:
> 
> Dear Yoav,
>  
> https://www.ietf.org/id/draft-wang-tls-raw-public-key-with-ibc-09.txt <https://www.ietf.org/id/draft-wang-tls-raw-public-key-with-ibc-09.txt>.
>  
> Cc: [email-masked] <mailto:[email-masked]>; Sean Turner
> We’ve discussed it, and you can get your code points.  However, there are a few things you need to do first:
> The current draft in the datatracker is version -08, not -10. That version requests just one code point assignment, not 4.  Please submit the updated draft.
> Even in the PDF version of the draft, the four code points appear in section 4, but they do not appear in section 8 (IANA Considerations).
> The IANA considerations section is confusing.  It states that IANA is asked to assign an OID, and in the next bullet point says that this OID has already been assigned.  It’s not clear to me, and it won’t be clear to IANA what you want them to do.
>  
> On 26 Mar 2019, at 9:58, Wang Haiguang <[email-masked] <mailto:[email-masked]>> wrote:
>  
> Dear Rich, Yoav and Nick
>  
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/tls-reg-review <https://www.ietf.org/mailman/listinfo/tls-reg-review>

---

From: Wang Haiguang <[email-masked]>
Date: Mon, 15 Apr 2019 01:26:35 +0000

Dear Yoav

Thanks very much for your kindness.

I have updated the draft by copying the text you provided in the last email  into the IANA section.
Please help to check whether the content in the IANA section is appropriate or not.

If it is okay, I will upload this version as a version 10 to the IETF data tracker.

Best regards.

Haiguang

From: Yoav Nir [mailto:[email-masked]]
Sent: Friday, April 12, 2019 5:58 PM
To: Wang Haiguang <[email-masked]>
Cc: [email-masked]; Sean Turner <[email-masked]>
Subject: Re: [Tls-reg-review] Application for the TLS code points

Hi, Haiguang.

https://www.iana.org/assignments/tls-parameters/tls-parameters.xml#tls-signaturescheme<https://www.iana.org/assignments/tls-parameters/tls-parameters.xml#tls-parameters-16>

  *   eccsi_sha256
  *   iso_ibs1
  *   iso_ibs2
  *   iso_chinese_ibs

Yoav

On 12 Apr 2019, at 11:05, Wang Haiguang <[email-masked]<mailto:[email-masked]>> wrote:

Dear Yoav,

Best regards.

Haiguang

From: Wang Haiguang
Sent: Thursday, March 28, 2019 4:34 PM
To: Yoav Nir <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; Sean Turner <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Tls-reg-review] Application for the TLS code points

Dear Yoav,

Best regards.

Haiguang
From: Yoav Nir [[email-masked]<mailto:[email-masked]>]

  1.  The current draft in the datatracker is version -08, not -10. That version requests just one code point assignment, not 4.  Please submit the updated draft.
  2.  Even in the PDF version of the draft, the four code points appear in section 4, but they do not appear in section 8 (IANA Considerations).
  3.  The IANA considerations section is confusing.  It states that IANA is asked to assign an OID, and in the next bullet point says that this OID has already been assigned.  It’s not clear to me, and it won’t be clear to IANA what you want them to do.

Hope this helps.

Yoav

Dear Rich, Yoav and Nick

enum {
...

Best regards.

Haiguang

---

From: Yoav Nir <[email-masked]>
Date: Tue, 16 Apr 2019 00:08:45 +0300

Looks good to me.

Yoav

> On 15 Apr 2019, at 4:26, Wang Haiguang <[email-masked]> wrote:
> 
> Dear Yoav
>  
> On 12 Apr 2019, at 11:05, Wang Haiguang <[email-masked] <mailto:[email-masked]>> wrote:
>  
> Dear Yoav,
>  
> To: Yoav Nir <[email-masked] <mailto:[email-masked]>>
> Cc: [email-masked] <mailto:[email-masked]>; Sean Turner <[email-masked] <mailto:[email-masked]>>
> From: Yoav Nir [[email-masked] <mailto:[email-masked]>]
> <draft-wang-tls-raw-public-key-with-ibc-10.pdf>

---

From: Nick Sullivan <[email-masked]>
Date: Mon, 15 Apr 2019 17:23:35 -0700

Looks good to me too.

On Mon, Apr 15, 2019 at 2:08 PM Yoav Nir <[email-masked]> wrote:

> *From:* Yoav Nir [mailto:[email-masked] <[email-masked]>]
> *Sent:* Friday, April 12, 2019 5:58 PM
> *To:* Wang Haiguang <[email-masked]>
> *Cc:* [email-masked]; Sean Turner <[email-masked]>
> *Subject:* Re: [Tls-reg-review] Application for the TLS code points
>
> Hi, Haiguang.
>
> This is still not right. The word “reserved” in IANA registries means code
> points that are not to be assigned. For example, in this registry a lot of
> ranges are reserved for backward compatibility..
>
>
> https://www.iana.org/assignments/tls-parameters/tls-parameters.xml#tls-signaturescheme
> <https://www.iana.org/assignments/tls-parameters/tls-parameters.xml#tls-parameters-16>
>
> IANA is requested to assign 4 code points from the TLS SignatureScheme
> registry with the following descriptions:
>
>    - eccsi_sha256
>    - iso_ibs1
>    - iso_ibs2
>    - iso_chinese_ibs
>
>
> On 12 Apr 2019, at 11:05, Wang Haiguang <
> [email-masked]> wrote:
>
> Dear Yoav,
>
> *From:* Wang Haiguang
> *Sent:* Thursday, March 28, 2019 4:34 PM
> *To:* Yoav Nir <[email-masked]>
> *Cc:* [email-masked]; Sean Turner <[email-masked]>
> *Subject:* RE: [Tls-reg-review] Application for the TLS code points
>
> Dear Yoav,
>
> Previously we have submit a version 9, but it seems that version is not
> the data tracker, so I am going to change the version number to 9 for next
> submission instead of a 10.
>
> Best regards.
>
> Haiguang
> ------------------------------
>
> *From:* Yoav Nir [[email-masked]]
> *Sent:* Thursday, 28 March, 2019 1:03:32 PM
> *To:* Wang Haiguang
> *Cc:* [email-masked]; Sean Turner
> *Subject:* Re: [Tls-reg-review] Application for the TLS code points
> Hi, Haiguang
>
>    1. The current draft in the datatracker is version -08, not -10. That
>    version requests just one code point assignment, not 4.  Please submit the
>    updated draft.
>    2. Even in the PDF version of the draft, the four code points appear
>    in section 4, but they do not appear in section 8 (IANA Considerations).
>    3. The IANA considerations section is confusing.  It states that IANA
>    is asked to assign an OID, and in the next bullet point says that this OID
>    has already been assigned.  It’s not clear to me, and it won’t be clear to
>    IANA what you want them to do.
>
>
> So please get back to us after you submit a revised draft with a fixed
> section 8, and we will instruct IANA to make the assignment.
>
> Hope this helps.
>
> Yoav
> On 26 Mar 2019, at 9:58, Wang Haiguang <[email-masked]>
> wrote:
>
> Dear Rich, Yoav and Nick
>
> Currently we are working on a personal draft named
> as draft-wang-tls-raw-public-key-with-ibc-10.
> We have made a presentation in IETF 104 yesterday. Attached is the our
> presentation slides and the draft that will be upload to the IETF meeting.
>
> We need 4 code points for four IBS signature algorithms, so please review
> and let us know whether we can get the four code points for implementation
> and testing of the protocol.
>
> enum {
> ...
> <draft-wang-tls-raw-public-key-with-ibc-10.pdf><slides-104-TLS-raw-public-key-IBC-10.pdf>
> _______________________________________________
> [email-masked]
> _______________________________________________
> [email-masked]

---

From: Wang Haiguang <[email-masked]>
Date: Tue, 16 Apr 2019 09:44:43 +0000

Dear Yoav and Sullivan

I have uploaded the version of TLS-IBC draft version 10 to the IETF data tracker for code points application. The version is the same as the one attached in the previous email.

Following is link to the uploaded draft:
https://www.ietf.org/id/draft-wang-tls-raw-public-key-with-ibc-10.pdf

May I know what other procedure I should do for the application the code points as required in the draft?

Thanks very for the help.

Regards.

Haiguang

From: Nick Sullivan [mailto:[email-masked]]
Sent: Tuesday, April 16, 2019 8:24 AM
To: Yoav Nir <[email-masked]>
Cc: Wang Haiguang <[email-masked]>; [email-masked]; Sean Turner <[email-masked]>
Subject: Re: [Tls-reg-review] Application for the TLS code points

Looks good to me too.

On Mon, Apr 15, 2019 at 2:08 PM Yoav Nir <[email-masked]<mailto:[email-masked]>> wrote:
Looks good to me.

Yoav

On 15 Apr 2019, at 4:26, Wang Haiguang <[email-masked]<mailto:[email-masked]>> wrote:

Dear Yoav

Best regards.

Haiguang

To: Wang Haiguang <[email-masked]<mailto:[email-masked]>>

Hi, Haiguang.

  *   eccsi_sha256
  *   iso_ibs1
  *   iso_ibs2
  *   iso_chinese_ibs

Yoav

Dear Yoav,

Best regards.

Haiguang

From: Wang Haiguang

Dear Yoav,

Best regards.

Haiguang

Hope this helps.

Yoav

Dear Rich, Yoav and Nick

enum {
...

Best regards.

Haiguang

---

From: Yoav Nir <[email-masked]>
Date: Tue, 16 Apr 2019 22:36:32 +0300

Hi,

Rich, Nick and I have discussed this, and we approve this request.

https://tools.ietf.org/html/draft-wang-tls-raw-public-key-with-ibc-10 <https://tools.ietf.org/html/draft-wang-tls-raw-public-key-with-ibc-10>

Please let us know if there are any problems with it.

Thanks

Yoav
(on behalf of the TLS registry review team)

> Begin forwarded message:
> 
> From: Wang Haiguang <[email-masked]>
> Date: 16 April 2019 at 12:44:43 GMT+3
> To: Nick Sullivan <[email-masked]>, Yoav Nir <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>, Sean Turner <[email-masked]>
> 
> Dear Yoav and Sullivan
>  
> https://www.ietf.org/id/draft-wang-tls-raw-public-key-with-ibc-10.pdf <https://www.ietf.org/id/draft-wang-tls-raw-public-key-with-ibc-10.pdf>
>  
> On Mon, Apr 15, 2019 at 2:08 PM Yoav Nir <[email-masked] <mailto:[email-masked]>> wrote:
> Looks good to me.
>  
> Yoav
> 
> 
> On 15 Apr 2019, at 4:26, Wang Haiguang <[email-masked] <mailto:[email-masked]>> wrote:
>  
> Dear Yoav
>  
> From: Yoav Nir [mailto:[email-masked] <mailto:[email-masked]>] 
> To: Wang Haiguang <[email-masked] <mailto:[email-masked]>>

---

From: Yoav Nir <[email-masked]>
Date: Wed, 17 Apr 2019 00:50:43 +0300

Hi, Amanda.

I don’t see much difference there, so I think starting with 0x0704 should be fine.

> On 17 Apr 2019, at 0:21, Amanda Baber via RT <[email-masked]> wrote:
> 
> Hi Yoav,
> 
> Which values should we assign for these four registrations? There are several separate ranges of available values:
> 
> https://www.iana.org/assignments/tls-parameters/tls-parameters.xhtml#tls-signaturescheme <https://www.iana.org/assignments/tls-parameters/tls-parameters.xhtml#tls-signaturescheme>
> 
> Best regards,
> 
> Amanda Baber
> Lead IANA Services Specialist
> 
> On Tue Apr 16 19:36:57 2019, [email-masked] <mailto:[email-masked]> wrote:
>> Hi,
>> 
>> <https://tools.ietf.org/html/draft-wang-tls-raw-public-key-with-ibc- <https://tools.ietf.org/html/draft-wang-tls-raw-public-key-with-ibc->
>> 10>
>> 
>>> I have uploaded the version of TLS-IBC draft version 10 to the IETF
>>> data tracker for code points application. The version is the same as
>>> the one attached in the previous email.
>>> 
>>> <https://www.ietf.org/id/draft-wang-tls-raw-public-key-with-ibc- <https://www.ietf.org/id/draft-wang-tls-raw-public-key-with-ibc->
>>> 10.pdf>
>>> 
>>> Cc: Wang Haiguang <[email-masked]>; tls-reg-
>>> [email-masked]; Sean Turner <[email-masked]>
>>> On Mon, Apr 15, 2019 at 2:08 PM Yoav Nir <[email-masked] <mailto:[email-masked]>
>>> <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
>>> Looks good to me.
>>> 
>>> Yoav
>>> 
>>> 
>>> On 15 Apr 2019, at 4:26, Wang Haiguang
>>> <[email-masked] <mailto:[email-masked]>
>>> <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
>>> 
>>> Dear Yoav
>>> 
>>> From: Yoav Nir [mailto:[email-masked] <mailto:[email-masked]>
>>> <mailto:[email-masked] <mailto:[email-masked]>>]
>>> To: Wang Haiguang <[email-masked] <mailto:[email-masked]>
>>> <mailto:[email-masked] <mailto:[email-masked]>>>
>>> Cc: [email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>; Sean
>>> Turner <[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>>
>>> This is still not right. The word “reserved” in IANA registries means
>>> code points that are not to be assigned. For example, in this
>>> registry a lot of ranges are reserved for backward compatibility..
>>> 
>>> https://www.iana.org/assignments/tls-parameters/tls- <https://www.iana.org/assignments/tls-parameters/tls->
>>> parameters.xml#tls-signaturescheme
>>> <https://www.iana.org/assignments/tls-parameters/tls- <https://www.iana.org/assignments/tls-parameters/tls->
>>> parameters.xml#tls-parameters-16>
>>> 
>>> IANA is requested to assign 4 code points from the TLS
>>> SignatureScheme registry with the following descriptions:
>>> eccsi_sha256
>>> iso_ibs1
>>> iso_ibs2
>>> iso_chinese_ibs
>>> 
>>> On 12 Apr 2019, at 11:05, Wang Haiguang
>>> <[email-masked] <mailto:[email-masked]>
>>> <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
>>> 
>>> Dear Yoav,
>>> 
>>> https://www.ietf.org/id/draft-wang-tls-raw-public-key-with-ibc-09.txt <https://www.ietf.org/id/draft-wang-tls-raw-public-key-with-ibc-09.txt>
>>> <https://www.ietf.org/id/draft-wang-tls-raw-public-key-with-ibc- <https://www.ietf.org/id/draft-wang-tls-raw-public-key-with-ibc->
>>> 09.txt>.
>>> 
>>> To: Yoav Nir <[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>>
>>> Cc: [email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>; Sean
>>> Turner <[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>>
>>> Previously we have submit a version 9, but it seems that version is
>>> not the data tracker, so I am going to change the version number to 9
>>> for next submission instead of a 10.
>>> 
>>> Best regards.
>>> 
>>> Haiguang
>>> From: Yoav Nir [[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>]
>>> Cc: [email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>; Sean
>>> Turner
>>> The current draft in the datatracker is version -08, not -10. That
>>> version requests just one code point assignment, not 4.  Please
>>> submit the updated draft.
>>> Even in the PDF version of the draft, the four code points appear in
>>> section 4, but they do not appear in section 8 (IANA Considerations).
>>> The IANA considerations section is confusing.  It states that IANA is
>>> asked to assign an OID, and in the next bullet point says that this
>>> OID has already been assigned.  It’s not clear to me, and it won’t be
>>> clear to IANA what you want them to do.
>>> 
>>> So please get back to us after you submit a revised draft with a
>>> fixed section 8, and we will instruct IANA to make the assignment.
>>> 
>>> Hope this helps.
>>> 
>>> Yoav
>>> On 26 Mar 2019, at 9:58, Wang Haiguang
>>> <[email-masked] <mailto:[email-masked]>
>>> <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
>>> 
>>> Dear Rich, Yoav and Nick
>>> 
>>> We have made a presentation in IETF 104 yesterday. Attached is the
>>> our presentation slides and the draft that will be upload to the IETF
>>> meeting.
>>> 
>>> We need 4 code points for four IBS signature algorithms, so please
>>> review and let us know whether we can get the four code points for
>>> implementation and testing of the protocol.
>>> 
>>> enum {
>>> ...
>>> <draft-wang-tls-raw-public-key-with-ibc-10.pdf><slides-104-TLS-raw-
>>> public-key-IBC-10.pdf>_______________________________________________
>>> [email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>
>>> <https://www.ietf.org/mailman/listinfo/tls-reg-review <https://www.ietf.org/mailman/listinfo/tls-reg-review>>
>>> 
>>> [email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>
>>> <https://www.ietf.org/mailman/listinfo/tls-reg-review <https://www.ietf.org/mailman/listinfo/tls-reg-review>>

---

From: Wang Haiguang <[email-masked]>
Date: Tue, 23 Apr 2019 07:13:09 +0000

Dear all

Thanks very much to help provided in assigning the code points for signature algorithms included in the TLS-IBC draft. 

Have a nice day. 

Haiguang

-----Original Message-----
From: Amanda Baber via RT [mailto:[email-masked]] 
Sent: Wednesday, April 17, 2019 8:04 AM
To: [email-masked]
Cc: [email-masked]; Wang Haiguang <[email-masked]>; [email-masked]
Subject: [IANA #1140715] Fwd: [Tls-reg-review] Application for the TLS code points (draft-wang-tls-raw-public-key-with-ibc)

Hi all,

We've added the following entries to the TLS SignatureScheme registry:

Value: 0x0704
Description: eccsi_sha256
Recommended: N
Reference: [draft-wang-tls-raw-public-key-with-ibc]

Value: 0x0705
Description: iso_ibs1
Recommended: N
Reference: [draft-wang-tls-raw-public-key-with-ibc]

Value: 0x0706
Description: iso_ibs2
Recommended: N
Reference: [draft-wang-tls-raw-public-key-with-ibc]

Value: 0x0707
Description: iso_chinese_ibs
Recommended: N
Reference: [draft-wang-tls-raw-public-key-with-ibc]

Please see
https://www.iana.org/assignments/tls-parameters

thanks,
Amanda

On Tue Apr 16 21:51:05 2019, [email-masked] wrote:
> > Which values should we assign for these four registrations? There 
> > are several separate ranges of available values:
> >
> > https://www.iana.org/assignments/tls-parameters/tls-
> > parameters.xhtml#tls-signaturescheme
> > <https://www.iana.org/assignments/tls-parameters/tls-
> > parameters.xhtml#tls-signaturescheme>
> >
> > Best regards,
> >
> > Amanda Baber
> >> https://tools.ietf.org/html/draft-wang-tls-raw-public-key-with-ibc-
> >> 10 <https://tools.ietf.org/html/draft-wang-tls-raw-public-key-with-
> >> ibc-10>
> >> <https://tools.ietf.org/html/draft-wang-tls-raw-public-key-with-ibc
> >> -
> >> <https://tools.ietf.org/html/draft-wang-tls-raw-public-key-with-ibc
> >> -
> >> >
> >> 10>
> >>
> >>> I have uploaded the version of TLS-IBC draft version 10 to the 
> >>> IETF data tracker for code points application. The version is the 
> >>> same as the one attached in the previous email.
> >>>
> >>> <https://www.ietf.org/id/draft-wang-tls-raw-public-key-with-ibc-
> >>> <https://www.ietf.org/id/draft-wang-tls-raw-public-key-with-ibc->
> >>> 10.pdf>
> >>>
> >>> May I know what other procedure I should do for the application 
> >>> the code points as required in the draft?
> >>>
> >>> On Mon, Apr 15, 2019 at 2:08 PM Yoav Nir <[email-masked] 
> >>> <mailto:[email-masked]> <mailto:[email-masked] 
> >>> <mailto:[email-masked]>>> wrote:
> >>> Looks good to me.
> >>>
> >>> Yoav
> >>>
> >>>
> >>> <[email-masked]
> >>> <mailto:[email-masked]>
> >>> <mailto:[email-masked]
> >>> <mailto:[email-masked]>>> wrote:
> >>>
> >>> Dear Yoav
> >>>
> >>> From: Yoav Nir [mailto:[email-masked] 
> >>> <mailto:[email-masked]> <mailto:[email-masked] 
> >>> <mailto:[email-masked]>>]
> >>> To: Wang Haiguang <[email-masked]
> >>> <mailto:[email-masked]>
> >>> <mailto:[email-masked]
> >>> <mailto:[email-masked]>>>
> >>> Cc: [email-masked] <mailto:[email-masked]> 
> >>> <mailto:[email-masked] <mailto:[email-masked]>>;
> >>> Sean
> >>> Turner <[email-masked] <mailto:[email-masked]> 
> >>> <mailto:[email-masked] <mailto:[email-masked]>>>
> >>> This is still not right. The word “reserved” in IANA registries 
> >>> means code points that are not to be assigned. For example, in 
> >>> this registry a lot of ranges are reserved for backward 
> >>> compatibility..
> >>>
> >>> https://www.iana.org/assignments/tls-parameters/tls-
> >>> <https://www.iana.org/assignments/tls-parameters/tls->
> >>> <https://www.iana.org/assignments/tls-parameters/tls-
> >>> <https://www.iana.org/assignments/tls-parameters/tls->
> >>> For all of these entries the Recommended field should be N, and 
> >>> the Reference field should be this document.
> >>>
> >>> <[email-masked]
> >>> <mailto:[email-masked]>
> >>> <mailto:[email-masked]
> >>> <mailto:[email-masked]>>> wrote:
> >>>
> >>> Dear Yoav,
> >>>
> >>> https://www.ietf.org/id/draft-wang-tls-raw-public-key-with-ibc-
> >>> 09.txt 
> >>> <https://www.ietf.org/id/draft-wang-tls-raw-public-key-with-
> >>> ibc-09.txt>
> >>> <https://www.ietf.org/id/draft-wang-tls-raw-public-key-with-ibc-
> >>> <https://www.ietf.org/id/draft-wang-tls-raw-public-key-with-ibc->
> >>> 09.txt>.
> >>>
> >>> eccsi_with_sha256, iso_ibs1, iso_ibs2, iso_chinese_ibs are 
> >>> required to be reserved.
> >>>
> >>> To: Yoav Nir <[email-masked] <mailto:[email-masked]> 
> >>> <mailto:[email-masked] <mailto:[email-masked]>>>
> >>> Cc: [email-masked] <mailto:[email-masked]> 
> >>> <mailto:[email-masked] <mailto:[email-masked]>>;
> >>> Sean
> >>> Turner <[email-masked] <mailto:[email-masked]> 
> >>> <mailto:[email-masked] <mailto:[email-masked]>>>
> >>> Previously we have submit a version 9, but it seems that version 
> >>> is not the data tracker, so I am going to change the version 
> >>> number to
> >>> 9
> >>> From: Yoav Nir [[email-masked] <mailto:[email-masked]> 
> >>> Cc: [email-masked] <mailto:[email-masked]> 
> >>> <mailto:[email-masked] <mailto:[email-masked]>>;
> >>> Sean
> >>> Turner
> >>> We’ve discussed it, and you can get your code points.  However, 
> >>> there are a few things you need to do first:
> >>> Even in the PDF version of the draft, the four code points appear 
> >>> The IANA considerations section is confusing.  It states that IANA 
> >>> is asked to assign an OID, and in the next bullet point says that 
> >>> this OID has already been assigned.  It’s not clear to me, and it 
> >>> won’t be clear to IANA what you want them to do.
> >>>
> >>> <[email-masked]
> >>> <mailto:[email-masked]>
> >>> <mailto:[email-masked]
> >>> <mailto:[email-masked]>>> wrote:
> >>>
> >>> Dear Rich, Yoav and Nick
> >>>
> >>> Currently we are working on a personal draft named as draft-wang-
> >>> tls-
> >>> raw-public-key-with-ibc-10.
> >>> our presentation slides and the draft that will be upload to the 
> >>> IETF meeting.
> >>>
> >>> public-key-IBC-
> >>> 10.pdf>_______________________________________________
> >>> <mailto:[email-masked] <mailto:[email-masked]>> 
> >>> <https://www.ietf.org/mailman/listinfo/tls-reg-review>
> >>> <https://www.ietf.org/mailman/listinfo/tls-reg-review
> >>> <https://www.ietf.org/mailman/listinfo/tls-reg-review>>
> >>>
> >>> <mailto:[email-masked] <mailto:[email-masked]>> 
> >>> <https://www.ietf.org/mailman/listinfo/tls-reg-review>
> >>> <https://www.ietf.org/mailman/listinfo/tls-reg-review
> >>> <https://www.ietf.org/mailman/listinfo/tls-reg-review>>