Subject: Re: [Tls-reg-review] [IANA #1141082] Fwd: Early code-point assignment request for draft-ietf-tls-dtls-connection-id

From: "Salz, Rich" <[email-masked]>
Date: Tue, 11 Jun 2019 16:17:25 +0000

How long would it take to add a comment field or a {dtls/tls/both} column?

On 6/11/19, 12:15 PM, "Sabrina Tanamal via RT" <[email-masked]> wrote:

    Hi all, 
    
    Can you let us know if we can proceed with this request or is there discussion needed based on the questions asked by Chris and Nick? 
    
    NOTE: We're trying to figure out if there's an issue with the mailing list, so we're explicitly copying Rich, Yoav and Nick. 
    
    Thanks,
    
    Sabrina Tanamal
    Senior IANA Services Specialist
    
    On Mon May 27 18:59:48 2019, [email-masked] wrote:
    > I’ve no strong objections, though erring on the side of clarity is
    > probably best. How difficult would it be to add a field to distinguish
    > between the two?
    > 
    > Best,
    > Chris
    > 
    > On Thu, May 23, 2019, at 11:00 AM, Nick Sullivan wrote:
    > > This sounds good to me. However, there doesn't seem to be a way to
    > > indicate that this extension is for DTLS only and not TLS. I don't
    > > think that's an issue, but I'm interested to hear if anyone else has
    > > an objection.
    > >
    > > On Thu, May 23, 2019 at 9:35 AM Salz, Rich <[email-masked]> wrote:
    > > > __ __
    > >
    > > > I don’t recall seeing this until now. Explicitly copying Yoav and
    > > > Nick.____
    > >
    > > > __ __
    > >
    > > > I’m one of three and I support this. Does this work?____
    > >
    > > > Value 53____
    > >
    > > > TLS 1.3 –____
    > >
    > > > Recommended Y____
    > >
    > > > RFC TBD____
    > >
    > > > __ __
    > >
    > > > *From: *Joseph Salowey <[email-masked]>
    > > > *Date: *Thursday, May 23, 2019 at 12:23 PM
    > > > *To: *"[email-masked]" <[email-masked]>, "tls-reg-
    > > > [email-masked]" <[email-masked]>
    > > > *Cc: *Benjamin Kaduk <[email-masked]>, "[email-masked]" <tls-
    > > > [email-masked]>
    > > > *Subject: *Re: [Tls-reg-review] [IANA #1141082] Fwd: Early code-
    > > > point assignment request for draft-ietf-tls-dtls-connection-id____
    > >
    > > > __ __
    > >
    > > > I haven't seen the messages appear in the tls-reg-review archives
    > > > so I'm cc'ing them on this email to see if its stuck somewhere. The
    > > > version of draft that I am preparing to send to the IESG is here
    > > > https://tools.ietf.org/html/draft-ietf-tls-dtls-connection-id-05
    > > > <https://urldefense.proofpoint.com/v2/url?u=https-
    > > > 3A__tools.ietf.org_html_draft-2Dietf-2Dtls-2Ddtls-2Dconnection-
    > > > 2Did-2D05&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-
    > > > w&m=AFFRssmLkZuplUd1HVENEAI4HsfgSfv353Ivwszsxwc&s=6AXFN925MRdSclV8uo2RFkWtrlWPoTZdLcXbR6fzS8g&e=>.
    > > > The authors have requested early code point assignment and that
    > > > requires expert approval. ____
    > >
    > > > __ __
    > >
    > > > Thanks,____
    > >
    > > > __ __
    > >
    > > > Joe____
    > >
    > > > __ __
    > >
    > > > __ __
    > >
    > > > On Thu, May 23, 2019 at 8:09 AM Sabrina Tanamal via RT <iana-
    > > > [email-masked]> wrote:____
    > >
    > > >> Hi Joe,
    > > >>
    > > >> We've sent this request to the experts at [email-masked]
    > > >> on 8 May 2019, and we pinged them again yesterday. We haven't
    > > >> heard back from the experts regarding this request, could you let
    > > >> us know if you still don't see it in the archives?
    > > >>
    > > >> Thank you,
    > > >> Sabrina
    > > >>
    > > >> On Thu May 23 05:27:22 2019, [email-masked] wrote:
    > > >> > Hi Sabrina,
    > > >> >
    > > >> > Am I supposed to ask the experts for a review or will IANA
    > > >> > initiate
    > > >> > this?
    > > >> > I don't think I've seen a request for review appear in the
    > > >> > archives
    > > >> > for the
    > > >> > [email-masked] yet.
    > > >> >
    > > >> > Thanks,
    > > >> >
    > > >> > Joe
    > > >> >
    > > >> > On Wed, May 8, 2019 at 2:54 PM Sabrina Tanamal via RT <iana-
    > > >> > [email-masked]>
    > > >> > wrote:
    > > >> >
    > > >> > > Hi Joe,
    > > >> > >
    > > >> > > We can make the ContentType registration in Section 8 now, but
    > > >> > > we
    > > >> > > need to
    > > >> > > ask you how to fill in the "DTLS-OK" column.
    > > >> > >
    > > >> > > Because the registration procedure for the ExtensionType
    > > >> > > Values is
    > > >> > > Specification Required, we need to ask the designated experts
    > > >> > > to
    > > >> > > review and
    > > >> > > approve the ExtensionType Value registration before we can
    > > >> > > make an
    > > >> > > early
    > > >> > > allocation.
    > > >> > >
    > > >> > > Thanks,
    > > >> > >
    > > >> > > Sabrina Tanamal
    > > >> > > Senior IANA Services Specialist
    > > >> > >
    > > >> > > On Wed May 08 14:25:55 2019, [email-masked] wrote:
    > > >> > > > Hi Michelle,
    > > >> > > >
    > > >> > > > Yes, this is a request for both.
    > > >> > > >
    > > >> > > > Thanks,
    > > >> > > >
    > > >> > > > Joe
    > > >> > > >
    > > >> > > > On Wed, May 8, 2019 at 6:51 AM Michelle Cotton via RT <
    > > >> > > [email-masked]>
    > > >> > > > wrote:
    > > >> > > >
    > > >> > > > > Hello Joe,
    > > >> > > > >
    > > >> > > > > Apologies for the delay in my response. I hope you are
    > > >> > > > > doing
    > > >> > > > > well.
    > > >> > > > >
    > > >> > > > > Quick question for your request below. In the document
    > > >> > > > > there are
    > > >> > > > > 2
    > > >> > > > > requests for parameter registrations. Are you requesting
    > > >> > > > > early
    > > >> > > allocation
    > > >> > > > > for both?
    > > >> > > > >
    > > >> > > > > Thanks in advance.
    > > >> > > > >
    > > >> > > > > --Michelle
    > > >> > > > >
    > > >> > > > > On Tue Apr 23 04:51:06 2019, [email-masked] wrote:
    > > >> > > > > > Hi IANA,
    > > >> > > > > >
    > > >> > > > > > We have received a request for early code point
    > > >> > > > > > assignment for
    > > >> > > > > > draft-ietf-tls-dtls-connection-id-04. The chairs believe
    > > >> > > > > > that
    > > >> > > > > > the
    > > >> > > draft
    > > >> > > > > is
    > > >> > > > > > stable. Our AD, Ben also approves this early assignment.
    > > >> > > > > > Please
    > > >> > > let me
    > > >> > > > > > know if you need more information or have any questions.
    > > >> > > > > >
    > > >> > > > > > Thanks,
    > > >> > > > > >
    > > >> > > > > > Joe
    > > >> > > > > >
    > > >> > > > > > ---------- Forwarded message ---------
    > > >> > > > > > From: Benjamin Kaduk <[email-masked]>
    > > >> > > > > > Date: Fri, Apr 19, 2019 at 7:12 PM
    > > >> > > > > > Subject: Re: Early code-point assignment request for
    > > >> > > > > > draft-ietf-tls-dtls-connection-id
    > > >> > > > > > To: Joseph Salowey <[email-masked]>
    > > >> > > > > > Cc: tls-chairs <[email-masked]>, <tls-reg-
    > > >> > > > > > [email-masked]>
    > > >> > > > > >
    > > >> > > > > >
    > > >> > > > > > On Sun, Apr 14, 2019 at 10:32:00PM -0700, Joseph Salowey
    > > >> > > > > > wrote:
    > > >> > > > > > > Hi Ben,
    > > >> > > > > > >
    > > >> > > > > > > We have a request for early code point assignment
    > > >> > > > > > > for draft-ietf-tls-dtls-connection-id. We believe the
    > > >> > > > > > > draft
    > > >> > > > > > > is
    > > >> > > stable
    > > >> > > > > and
    > > >> > > > > > > no one has objected to the early code point
    > > >> > > > > > > announcement on
    > > >> > > > > > > the
    > > >> > > list.
    > > >> > > > > > >
    > > >> > > > > > > Let me know if you have any questions or need more
    > > >> > > > > > > information.
    > > >> > > > > >
    > > >> > > > > > I'm happy to see this go forward.
    > > >> > > > > > (You will send the actual request to IANA, not me,
    > > >> > > > > > right?)
    > > >> > > > > >
    > > >> > > > > > Thanks, and sorry for the slow response,
    > > >> > > > > >
    > > >> > > > > > Ben
    > > >> > > > >
    > > >> > > > >
    > > >> > >
    > > >> > > ____
    > >

---

From: Sean Turner <[email-masked]>
Date: Thu, 13 Jun 2019 11:16:47 -0400

I think we could do this by updating the IANA considerations section in draft-ietf-tls-dtls-connection-id.

spt

> On Jun 11, 2019, at 12:17, Salz, Rich <[email-masked]> wrote:
>

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 13 Jun 2019 16:19:04 +0000

That would work (for now) and seems the fastest path forward.

So we approve the assignment and a rev'd draft will contain the annotation Sean mentions.

On 6/13/19, 11:16 AM, "Sean Turner" <[email-masked]> wrote:

    spt

---

From: Sean Turner <[email-masked]>
Date: Sun, 16 Jun 2019 13:23:21 -0400

Okay that’ll work.  I’ll submit a PR that alters the IANA considerations section to include a table.

spt

> On Jun 13, 2019, at 12:19, Salz, Rich <[email-masked]> wrote:
>

---

From: Sean Turner <[email-masked]>
Date: Sun, 16 Jun 2019 13:47:42 -0400

So … it turns out there are two registry requests for this draft:

1) TLS ExtensionType Values: connection_id

I think we got a number assigned here, but we need a couple of tweaks in the IANA section (I will submit a PR):

a) Needs to request new column for DTLS-only
b) Needs to specify TLS1.3 Column value.  I beieive the value should be empty as this is only applicable to DTLS 1.2.  To amke this clear we should ask for a note.

2) TLS ContentType Registry: tls12_cid

We still a number assignment for this one.

spt

> On May 23, 2019, at 13:59, Nick Sullivan <[email-masked]> wrote:
> 
> This sounds good to me. However, there doesn't seem to be a way to indicate that this extension is for DTLS only and not TLS. I don't think that's an issue, but I'm interested to hear if anyone else has an objection.
> 
> I don’t recall seeing this until now.  Explicitly copying Yoav and Nick.
> 
>  
> 
> I’m one of three and I support this.   Does this work?
> 
>                 Value 53
> 
>                 TLS 1.3 –
> 
>                 Recommended Y
> 
>                 RFC TBD
> 
>  
> 
> From: Joseph Salowey <[email-masked]>
> Date: Thursday, May 23, 2019 at 12:23 PM
> To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
> Cc: Benjamin Kaduk <[email-masked]>, "[email-masked]" <[email-masked]>
> Subject: Re: [Tls-reg-review] [IANA #1141082] Fwd: Early code-point assignment request for draft-ietf-tls-dtls-connection-id
> 
>  
> 
> I haven't seen the messages appear in the tls-reg-review archives so I'm cc'ing them on this email to see if its stuck somewhere.   The version of draft that I am preparing to send to the IESG is here https://tools.ietf.org/html/draft-ietf-tls-dtls-connection-id-05.  The authors have requested early code point assignment and that requires expert approval.  
> 
>  
> 
> Thanks,
> 
>  
> 
> Joe
> 
>  
> 
>  
> 
> On Thu, May 23, 2019 at 8:09 AM Sabrina Tanamal via RT <[email-masked]> wrote:
> 
> Hi Joe, 
> 
> We've sent this request to the experts at [email-masked] on 8 May 2019, and we pinged them again yesterday. We haven't heard back from the experts regarding this request, could you let us know if you still don't see it in the archives? 
> 
> Thank you,
> Sabrina
> 
> > Am I supposed to ask the experts for a review or will IANA initiate
> > this?
> > I don't think I've seen a request for review appear in the archives
> > for the
> > > We can make the ContentType registration in Section 8 now, but we
> > > need to
> > > Because the registration procedure for the ExtensionType Values is
> > > Specification Required, we need to ask the designated experts to
> > > review and
> > > approve the ExtensionType Value registration before we can make an
> > > early
> > > allocation.
> > >
> > > Thanks,
> > >
> > > Sabrina Tanamal
> > > > > Apologies for the delay in my response.  I hope you are doing
> > > > > well.
> > > > >
> > > > > Quick question for your request below.  In the document there are
> > > > > 2
> > > > > requests for parameter registrations.  Are you requesting early
> > > allocation
> > > > > for both?
> > > > >
> > > > > Thanks in advance.
> > > > >
> > > > > --Michelle
> > > > >
> > > > > > We have received a request for  early code point assignment for
> > > > > > draft-ietf-tls-dtls-connection-id-04.  The chairs believe that
> > > > > > the
> > > draft
> > > > > is
> > > > > > Cc: tls-chairs <[email-masked]>, <[email-masked]>
> > > > > >
> > > > > >
> > > > > > On Sun, Apr 14, 2019 at 10:32:00PM -0700, Joseph Salowey wrote:
> > > > > > > Hi Ben,
> > > > > > >
> > > > > > > for draft-ietf-tls-dtls-connection-id.  We believe the draft
> > > > > > > is
> > > stable
> > > > > and
> > > > > > > no one has objected to the early code point announcement on
> > > > > > > the
> > > list.
> > > > > > >
> > > > > > (You will send the actual request to IANA, not me, right?)
> > > > > >

---

From: "Salz, Rich" <[email-masked]>
Date: Sun, 16 Jun 2019 20:45:31 +0000

So looking at the registry, it seems that
  25  tls1.2 connection id y
Makes sense.

On 6/16/19, 1:47 PM, "Sean Turner" <[email-masked]> wrote:

    

    
    
    spt

---

From: "Sabrina Tanamal via RT" <[email-masked]>
Date: Mon, 24 Jun 2019 22:54:19 +0000

Hi all, 

Does IANA need to make one or more assignments right now? We understand that we need approvals from at least two designated experts in order to proceed. 

Thanks,
Sabrina

On Sun Jun 16 20:46:16 2019, [email-masked] wrote:
> I think we got a number assigned here, but we need a couple of tweaks
> in the IANA section (I will submit a PR):
> 
> b) Needs to specify TLS1.3 Column value.  I beieive the value should
> be empty as this is only applicable to DTLS 1.2.  To amke this clear
> we should ask for a note.
> 
> > Nick.
> > To: "[email-masked]" <[email-masked]>, "tls-reg-
> > Subject: Re: [Tls-reg-review] [IANA #1141082] Fwd: Early code-point
> > assignment request for draft-ietf-tls-dtls-connection-id
> >
> >
> >
> > I haven't seen the messages appear in the tls-reg-review archives so
> > I'm cc'ing them on this email to see if its stuck somewhere.   The
> > https://tools.ietf.org/html/draft-ietf-tls-dtls-connection-id-05.
> > requires expert approval.
> >
> >
> >
> > Thanks,
> >
> >
> >
> > Joe
> >
> >
> >
> >
> >
> > [email-masked]> wrote:
> > We've sent this request to the experts at [email-masked] on
> > 8 May 2019, and we pinged them again yesterday. We haven't heard back
> > from the experts regarding this request, could you let us know if you
> > still don't see it in the archives?
> >
> > Thank you,
> > Sabrina
> >

---

From: Sean Turner <[email-masked]>
Date: Mon, 24 Jun 2019 21:49:34 -0400

An excellent question :). When we are done there will be two code points assigned for this draft.

spt

> On Jun 24, 2019, at 18:54, Sabrina Tanamal via RT <[email-masked]> wrote:
> 
> Hi all, 
>

---

From: Sean Turner <[email-masked]>
Date: Wed, 26 Jun 2019 12:56:25 -0400

Yoav or Nick,

If we need two approvals, can one of your confirm these assignments:

Registry: TLS ExtensionType Values
Value: 53
Extension Name: connection_id

Registry: TLS ContentType Registry
Value: 25
Extension Name: tls12_cid

Thanks!

spt

> On Jun 24, 2019, at 21:49, Sean Turner <[email-masked]> wrote:
>

---

From: Yoav Nir <[email-masked]>
Date: Wed, 26 Jun 2019 23:19:35 +0300

Sorry. Sure.  

These seem fine.

Yoav

> On 26 Jun 2019, at 19:56, Sean Turner <[email-masked]> wrote:
> 
> Yoav or Nick,
>

---

From: Sean Turner <[email-masked]>
Date: Thu, 27 Jun 2019 23:24:26 -0400

Amanda,

I think we’re good to go?

spt

> On Jun 26, 2019, at 16:19, Yoav Nir <[email-masked]> wrote:
> 
> Sorry. Sure.  
> 
> These seem fine.
> 
> Yoav
>

---

From: "Sabrina Tanamal via RT" <[email-masked]>
Date: Fri, 28 Jun 2019 16:17:52 +0000

Hi Sean, 

Before we proceed with the assignments, can you confirm that these fields are filled out correctly? 

TLS 1.3: - 
Recommended: Y

Description: tls12_cid
DTLS-OK: Y

Thanks,
Sabrina

On Fri Jun 28 03:24:48 2019, [email-masked] wrote:
> >>>> Does IANA need to make one or more assignments right now? We
> >>>> understand that we need approvals from at least two designated
> >>>> experts in order to proceed.
> >>>>
> >>>> Thanks,
> >>>> Sabrina
> >>>>
> >>>>>>>> Values
> >>>>>>>> make
> >>>>>>>> an
> >>>>>>>>>> there
> >>>>>>>>>> are