Subject: Re: [Tls-reg-review] [IANA #1141082] Early code-point assignment request for draft-ietf-tls-dtls-connection-id

From: Sean Turner <[email-masked]>
Date: Tue, 2 Jul 2019 18:07:25 -0400

These look correct to me.  Post away!

spt

> On Jun 28, 2019, at 12:17, Sabrina Tanamal via RT <[email-masked]> wrote:
> 
> Hi Sean, 
> 
> Before we proceed with the assignments, can you confirm that these fields are filled out correctly? 
> 
> Registry: TLS ExtensionType Values
> Value: 53
> Extension Name: connection_id
> TLS 1.3: - 
> Recommended: Y
> 
> Registry: TLS ContentType Registry
> Value: 25
> Description: tls12_cid
> DTLS-OK: Y
> 
> Thanks,
> Sabrina
> 
> On Fri Jun 28 03:24:48 2019, [email-masked] wrote:
>> Amanda,
>> 
>> I think we’re good to go?
>> 
>> spt
>> 
>>> On Jun 26, 2019, at 16:19, Yoav Nir <[email-masked]> wrote:
>>> 
>>> Sorry. Sure.
>>> 
>>> These seem fine.
>>> 
>>> Yoav
>>> 
>>>> On 26 Jun 2019, at 19:56, Sean Turner <[email-masked]> wrote:
>>>> 
>>>> Yoav or Nick,
>>>> 
>>>> If we need two approvals, can one of your confirm these assignments:
>>>> 
>>>> Registry: TLS ExtensionType Values
>>>> Value: 53
>>>> Extension Name: connection_id
>>>> 
>>>> Registry: TLS ContentType Registry
>>>> Value: 25
>>>> Extension Name: tls12_cid
>>>> 
>>>> Thanks!
>>>> 
>>>> spt
>>>> 
>>>>> On Jun 24, 2019, at 21:49, Sean Turner <[email-masked]> wrote:
>>>>> 
>>>>> An excellent question :). When we are done there will be two code
>>>>> points assigned for this draft.
>>>>> 
>>>>> spt
>>>>> 
>>>>>> On Jun 24, 2019, at 18:54, Sabrina Tanamal via RT <iana-
>>>>>> [email-masked]> wrote:
>>>>>> 
>>>>>> Hi all,
>>>>>> 
>>>>>> Does IANA need to make one or more assignments right now? We
>>>>>> understand that we need approvals from at least two designated
>>>>>> experts in order to proceed.
>>>>>> 
>>>>>> Thanks,
>>>>>> Sabrina
>>>>>> 
>>>>>> On Sun Jun 16 20:46:16 2019, [email-masked] wrote:
>>>>>>> So looking at the registry, it seems that
>>>>>>> 25  tls1.2 connection id y
>>>>>>> Makes sense.
>>>>>>> 
>>>>>>> 
>>>>>>> 
>>>>>>> On 6/16/19, 1:47 PM, "Sean Turner" <[email-masked]> wrote:
>>>>>>> 
>>>>>>> So … it turns out there are two registry requests for this draft:
>>>>>>> 
>>>>>>> 1) TLS ExtensionType Values: connection_id
>>>>>>> 
>>>>>>> I think we got a number assigned here, but we need a couple of
>>>>>>> tweaks
>>>>>>> in the IANA section (I will submit a PR):
>>>>>>> 
>>>>>>> a) Needs to request new column for DTLS-only
>>>>>>> b) Needs to specify TLS1.3 Column value.  I beieive the value
>>>>>>> should
>>>>>>> be empty as this is only applicable to DTLS 1.2.  To amke this
>>>>>>> clear
>>>>>>> we should ask for a note.
>>>>>>> 
>>>>>>> 2) TLS ContentType Registry: tls12_cid
>>>>>>> 
>>>>>>> We still a number assignment for this one.
>>>>>>> 
>>>>>>> spt
>>>>>>> 
>>>>>>>> On May 23, 2019, at 13:59, Nick Sullivan <[email-masked]>
>>>>>>>> wrote:
>>>>>>>> 
>>>>>>>> This sounds good to me. However, there doesn't seem to be a way
>>>>>>>> to
>>>>>>>> indicate that this extension is for DTLS only and not TLS. I
>>>>>>>> don't
>>>>>>>> think that's an issue, but I'm interested to hear if anyone else
>>>>>>>> has
>>>>>>>> an objection.
>>>>>>>> 
>>>>>>>> On Thu, May 23, 2019 at 9:35 AM Salz, Rich <[email-masked]>
>>>>>>>> wrote:
>>>>>>>> 
>>>>>>>> 
>>>>>>>> I don’t recall seeing this until now.  Explicitly copying Yoav
>>>>>>>> and
>>>>>>>> Nick.
>>>>>>>> 
>>>>>>>> 
>>>>>>>> 
>>>>>>>> I’m one of three and I support this.   Does this work?
>>>>>>>> 
>>>>>>>> Value 53
>>>>>>>> 
>>>>>>>> TLS 1.3 –
>>>>>>>> 
>>>>>>>> Recommended Y
>>>>>>>> 
>>>>>>>> RFC TBD
>>>>>>>> 
>>>>>>>> 
>>>>>>>> 
>>>>>>>> From: Joseph Salowey <[email-masked]>
>>>>>>>> Date: Thursday, May 23, 2019 at 12:23 PM
>>>>>>>> To: "[email-masked]" <[email-masked]>, "tls-reg-
>>>>>>>> [email-masked]" <[email-masked]>
>>>>>>>> Cc: Benjamin Kaduk <[email-masked]>, "[email-masked]" <tls-
>>>>>>>> [email-masked]>
>>>>>>>> Subject: Re: [Tls-reg-review] [IANA #1141082] Fwd: Early code-
>>>>>>>> point
>>>>>>>> assignment request for draft-ietf-tls-dtls-connection-id
>>>>>>>> 
>>>>>>>> 
>>>>>>>> 
>>>>>>>> I haven't seen the messages appear in the tls-reg-review
>>>>>>>> archives so
>>>>>>>> I'm cc'ing them on this email to see if its stuck somewhere.
>>>>>>>> The
>>>>>>>> version of draft that I am preparing to send to the IESG is here
>>>>>>>> https://tools.ietf.org/html/draft-ietf-tls-dtls-connection-id-
>>>>>>>> 05.
>>>>>>>> The authors have requested early code point assignment and that
>>>>>>>> requires expert approval.
>>>>>>>> 
>>>>>>>> 
>>>>>>>> 
>>>>>>>> Thanks,
>>>>>>>> 
>>>>>>>> 
>>>>>>>> 
>>>>>>>> Joe
>>>>>>>> 
>>>>>>>> 
>>>>>>>> 
>>>>>>>> 
>>>>>>>> 
>>>>>>>> On Thu, May 23, 2019 at 8:09 AM Sabrina Tanamal via RT <iana-
>>>>>>>> [email-masked]> wrote:
>>>>>>>> 
>>>>>>>> Hi Joe,
>>>>>>>> 
>>>>>>>> We've sent this request to the experts at tls-reg-
>>>>>>>> [email-masked] on
>>>>>>>> 8 May 2019, and we pinged them again yesterday. We haven't heard
>>>>>>>> back
>>>>>>>> from the experts regarding this request, could you let us know
>>>>>>>> if you
>>>>>>>> still don't see it in the archives?
>>>>>>>> 
>>>>>>>> Thank you,
>>>>>>>> Sabrina
>>>>>>>> 
>>>>>>>> On Thu May 23 05:27:22 2019, [email-masked] wrote:
>>>>>>>>> Hi Sabrina,
>>>>>>>>> 
>>>>>>>>> Am I supposed to ask the experts for a review or will IANA
>>>>>>>>> initiate
>>>>>>>>> this?
>>>>>>>>> I don't think I've seen a request for review appear in the
>>>>>>>>> archives
>>>>>>>>> for the
>>>>>>>>> [email-masked] yet.
>>>>>>>>> 
>>>>>>>>> Thanks,
>>>>>>>>> 
>>>>>>>>> Joe
>>>>>>>>> 
>>>>>>>>> On Wed, May 8, 2019 at 2:54 PM Sabrina Tanamal via RT <iana-
>>>>>>>>> [email-masked]>
>>>>>>>>> wrote:
>>>>>>>>> 
>>>>>>>>>> Hi Joe,
>>>>>>>>>> 
>>>>>>>>>> We can make the ContentType registration in Section 8 now, but
>>>>>>>>>> we
>>>>>>>>>> need to
>>>>>>>>>> ask you how to fill in the "DTLS-OK" column.
>>>>>>>>>> 
>>>>>>>>>> Because the registration procedure for the ExtensionType
>>>>>>>>>> Values
>>>>>>>>>> is
>>>>>>>>>> Specification Required, we need to ask the designated experts
>>>>>>>>>> to
>>>>>>>>>> review and
>>>>>>>>>> approve the ExtensionType Value registration before we can
>>>>>>>>>> make
>>>>>>>>>> an
>>>>>>>>>> early
>>>>>>>>>> allocation.
>>>>>>>>>> 
>>>>>>>>>> Thanks,
>>>>>>>>>> 
>>>>>>>>>> Sabrina Tanamal
>>>>>>>>>> Senior IANA Services Specialist
>>>>>>>>>> 
>>>>>>>>>> On Wed May 08 14:25:55 2019, [email-masked] wrote:
>>>>>>>>>>> Hi Michelle,
>>>>>>>>>>> 
>>>>>>>>>>> Yes, this is a request for both.
>>>>>>>>>>> 
>>>>>>>>>>> Thanks,
>>>>>>>>>>> 
>>>>>>>>>>> Joe
>>>>>>>>>>> 
>>>>>>>>>>> On Wed, May 8, 2019 at 6:51 AM Michelle Cotton via RT <
>>>>>>>>>> [email-masked]>
>>>>>>>>>>> wrote:
>>>>>>>>>>> 
>>>>>>>>>>>> Hello Joe,
>>>>>>>>>>>> 
>>>>>>>>>>>> Apologies for the delay in my response.  I hope you are
>>>>>>>>>>>> doing
>>>>>>>>>>>> well.
>>>>>>>>>>>> 
>>>>>>>>>>>> Quick question for your request below.  In the document
>>>>>>>>>>>> there
>>>>>>>>>>>> are
>>>>>>>>>>>> 2
>>>>>>>>>>>> requests for parameter registrations.  Are you requesting
>>>>>>>>>>>> early
>>>>>>>>>> allocation
>>>>>>>>>>>> for both?
>>>>>>>>>>>> 
>>>>>>>>>>>> Thanks in advance.
>>>>>>>>>>>> 
>>>>>>>>>>>> --Michelle
>>>>>>>>>>>> 
>>>>>>>>>>>> On Tue Apr 23 04:51:06 2019, [email-masked] wrote:
>>>>>>>>>>>>> Hi IANA,
>>>>>>>>>>>>> 
>>>>>>>>>>>>> We have received a request for  early code point assignment
>>>>>>>>>>>>> for
>>>>>>>>>>>>> draft-ietf-tls-dtls-connection-id-04.  The chairs believe
>>>>>>>>>>>>> that
>>>>>>>>>>>>> the
>>>>>>>>>> draft
>>>>>>>>>>>> is
>>>>>>>>>>>>> stable.  Our AD, Ben also approves this early assignment.
>>>>>>>>>>>>> Please
>>>>>>>>>> let me
>>>>>>>>>>>>> know if you need more information or have any questions.
>>>>>>>>>>>>> 
>>>>>>>>>>>>> Thanks,
>>>>>>>>>>>>> 
>>>>>>>>>>>>> Joe
>>>>>>>>>>>>> 
>>>>>>>>>>>>> ---------- Forwarded message ---------
>>>>>>>>>>>>> From: Benjamin Kaduk <[email-masked]>
>>>>>>>>>>>>> Date: Fri, Apr 19, 2019 at 7:12 PM
>>>>>>>>>>>>> Subject: Re: Early code-point assignment request for
>>>>>>>>>>>>> draft-ietf-tls-dtls-connection-id
>>>>>>>>>>>>> To: Joseph Salowey <[email-masked]>
>>>>>>>>>>>>> Cc: tls-chairs <[email-masked]>, <tls-reg-
>>>>>>>>>>>>> [email-masked]>
>>>>>>>>>>>>> 
>>>>>>>>>>>>> 
>>>>>>>>>>>>> On Sun, Apr 14, 2019 at 10:32:00PM -0700, Joseph Salowey
>>>>>>>>>>>>> wrote:
>>>>>>>>>>>>>> Hi Ben,
>>>>>>>>>>>>>> 
>>>>>>>>>>>>>> We have a request for early code point assignment
>>>>>>>>>>>>>> for draft-ietf-tls-dtls-connection-id.  We believe the
>>>>>>>>>>>>>> draft
>>>>>>>>>>>>>> is
>>>>>>>>>> stable
>>>>>>>>>>>> and
>>>>>>>>>>>>>> no one has objected to the early code point announcement
>>>>>>>>>>>>>> on
>>>>>>>>>>>>>> the
>>>>>>>>>> list.
>>>>>>>>>>>>>> 
>>>>>>>>>>>>>> Let me know if you have any questions or need more
>>>>>>>>>>>>>> information.
>>>>>>>>>>>>> 
>>>>>>>>>>>>> I'm happy to see this go forward.
>>>>>>>>>>>>> (You will send the actual request to IANA, not me, right?)
>>>>>>>>>>>>> 
>>>>>>>>>>>>> Thanks, and sorry for the slow response,
>>>>>>>>>>>>> 
>>>>>>>>>>>>> Ben
>>>>>>>>>>>> 
>>>>>>>>>>>> 
>>>>>>>>>> 
>>>>>>>>>> 
>>>>>>>> 
>>>>>>> 
>>>>>>> 
>>>>>>> 
>>>>>> 
>>>>> 
>>>> 
>>> 
>

---

From: "Sabrina Tanamal via RT" <[email-masked]>
Date: Tue, 02 Jul 2019 23:46:18 +0000

Hi all, 

The early allocations for this document are complete. 

We've made the following early allocation at https://www.iana.org/assignments/tls-extensiontype-values: 

53	connection_id (TEMPORARY - registered 2019-07-02, expires 2020-07-02)	-	Y	[draft-ietf-tls-dtls-connection-id]

We've made the following early allocation at https://www.iana.org/assignments/tls-parameters:

25	tls12_cid (TEMPORARY - registered 2019-07-02, expires 2020-07-02)	Y	[draft-ietf-tls-dtls-connection-id]

If this document hasn't been approved for publication by July 2020, we'll contact you about approving a one-year renewal. Any further renewals would require IESG approval.

Best regards,

Sabrina Tanamal