Subject: [Tls-reg-review] Request to Register Value in TLS ALPN Registry

From: Roland Shoemaker <[email-masked]>
Date: Tue, 1 Oct 2019 10:46:52 -0700

Hello,

I’m writing to request registration of a TLS ALPN Protocol ID. This ID is to be used as part of a new ACME validation method and is specified in draft-acme-tls-alpn Section 6.2 (https://datatracker.ietf.org/doc/draft-ietf-acme-tls-alpn/). This document is currently in IESG Evaluation so we expect it to actually be published.

Let me know if you have any questions and I’ll be happy to help.
Roland

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 1 Oct 2019 18:18:18 +0000

Is the "-tls" suffix needed?  I prefer it were removed (nobody else has it, and the TLS is implied :)

On 10/1/19, 1:47 PM, "Roland Shoemaker" <[email-masked]> wrote:

    Hello,

    Let me know if you have any questions and I’ll be happy to help.
    Roland
    _______________________________________________
    tls-reg-review mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/tls-reg-review

---

From: Roland Shoemaker <[email-masked]>
Date: Tue, 1 Oct 2019 11:21:27 -0700

Heh, it’s not necessarily required and you are correct it is rather redundant. That said the protocol ID is already in use so making changes to the sequence now will be somewhat painful. That said if you are dead set against it, we can likely handle the change.

> On Oct 1, 2019, at 11:18 AM, Salz, Rich <[email-masked]> wrote:
>

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 1 Oct 2019 18:34:56 +0000

I don't like disturbing production :)  Let's see what Yoav and/or Nick say.

On 10/1/19, 2:21 PM, "Roland Shoemaker" <[email-masked]> wrote:

---

From: Roland Shoemaker <[email-masked]>
Date: Mon, 21 Oct 2019 13:14:24 -0700

Hey all,

Just wanted to check in and see if there had been any out-of-band discussion of this or if there is anything I could do to help inform deliberations.

Thanks,
Roland

> On Oct 1, 2019, at 11:34 AM, Salz, Rich <[email-masked]> wrote:
>

---

From: Nick Sullivan <[email-masked]>
Date: Tue, 22 Oct 2019 11:08:46 -0700

This looks fine to me.

On Mon, Oct 21, 2019 at 1:14 PM Roland Shoemaker <[email-masked]>
wrote:

> Hey all,
>
> Just wanted to check in and see if there had been any out-of-band
> discussion of this or if there is anything I could do to help inform
> deliberations.
>
> Thanks,
> Roland
>
> >    Heh, it’s not necessarily required and you are correct it is rather
> redundant. That said the protocol ID is already in use so making changes to
> the sequence now will be somewhat painful. That said if you are dead set
> against it, we can likely handle the change.
> >
> >>   I’m writing to request registration of a TLS ALPN Protocol ID. This
> ID is to be used as part of a new ACME validation method and is specified
> in draft-acme-tls-alpn Section 6.2 (
> https://datatracker.ietf.org/doc/draft-ietf-acme-tls-alpn/). This
> document is currently in IESG Evaluation so we expect it to actually be
> published.
> >>