Subject: Re: [Tls-reg-review] [IANA #1147787] Request to register value in TLS extension registry for Delegated Credentials (draft-ietf-tls-subcerts)

From: Nick Sullivan <[email-masked]>
Date: Thu, 30 Jan 2020 15:18:54 -0800

Update: TLS chairs have asked for early assignment. I'm conflicted out from
voting on this one since it's my draft, but I'd be happy to see the
assignment happen sooner so I can submit a WGLC version of the draft
including the extension point.

Nick

On Tue, Sep 3, 2019 at 5:08 PM Nick Sullivan <[email-masked]> wrote:

> Hi Amanda,
>
> Let's wait to make the assignment.
>
> Nick
>
> On Tue, Sep 3, 2019 at 5:05 PM Amanda Baber via RT <
> [email-masked]> wrote:
>
>> Hi Nick,
>>
>> Resending this question: can you confirm that we should make this
>> assignment now, rather than before the document is approved?
>>
>> If so, should we use value(s) 33-34, 36-40, 54, or 57-65279?
>>
>> thanks,
>> Amanda
>>
>> On Fri Aug 02 19:50:20 2019, [email-masked] wrote:
>> > I am fine with whatever number Nick wants :)
>> >
>> > On 8/2/19, 2:19 PM, "Amanda Baber via RT" <[email-masked]>
>> > wrote:
>> >
>> > Hi all,
>> >
>> > If you'd like us to make the assignment now, should we take the value
>> > from range 32-34, 36-40, or 54-65279?
>> >
>> > thanks,
>> > Amanda
>> >
>> > On Wed Jul 24 13:37:01 2019, amanda.baber wrote:
>> > > Hi all,
>> > >
>> > > Should we make this registration now or wait for the document to be
>> > > approved?
>> > >
>> > > thanks,
>> > > Amanda
>> > >
>> > > On Tue Jul 23 22:03:58 2019, [email-masked] wrote:
>> > > > Hello,
>> > > >
>> > > > I'd like to request a review from the other two members of the
>> > > > review
>> > > > panel
>> > > > for a new extension value for a draft that is currently adopted by
>> > > > the TLS
>> > > > working group: Delegated Credentials for TLS.
>> > > >
>> > > > https://datatracker.ietf.org/doc/draft-ietf-tls-subcerts/
>> > > >
>> > > > CH, CR, CT, Recommended: Y
>> > > >
>> > > > Nick
>> >
>> >
>> >
>>
>

---

From: "Amanda Baber via RT" <[email-masked]>
Date: Thu, 30 Jan 2020 23:25:09 +0000

Rich, Yoav,

This has already been approved; can you confirm that we can make the assignment now?

thanks,
Amanda

---

From: "Salz, Rich" <[email-masked]>
Date: Fri, 31 Jan 2020 00:48:24 +0000

Yes.

On 1/30/20, 6:25 PM, "Amanda Baber via RT" <[email-masked]> wrote:

    Rich, Yoav,

    thanks,
    Amanda

---

From: "Salz, Rich" <[email-masked]>
Date: Fri, 31 Jan 2020 00:49:00 +0000

Take it from 33-34

From: Nick Sullivan <[email-masked]>
Date: Thursday, January 30, 2020 at 6:19 PM
To: "[email-masked]" <[email-masked]>, Yoav Nir <[email-masked]>, Rich Salz <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [IANA #1147787] Request to register value in TLS extension registry for Delegated Credentials (draft-ietf-tls-subcerts)

Update: TLS chairs have asked for early assignment. I'm conflicted out from voting on this one since it's my draft, but I'd be happy to see the assignment happen sooner so I can submit a WGLC version of the draft including the extension point.

Nick

On Tue, Sep 3, 2019 at 5:08 PM Nick Sullivan <[email-masked]<mailto:[email-masked]>> wrote:
Hi Amanda,

Nick

On Tue, Sep 3, 2019 at 5:05 PM Amanda Baber via RT <[email-masked]<mailto:[email-masked]>> wrote:
Hi Nick,

Resending this question: can you confirm that we should make this assignment now, rather than before the document is approved?

thanks,
Amanda

On Fri Aug 02 19:50:20 2019, [email-masked]<mailto:[email-masked]> wrote:
> On 8/2/19, 2:19 PM, "Amanda Baber via RT" <[email-masked]<mailto:[email-masked]>>
> wrote:
>
> Hi all,
>
> > On Tue Jul 23 22:03:58 2019, [email-masked]<mailto:[email-masked]> wrote:
> > > Hello,
> > >
> > > https://datatracker.ietf.org/doc/draft-ietf-tls-subcerts/<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dtls-2Dsubcerts_&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=LSAwIsPnSudREqNMuymCzxZy60QSc-Ts2YCkGlq9qoo&s=_o-4jNfScvyAmxtBK40e8BCBDb_2RGKWmtLQ8Xcwttw&e=>
> > >

---

From: Yoav Nir <[email-masked]>
Date: Fri, 31 Jan 2020 06:49:46 +0200

Agree

> On 31 Jan 2020, at 2:49, Salz, Rich <[email-masked]> wrote:
> 
> Take it from 33-34
>  
> On Tue, Sep 3, 2019 at 5:08 PM Nick Sullivan <[email-masked] <mailto:[email-masked]>> wrote:
>> Hi Amanda, 
>>  
>> On Tue, Sep 3, 2019 at 5:05 PM Amanda Baber via RT <[email-masked] <mailto:[email-masked]>> wrote:
>>> Hi Nick,
>>> 
>>> On Fri Aug 02 19:50:20 2019, [email-masked] <mailto:[email-masked]> wrote:
>>> > On 8/2/19, 2:19 PM, "Amanda Baber via RT" <[email-masked] <mailto:[email-masked]>>
>>> > wrote:
>>> > 
>>> > Hi all,
>>> > 
>>> > > On Tue Jul 23 22:03:58 2019, [email-masked] <mailto:[email-masked]> wrote:
>>> > > > Hello,
>>> > > >
>>> > > > https://datatracker.ietf.org/doc/draft-ietf-tls-subcerts/ <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dtls-2Dsubcerts_&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=LSAwIsPnSudREqNMuymCzxZy60QSc-Ts2YCkGlq9qoo&s=_o-4jNfScvyAmxtBK40e8BCBDb_2RGKWmtLQ8Xcwttw&e=>
>>> > > >

---

From: "Amanda Baber via RT" <[email-masked]>
Date: Fri, 31 Jan 2020 18:53:57 +0000

Hi Nick, Rich, Yoav,

We've added the following entry to the TLS ExtensionType Values registry:

Value: 34
Extension Name: delegated_credentials
TLS 1.3: CH, CR, CT
Recommended: Y
Reference: [draft-ietf-tls-subcerts]

Please see
https://www.iana.org/assignments/tls-extensiontype-values

Best regards,

Amanda Baber
Lead IANA Services Specialist