Subject: Re: [Tls-reg-review] Request to register ALPN ID for DNS-over-TLS

From: "Reed, Jon" <[email-masked]>
Date: Tue, 14 Jan 2020 18:10:46 +0000

Hi folks, 

Just following up on this, since I think the 3 week review period has expired.   Can we move forward with publishing this registration, or is there some periodic publication cycle?

Thanks, 

Jon

> On Dec 16, 2019, at 2:26 PM, Nick Sullivan <[email-masked]> wrote:
> 
> Fine with me.
> 
> On Mon, Dec 16, 2019 at 9:16 AM Yoav Nir <[email-masked] <mailto:[email-masked]>> wrote:
> I think it’s fine.  Nick?
> 
>> On 16 Dec 2019, at 17:52, Salz, Rich <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Yoav and Nick,
>>  
>> Could you guys approve this?  Since it came from Akamai, I want to abstain.
>>  
>> From: "Reed, Jon" <[email-masked] <mailto:[email-masked]>>
>> Date: Monday, December 16, 2019 at 7:56 AM
>> To: "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
>> Subject: [Tls-reg-review] Request to register ALPN ID for DNS-over-TLS
>>  
>> Hi, 
>>  
>> I'd like to request registration of an ALPN ID for DNS-over-TLS (RFC 7858).   The ID will be used, by prior out-of-band mutual agreement, in cases where DNS-over-TLS is used over a non-standard-part (e.g. 443).    The identification sequence will be: 0x64 0x6F 0x74 ("dot").
>>  
>> Rich Salz suggested I survey the dprive working group before doing this, and I have done so[1].  There appears to be support for this, including from one of the authors of RFC 7858, provided it's used by prior agreement on non-standard ports, and not required as part of normal use on port 853.
>>  
>> Please let me know if you have more questions or need more information.
>>  
>> Thanks, 
>>  
>> Jon
>>  
>> [1] https://mailarchive.ietf.org/arch/msg/dns-privacy/iZ2rDIhFB2ZWsGC3PcdBVLGa8Do <https://urldefense.proofpoint.com/v2/url?u=https-3A__mailarchive.ietf.org_arch_msg_dns-2Dprivacy_iZ2rDIhFB2ZWsGC3PcdBVLGa8Do&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=_xTHEvws93UZ7jl9jhO7Pg&m=i070mdRi8IojDr3bkm87Qo7LqaTJVtz-8A6t_AJuNj0&s=xt3xOwMGNirCRCDokBxZVoL0ybgcuYq6giiuUtVOp7w&e=>
>>  
>> --
>> Jon Reed
>> [email-masked] <mailto:[email-masked]>
>> Nameservers Service Performance
>> Akamai Technologies
>

---

From: Yoav Nir <[email-masked]>
Date: Tue, 14 Jan 2020 20:36:22 +0200

Sorry, I missed that IANA was not on this thread.

IANA: since I and Nick approve, we can proceed with this.

Yoav

> On 14 Jan 2020, at 20:10, Reed, Jon <[email-masked]> wrote:
> 
> Hi folks, 
> 
>> On Dec 16, 2019, at 2:26 PM, Nick Sullivan <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Fine with me.
>>

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 14 Jan 2020 19:45:13 +0000

There’s no publishing cycle; the IANA folks just update the doc and publish to the website.

The approvals probably got drowned out during the holiday festivities.  You got approved, so you treat the assignment as official; the website/registry will catch up soon.

From: "Reed, Jon" <[email-masked]>
Date: Tuesday, January 14, 2020 at 1:10 PM
To: Nick Sullivan <[email-masked]>
Cc: Yoav Nir <[email-masked]>, Rich Salz <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Tls-reg-review] Request to register ALPN ID for DNS-over-TLS

Hi folks,

Thanks,

Jon

On Dec 16, 2019, at 2:26 PM, Nick Sullivan <[email-masked]<mailto:[email-masked]>> wrote:

Fine with me.

On Mon, Dec 16, 2019 at 9:16 AM Yoav Nir <[email-masked]<mailto:[email-masked]>> wrote:
I think it’s fine.  Nick?

On 16 Dec 2019, at 17:52, Salz, Rich <[email-masked]<mailto:[email-masked]>> wrote:

Yoav and Nick,

From: "Reed, Jon" <[email-masked]<mailto:[email-masked]>>
Date: Monday, December 16, 2019 at 7:56 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [Tls-reg-review] Request to register ALPN ID for DNS-over-TLS

Hi,

Thanks,

Jon

[1] https://mailarchive.ietf.org/arch/msg/dns-privacy/iZ2rDIhFB2ZWsGC3PcdBVLGa8Do<https://urldefense.proofpoint.com/v2/url?u=https-3A__mailarchive.ietf.org_arch_msg_dns-2Dprivacy_iZ2rDIhFB2ZWsGC3PcdBVLGa8Do&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=_xTHEvws93UZ7jl9jhO7Pg&m=i070mdRi8IojDr3bkm87Qo7LqaTJVtz-8A6t_AJuNj0&s=xt3xOwMGNirCRCDokBxZVoL0ybgcuYq6giiuUtVOp7w&e=>

--
Jon Reed
[email-masked]<mailto:[email-masked]>
Nameservers Service Performance
Akamai Technologies

---

From: "Reed, Jon" <[email-masked]>
Date: Tue, 14 Jan 2020 20:05:05 +0000

Cool, thanks.

> On Jan 14, 2020, at 2:45 PM, Salz, Rich <[email-masked]> wrote:
>

---

From: "Sabrina Tanamal via RT" <[email-masked]>
Date: Wed, 15 Jan 2020 18:59:34 +0000

Hi Jon, 

How should we fill in the "Reference" field for DNS-over-TLS? 

Thanks,

Sabrina Tanamal
Senior IANA Services Specialist

On Tue Jan 14 18:36:49 2020, [email-masked] wrote:
> > Just following up on this, since I think the 3 week review period has
> > expired.   Can we move forward with publishing this registration, or
> > is there some periodic publication cycle?
> >
> > Thanks,
> >
> > Jon
> >
> >>> To: "[email-masked] <mailto:[email-masked]>"
> >>> <[email-masked] <mailto:[email-masked]>>
> >>> I'd like to request registration of an ALPN ID for DNS-over-TLS
> >>> (RFC 7858).   The ID will be used, by prior out-of-band mutual
> >>> agreement, in cases where DNS-over-TLS is used over a non-standard-
> >>> part (e.g. 443).    The identification sequence will be: 0x64 0x6F
> >>> 0x74 ("dot").
> >>>
> >>> Rich Salz suggested I survey the dprive working group before doing
> >>> this, and I have done so[1].  There appears to be support for this,
> >>> including from one of the authors of RFC 7858, provided it's used
> >>> by prior agreement on non-standard ports, and not required as part
> >>> of normal use on port 853.
> >>>
> >>> [1] https://mailarchive.ietf.org/arch/msg/dns-
> >>> privacy/iZ2rDIhFB2ZWsGC3PcdBVLGa8Do
> >>> <https://urldefense.proofpoint.com/v2/url?u=https-
> >>> 3A__mailarchive.ietf.org_arch_msg_dns-
> >>> 2Dprivacy_iZ2rDIhFB2ZWsGC3PcdBVLGa8Do&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=_xTHEvws93UZ7jl9jhO7Pg&m=i070mdRi8IojDr3bkm87Qo7LqaTJVtz-
> >>> 8A6t_AJuNj0&s=xt3xOwMGNirCRCDokBxZVoL0ybgcuYq6giiuUtVOp7w&e=>
> >>>
> >>> --
> >>> Jon Reed

---

From: "Reed, Jon" <[email-masked]>
Date: Wed, 15 Jan 2020 19:13:52 +0000

Hi Sabrina,

I think you can just link to RFC 7858 (https://tools.ietf.org/html/rfc7858 <https://tools.ietf.org/html/rfc7858>).

Thanks, 

Jon

> On Jan 15, 2020, at 1:59 PM, Sabrina Tanamal via RT <[email-masked]> wrote:
> 
> Hi Jon, 
> 
> On Tue Jan 14 18:36:49 2020, [email-masked] <mailto:[email-masked]> wrote:
>>>> On Dec 16, 2019, at 2:26 PM, Nick Sullivan <[email-masked]
>>>> <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
>>>> 
>>>> Fine with me.
>>>> 
>>>> On Mon, Dec 16, 2019 at 9:16 AM Yoav Nir <[email-masked] <mailto:[email-masked]>
>>>> <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
>>>> I think it’s fine.  Nick?
>>>> 
>>>>> On 16 Dec 2019, at 17:52, Salz, Rich <[email-masked] <mailto:[email-masked]>
>>>>> <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
>>>>> 
>>>>> Yoav and Nick,
>>>>> 
>>>>> From: "Reed, Jon" <[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>>
>>>>> To: "[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>"
>>>>> <[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>>
>>>>> [1] https://mailarchive.ietf.org/arch/msg/dns- <https://mailarchive.ietf.org/arch/msg/dns->
>>>>> <https://urldefense.proofpoint.com/v2/url?u=https- <https://urldefense.proofpoint.com/v2/url?u=https->
>>>>> [email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>

---

From: "Sabrina Tanamal via RT" <[email-masked]>
Date: Wed, 15 Jan 2020 19:29:10 +0000

Dear Yoav, Rich, and Nick,

Can one of you confirm that we can list RFC 7858 in the "Reference" field for DNS-over-TLS?

Thanks,
Sabrina

On Wed Jan 15 19:14:33 2020, [email-masked] wrote:
> Hi Sabrina,
> 
> I think you can just link to RFC 7858
> (https://tools.ietf.org/html/rfc7858
> <https://tools.ietf.org/html/rfc7858>).
> 
> Thanks,
> 
> Jon
> 
> >>>>> Could you guys approve this?  Since it came from Akamai, I want
> >>>>> to
> >>>>> abstain.
> >>>>>
> >>>>> From: "Reed, Jon" <[email-masked] <mailto:[email-masked]>
> >>>>> <mailto:[email-masked] <mailto:[email-masked]>>>
> >>>>> To: "[email-masked] <mailto:[email-masked]>
> >>>>> <mailto:[email-masked] <mailto:tls-reg-
> >>>>> [email-masked]>>"
> >>>>> <[email-masked] <mailto:[email-masked]>
> >>>>> <mailto:[email-masked] <mailto:tls-reg-
> >>>>> [email-masked]>>>
> >>>>> Subject: [Tls-reg-review] Request to register ALPN ID for DNS-
> >>>>> over-
> >>>>> TLS
> >>>>>
> >>>>> Hi,
> >>>>>
> >>>>> <https://mailarchive.ietf.org/arch/msg/dns->
> >>>>> <https://urldefense.proofpoint.com/v2/url?u=https->
> >>>>> <mailto:[email-masked] <mailto:[email-masked]>>

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 15 Jan 2020 19:43:40 +0000

confirmed

On 1/15/20, 2:29 PM, "Sabrina Tanamal via RT" <[email-masked]> wrote:

    
    Thanks,
    Sabrina

---

From: "Sabrina Tanamal via RT" <[email-masked]>
Date: Wed, 15 Jan 2020 22:31:50 +0000

Hi Jon, 

We've added the following entry to the Application-Layer Protocol Negotiation (ALPN) Protocol IDs registry: 

Protocol: DNS-over-TLS
Identification Sequence: 0x64 0x6F 0x74 ("dot")
Reference: [RFC7858]

Please see
https://www.iana.org/assignments/tls-extensiontype-values

Best regards, 

Sabrina Tanamal

---

From: "Reed, Jon" <[email-masked]>
Date: Wed, 15 Jan 2020 22:45:36 +0000

Great, thanks!

> On Jan 15, 2020, at 5:31 PM, Sabrina Tanamal via RT <[email-masked]> wrote:
> 
> Hi Jon, 
> 
> https://www.iana.org/assignments/tls-extensiontype-values <https://www.iana.org/assignments/tls-extensiontype-values>
> 
> Best regards, 
> 
> Sabrina Tanamal
> On Wed Jan 15 19:14:33 2020, [email-masked] <mailto:[email-masked]> wrote:
>> Hi Sabrina,
>> 
>> (https://tools.ietf.org/html/rfc7858 <https://tools.ietf.org/html/rfc7858>
>> <https://tools.ietf.org/html/rfc7858 <https://tools.ietf.org/html/rfc7858>>).
>> 
>> Thanks,
>> 
>> Jon
>> 
>>> On Tue Jan 14 18:36:49 2020, [email-masked]
>>> <mailto:[email-masked] <mailto:[email-masked]>> wrote:
>>>>> On 14 Jan 2020, at 20:10, Reed, Jon <[email-masked] <mailto:[email-masked]>> wrote:
>>>>> 
>>>>> Hi folks,
>>>>> 
>>>>>> On Dec 16, 2019, at 2:26 PM, Nick Sullivan <[email-masked] <mailto:[email-masked]>
>>>>>> <mailto:[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>>> wrote:
>>>>>> 
>>>>>> Fine with me.
>>>>>> 
>>>>>> <mailto:[email-masked] <mailto:[email-masked]>>
>>>>>> <mailto:[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>>> wrote:
>>>>>> I think it’s fine.  Nick?
>>>>>> 
>>>>>>> <mailto:[email-masked] <mailto:[email-masked]>>
>>>>>>> <mailto:[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>>> wrote:
>>>>>>> 
>>>>>>> Yoav and Nick,
>>>>>>> 
>>>>>>> From: "Reed, Jon" <[email-masked] <mailto:[email-masked]><mailto:[email-masked] <mailto:[email-masked]>>
>>>>>>> <mailto:[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>>>
>>>>>>> To: "[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>
>>>>>>> <mailto:[email-masked] <mailto:[email-masked]> <mailto:tls-reg-
>>>>>>> [email-masked] <mailto:[email-masked]>>>"
>>>>>>> <[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>
>>>>>>> <mailto:[email-masked] <mailto:[email-masked]> <mailto:tls-reg-
>>>>>>> [email-masked] <mailto:[email-masked]>>>>
>>>>>>> <https://mailarchive.ietf.org/arch/msg/dns- <https://mailarchive.ietf.org/arch/msg/dns->>
>>>>>>> <https://urldefense.proofpoint.com/v2/url?u=https- <https://urldefense.proofpoint.com/v2/url?u=https->>
>>>>>>> <mailto:[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>>