Subject: [Tls-reg-review] Request to register TLS EXPORTER-BBF-Dying-Gasp label

From: William Lupton <[email-masked]>
Date: Wed, 11 Mar 2020 10:04:50 +0000

Hello,

The Broadband Forum (BBF) would like to register the following TLS Exporter
label:

   - Value: EXPORTER-BBF-Dying-Gasp
   - DTLS-OK: N (because the intended use exports material from TLS, not
   DTLS)
   - Recommended: N
   - Reference: TR-301 Issue 2 Amendment 1 (will be published at
   https://www.broadband-forum.org/technical/download/TR-301_Issue-2_Amendment-1.pdf
   )

The referenced document is currently in the final stages of review but has
not been published yet (the latest published version can be downloaded from
https://www.broadband-forum.org/technical/download/TR-301_Issue-2_Corrigendum-1.pdf;
the new version is due for publication in June 2020). One of the things
delaying publication is that we want to register this label prior to
publication!

We could supply the latest version of the document on request (but would
need reassurance that it will be available only to the expert reviewers).
However, maybe it will be sufficient to quote the relevant section from the
current draft?

Please see below:
--------

8.1.1.2 Dying Gasp Message Format Version 1
...

R-265 The DPU and PMA MUST export the key used to generate the HMAC from
the TLS connection supporting the current DPU/PMA NETCONF connection, using
the keying material export function as defined in RFC 5705 with the
following input parameters:

   - Label = “EXPORTER-BBF-Dying-Gasp”
   - Application context = “Dying-Gasp”
   - Length = 32

--------

Thanks,
William Lupton
Broadband Forum Software Architect

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 11 Mar 2020 15:39:31 +0000

Approved.

(Dying gasp.  Funny.  I am reminded of the old DCE system where “ping” responses where “indy” – I’m not dead yet. :)

From: William Lupton <[email-masked]>
Date: Wednesday, March 11, 2020 at 6:06 AM
To: "[email-masked]" <[email-masked]>
Cc: Timothy Carey <[email-masked]>, "Verbueken, Herman (Nokia - BE/Antwerp)" <[email-masked]>, "Van Der Putten, Frank (Nokia - BE/Antwerp)" <[email-masked]>, "Kozarev, Aleksandra" <[email-masked]>
Subject: [Tls-reg-review] Request to register TLS EXPORTER-BBF-Dying-Gasp label

Hello,

The Broadband Forum (BBF) would like to register the following TLS Exporter label:

  *   Value: EXPORTER-BBF-Dying-Gasp
  *   DTLS-OK: N (because the intended use exports material from TLS, not DTLS)
  *   Recommended: N
  *   Reference: TR-301 Issue 2 Amendment 1 (will be published at https://www.broadband-forum.org/technical/download/TR-301_Issue-2_Amendment-1.pdf<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.broadband-2Dforum.org_technical_download_TR-2D301-5FIssue-2D2-5FAmendment-2D1.pdf&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=9pL6elL5Igaw5L4RJ04fH_m3CxT0FCzeH9hgSa0RgMk&s=JqqO2kOcaBTIm_Yd4Ce6g6ZVdNJ-wpGRyddmLGGT7ns&e=>)
The referenced document is currently in the final stages of review but has not been published yet (the latest published version can be downloaded from https://www.broadband-forum.org/technical/download/TR-301_Issue-2_Corrigendum-1.pdf<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.broadband-2Dforum.org_technical_download_TR-2D301-5FIssue-2D2-5FCorrigendum-2D1.pdf&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=9pL6elL5Igaw5L4RJ04fH_m3CxT0FCzeH9hgSa0RgMk&s=9oJWCv67HmYee0EU0D6QOEYzqoR9dNFYY2AVzHDDs9E&e=>; the new version is due for publication in June 2020). One of the things delaying publication is that we want to register this label prior to publication!

We could supply the latest version of the document on request (but would need reassurance that it will be available only to the expert reviewers). However, maybe it will be sufficient to quote the relevant section from the current draft?

Please see below:
--------

R-265 The DPU and PMA MUST export the key used to generate the HMAC from the TLS connection supporting the current DPU/PMA NETCONF connection, using the keying material export function as defined in RFC 5705 with the following input parameters:

  *   Label = “EXPORTER-BBF-Dying-Gasp”
  *   Application context = “Dying-Gasp”
  *   Length = 32
--------

Thanks,
William Lupton

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 11 Mar 2020 17:30:03 +0000

Adding IANA so they’ll see this :)

From: Rich Salz <[email-masked]>
Date: Wednesday, March 11, 2020 at 11:39 AM
To: William Lupton <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: Timothy Carey <[email-masked]>, "Verbueken, Herman (Nokia - BE/Antwerp)" <[email-masked]>, "Van Der Putten, Frank (Nokia - BE/Antwerp)" <[email-masked]>, "Kozarev, Aleksandra" <[email-masked]>
Subject: Re: [Tls-reg-review] Request to register TLS EXPORTER-BBF-Dying-Gasp label

Approved.

Hello,

Please see below:
--------

Thanks,
William Lupton

---

From: "Amanda Baber via RT" <[email-masked]>
Date: Wed, 11 Mar 2020 17:43:29 +0000

Hi Yoav, Nick,

Can one of you also approve this request?

thanks,

Amanda Baber
Lead IANA Services Specialist

On Wed Mar 11 17:30:46 2020, [email-masked] wrote:
> To: William Lupton <[email-masked]>, "tls-reg-
> [email-masked]" <[email-masked]>
> Cc: Timothy Carey <[email-masked]>, "Verbueken, Herman (Nokia
> - BE/Antwerp)" <[email-masked]>, "Van Der Putten, Frank
> (Nokia - BE/Antwerp)" <[email-masked]>, "Kozarev,
> Aleksandra" <[email-masked]>
> (Dying gasp.  Funny.  I am reminded of the old DCE system where “ping”
> responses where “indy” – I’m not dead yet. :)
> 
> Cc: Timothy Carey <[email-masked]>, "Verbueken, Herman (Nokia
> - BE/Antwerp)" <[email-masked]>, "Van Der Putten, Frank
> (Nokia - BE/Antwerp)" <[email-masked]>, "Kozarev,
> Aleksandra" <[email-masked]>
> *   Reference: TR-301 Issue 2 Amendment 1 (will be published at
> https://www.broadband-forum.org/technical/download/TR-301_Issue-
> 2_Amendment-1.pdf<https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.broadband-2Dforum.org_technical_download_TR-2D301-5FIssue-2D2-
> 5FAmendment-
> 2D1.pdf&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-
> w&m=9pL6elL5Igaw5L4RJ04fH_m3CxT0FCzeH9hgSa0RgMk&s=JqqO2kOcaBTIm_Yd4Ce6g6ZVdNJ-
> wpGRyddmLGGT7ns&e=>)
> The referenced document is currently in the final stages of review but
> has not been published yet (the latest published version can be
> downloaded from https://www.broadband-forum.org/technical/download/TR-
> 301_Issue-2_Corrigendum-
> 1.pdf<https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.broadband-2Dforum.org_technical_download_TR-2D301-5FIssue-2D2-
> 5FCorrigendum-
> 2D1.pdf&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-
> w&m=9pL6elL5Igaw5L4RJ04fH_m3CxT0FCzeH9hgSa0RgMk&s=9oJWCv67HmYee0EU0D6QOEYzqoR9dNFYY2AVzHDDs9E&e=>;
> the new version is due for publication in June 2020). One of the
> things delaying publication is that we want to register this label
> prior to publication!
> 
> We could supply the latest version of the document on request (but
> would need reassurance that it will be available only to the expert
> reviewers). However, maybe it will be sufficient to quote the relevant
> section from the current draft?
> 
> Please see below:
> --------
> 
> R-265 The DPU and PMA MUST export the key used to generate the HMAC
> from the TLS connection supporting the current DPU/PMA NETCONF
> connection, using the keying material export function as defined in
> RFC 5705 with the following input parameters:
>

---

From: Yoav Nir <[email-masked]>
Date: Wed, 11 Mar 2020 19:47:14 +0200

Sure.

Yoav

> On 11 Mar 2020, at 19:43, Amanda Baber via RT <[email-masked]> wrote:
> 
> Hi Yoav, Nick,
> 
> _______________________________________________
> tls-reg-review mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls-reg-review

---

From: "Amanda Baber via RT" <[email-masked]>
Date: Wed, 11 Mar 2020 20:55:55 +0000

Hi all,

The following entry has been added to the TLS Exporter Labels registry:

Value: EXPORTER-BBF-Dying-Gasp
DTLS-OK: N
Recommended: N
Reference: TR-301 Issue 2 Amendment 1 <https://www.broadband-forum.org/technical/download/TR-301_Issue-2_Corrigendum-1.pdf>

Please let us know when the URL can be updated.

Best regards,

Amanda Baber