Subject: Re: [Tls-reg-review] Question about the TLS cipher suite registry

From: "Salz, Rich" <[email-masked]>
Date: Thu, 5 Mar 2020 02:36:54 +0000

Using the tls-reg-review mail alias so that IANA sees this.

I don’t know how the csv or XHTML files are maintained.  Looking at https://www.iana.org/assignments/tls-parameters/tls-parameters.xhtml#tls-parameters-4, I see this:
        0xFA,0x00-C9

Unassigned

Is that the range you mean?

From: Adam Foltzer <[email-masked]>
Date: Wednesday, March 4, 2020 at 6:58 PM
To: Mark Nottingham <[email-masked]>
Cc: Yoav Nir <[email-masked]>, Rich Salz <[email-masked]>, Nick Sullivan <[email-masked]>
Subject: Re: Question about the TLS cipher suite registry

Thanks, Mark!

Hi everyone,

I was working with the CSV of the cipher suite registry (https://www.iana.org/assignments/tls-parameters/tls-parameters-4.csv<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.iana.org_assignments_tls-2Dparameters_tls-2Dparameters-2D4.csv&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=dpcjQ2TVZH5UswHqtHodv3nFO9QiYT-91jWev8I1OVg&s=oWGFQzXXyHhRfUn7HdSz_GjjhhIOk39VO5CKXJ1mG38&e=>) and noticed that the value range 0xFA,0xCA-F9 is missing both from the CSV and the XHTML table. As far as I can tell, this is the only missing range.

I wanted to bring this to your attention, as well as ask whether it'd be correct to treat these values as Unassigned for the time being.

Thank you!

Adam

On Wed, Mar 4, 2020 at 3:38 PM Mark Nottingham <[email-masked]<mailto:[email-masked]>> wrote:
Gents,

One of my colleagues, Adam (CC:ed) has a question about the TLS cipher suite registry.

Over to you, Adam!

Cheers,

--
Mark Nottingham   https://www.mnot.net/<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.mnot.net_&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=dpcjQ2TVZH5UswHqtHodv3nFO9QiYT-91jWev8I1OVg&s=SHPGhce_r4u8Yg6qhyG0JBGpU5AMG_DFPiqHswyyPGc&e=>

--
Adam C. Foltzer | Senior Software Engineer
fastly.com<https://urldefense.proofpoint.com/v2/url?u=http-3A__fastly.com&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=dpcjQ2TVZH5UswHqtHodv3nFO9QiYT-91jWev8I1OVg&s=VXi94D-mlhEn_pyKojowqvnn4s_EtDXYYUZAnU6uKwI&e=> | @fastly

---

From: Yoav Nir <[email-masked]>
Date: Thu, 5 Mar 2020 06:13:19 +0200

No, the range immediately (not) after that:  0xFA,0xCA -F9

0xFA,0x00-C9	Unassigned			
0xFA,0xFA	Reserved	Y	N	[RFC8701 <https://www.iana.org/go/rfc8701>]
0xFA,0xFB-FF	Unassigned
It’s not assigned to anything, but it seems to be missing.

> On 5 Mar 2020, at 4:36, Salz, Rich <rsalz=[email-masked]> wrote:
> 
> I don’t know how the csv or XHTML files are maintained.  Looking athttps://www.iana.org/assignments/tls-parameters/tls-parameters.xhtml#tls-parameters-4 <https://www.iana.org/assignments/tls-parameters/tls-parameters.xhtml#tls-parameters-4>, I see this:
>         0xFA,0x00-C9
> Unassigned
>  
> I was working with the CSV of the cipher suite registry (https://www.iana.org/assignments/tls-parameters/tls-parameters-4.csv <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.iana.org_assignments_tls-2Dparameters_tls-2Dparameters-2D4.csv&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=dpcjQ2TVZH5UswHqtHodv3nFO9QiYT-91jWev8I1OVg&s=oWGFQzXXyHhRfUn7HdSz_GjjhhIOk39VO5CKXJ1mG38&e=>) and noticed that the value range 0xFA,0xCA-F9 is missing both from the CSV and the XHTML table. As far as I can tell, this is the only missing range.
>  
> On Wed, Mar 4, 2020 at 3:38 PM Mark Nottingham <[email-masked] <mailto:[email-masked]>> wrote:
>> Gents,
>> 
>> Mark Nottingham   https://www.mnot.net/ <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.mnot.net_&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=dpcjQ2TVZH5UswHqtHodv3nFO9QiYT-91jWev8I1OVg&s=SHPGhce_r4u8Yg6qhyG0JBGpU5AMG_DFPiqHswyyPGc&e=>
> 
>  
> -- 
> fastly.com <https://urldefense.proofpoint.com/v2/url?u=http-3A__fastly.com&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=dpcjQ2TVZH5UswHqtHodv3nFO9QiYT-91jWev8I1OVg&s=VXi94D-mlhEn_pyKojowqvnn4s_EtDXYYUZAnU6uKwI&e=> | @fastly
> _______________________________________________
> tls-reg-review mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/tls-reg-review <https://www.ietf.org/mailman/listinfo/tls-reg-review>

---

From: Adam Foltzer <[email-masked]>
Date: Wed, 4 Mar 2020 18:54:47 -0800

Thank you!

> I don’t know how the csv or XHTML files are maintained.  Looking at
> https://www.iana.org/assignments/tls-parameters/tls-parameters.xhtml#tls-parameters-4,
> I see this:
>
>         0xFA,0x00-C9
>
> Unassigned
>

This is the range that immediately precedes the missing range. The
following line is "0xFA,0xFA Reserved", so nothing between 0xFA,0xCA and
0xFA,0xF9 is defined. I initially caught this because the exhaustiveness
check on a Rust pattern match noted that the values didn't cover the whole
range of inputs, so I doubt it's a sorting error either.

Thanks for taking a look!

On Wed, Mar 4, 2020 at 6:37 PM Salz, Rich <[email-masked]> wrote:

> I don’t know how the csv or XHTML files are maintained.  Looking at
> https://www.iana.org/assignments/tls-parameters/tls-parameters.xhtml#tls-parameters-4,
> I see this:
>
>         0xFA,0x00-C9
>
> Unassigned
>
>
>
> *From: *Adam Foltzer <[email-masked]>
> *Date: *Wednesday, March 4, 2020 at 6:58 PM
> *To: *Mark Nottingham <[email-masked]>
> *Cc: *Yoav Nir <[email-masked]>, Rich Salz <[email-masked]>, Nick
> Sullivan <[email-masked]>
> *Subject: *Re: Question about the TLS cipher suite registry
>
>
>
> Thanks, Mark!
>
>
>
> Hi everyone,
>
>
>
> I was working with the CSV of the cipher suite registry (
> https://www.iana.org/assignments/tls-parameters/tls-parameters-4.csv
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.iana.org_assignments_tls-2Dparameters_tls-2Dparameters-2D4.csv&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=dpcjQ2TVZH5UswHqtHodv3nFO9QiYT-91jWev8I1OVg&s=oWGFQzXXyHhRfUn7HdSz_GjjhhIOk39VO5CKXJ1mG38&e=>)
> and noticed that the value range 0xFA,0xCA-F9 is missing both from the CSV
> and the XHTML table. As far as I can tell, this is the only missing range.
>
>
>
> I wanted to bring this to your attention, as well as ask whether it'd be
> correct to treat these values as Unassigned for the time being.
>
>
>
> Thank you!
>
>
>
> Adam
>
>
>
> On Wed, Mar 4, 2020 at 3:38 PM Mark Nottingham <[email-masked]> wrote:
>
> Gents,
>
> Mark Nottingham   https://www.mnot.net/
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.mnot.net_&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=dpcjQ2TVZH5UswHqtHodv3nFO9QiYT-91jWev8I1OVg&s=SHPGhce_r4u8Yg6qhyG0JBGpU5AMG_DFPiqHswyyPGc&e=>
>
>
>
>
> --
>
> fastly.com
> <https://urldefense.proofpoint.com/v2/url?u=http-3A__fastly.com&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=dpcjQ2TVZH5UswHqtHodv3nFO9QiYT-91jWev8I1OVg&s=VXi94D-mlhEn_pyKojowqvnn4s_EtDXYYUZAnU6uKwI&e=>
> | @fastly
>

fastly.com | @fastly