Subject: Re: [Tls-reg-review] Request to register 3 values in TLS ExtensionType Values registry

From: "Salz, Rich" <[email-masked]>
Date: Thu, 11 Jun 2020 14:49:06 +0000

Is there any chance you could send something that “looks” like rows in the tables you want to update?  It would avoid another (sic) round-trip of you correcting what we suggest :)

From: Miguel Angel Reina Ortega <[email-masked]>
Date: Thursday, June 11, 2020 at 4:00 AM
To: "[email-masked]" <[email-masked]>
Subject: [Tls-reg-review] Request to register 3 values in TLS ExtensionType Values registry

Dear TLS ExtensionType Values Registry Experts,

ETSI TC CYBER has developed a Technical Specification TS 103 523-2 "Transport Layer Middlebox Security Protocol (TLMSP)" specifying a protocol to enable secure transparent communication sessions between network endpoints with one or more middleboxes between these endpoints, using data encryption and integrity protection, as well as authentication of the identity of the endpoints and the identity of any middlebox present. The Middlebox Security Protocol builds on TLS 1.2.

ETSI TC CYBER is about to approve the final draft TS 103 523-2 for publication and then requests the registration of 3 TLS ExtensionType Values as defined in the final draft TS 103 523-2 available at https://docbox.etsi.org/CYBER/CYBER/Open/Latest_Drafts/CYBER-0027-2v020-TLMSP-Transport-Layer-Middlebox-Security-Protocol.pdf<https://urldefense.proofpoint.com/v2/url?u=https-3A__docbox.etsi.org_CYBER_CYBER_Open_Latest-5FDrafts_CYBER-2D0027-2D2v020-2DTLMSP-2DTransport-2DLayer-2DMiddlebox-2DSecurity-2DProtocol.pdf&d=DwMGaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=oQMPGfGgrdxWDPibuv7xZmkvs4QwZHGAlXPJhbmALhg&s=7BhZBrWwPqaCtDCObi_1lvKoXHZTiYCo_c2qzo6vQhE&e=>.

The 3 extensions are defined in the following clauses:

     * clause 4.3.5 extension named TLSMP

     * clause C.2.3 extensions named TLMSP_proxying and TLMSP_delegate

     * IANA considerations in annex I

Please, note that we will be able to provide the final URL of the published TS only after its publication.

Best regards.

-----------------------------------------------------------------------------------------------------------------
Miguel Angel Reina Ortega – Testing Expert
Centre for Testing and Interoperability (CTI)
ETSI ● www.etsi.org<https://urldefense.proofpoint.com/v2/url?u=http-3A__www.etsi.org_&d=DwMGaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=oQMPGfGgrdxWDPibuv7xZmkvs4QwZHGAlXPJhbmALhg&s=Dhex2E0fq6_9W63p8udrlFYOi5gTkDRSlvGzf6w4CVU&e=> ● [email-masked]<mailto:[email-masked]>
Phone: +33 (0)4 92 94 43 49 ● Mobile: +33 (0)6 76 73 60 99

This email may contain confidential information and is intended for
the use of the addressee only. Any unauthorized use may be unlawful.
If you receive this email by mistake, please advise the sender
immediately by using the reply facility in your email software.
Thank you for your co-operation.

---

From: Miguel Angel Reina Ortega <[email-masked]>
Date: Fri, 12 Jun 2020 06:16:46 +0000

Dear Rich,

Please, find the rows here below:

Value
Extension name
TLS 1.3
Recommended
Reference
??
TLMSP
-
N
[ETSI TS 103 523-2<https://docbox.etsi.org/CYBER/CYBER/Open/Latest_Drafts/CYBER-0027-2v020-TLMSP-Transport-Layer-Middlebox-Security-Protocol.pdf>]
??
TLMSP_proxying
-
N
[ETSI TS 103 523-2<https://docbox.etsi.org/CYBER/CYBER/Open/Latest_Drafts/CYBER-0027-2v020-TLMSP-Transport-Layer-Middlebox-Security-Protocol.pdf>]
??
TLMSP_delegate
-
N
[ETSI TS 103 523-2<https://docbox.etsi.org/CYBER/CYBER/Open/Latest_Drafts/CYBER-0027-2v020-TLMSP-Transport-Layer-Middlebox-Security-Protocol.pdf>]

Should you need anything else, do not hesitate to contact me.

Best regards.

ETSI ● www.etsi.org<http://www.etsi.org/> ● [email-masked]<mailto:[email-masked]>

From: Salz, Rich <[email-masked]>
Sent: 11 June 2020 16:49
To: Miguel Angel Reina Ortega <[email-masked]>; [email-masked]
Subject: Re: [Tls-reg-review] Request to register 3 values in TLS ExtensionType Values registry

From: Miguel Angel Reina Ortega <[email-masked]<mailto:[email-masked]>>
Date: Thursday, June 11, 2020 at 4:00 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [Tls-reg-review] Request to register 3 values in TLS ExtensionType Values registry

Best regards.

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 15 Jun 2020 13:13:13 +0000

Thanks.

Why aren’t the handshake types being registered?

From: Miguel Angel Reina Ortega <[email-masked]>
Date: Friday, June 12, 2020 at 2:16 AM
To: Rich Salz <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: [Tls-reg-review] Request to register 3 values in TLS ExtensionType Values registry

Dear Rich,

Value

Extension name

TLS 1.3

Recommended

Reference

??

TLMSP

-

N

[ETSI TS 103 523-2<https://urldefense.proofpoint.com/v2/url?u=https-3A__docbox.etsi.org_CYBER_CYBER_Open_Latest-5FDrafts_CYBER-2D0027-2D2v020-2DTLMSP-2DTransport-2DLayer-2DMiddlebox-2DSecurity-2DProtocol.pdf&d=DwMGaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=rlqIJ6xS9MsILcMtR4u-PndR3hWt4w1dkF1miThFZFo&s=DQjWi7QXn-xYLa2Zagw4v9HOrsExXdWdodqgmfpIJzo&e=>]

??

TLMSP_proxying

-

N

[ETSI TS 103 523-2<https://urldefense.proofpoint.com/v2/url?u=https-3A__docbox.etsi.org_CYBER_CYBER_Open_Latest-5FDrafts_CYBER-2D0027-2D2v020-2DTLMSP-2DTransport-2DLayer-2DMiddlebox-2DSecurity-2DProtocol.pdf&d=DwMGaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=rlqIJ6xS9MsILcMtR4u-PndR3hWt4w1dkF1miThFZFo&s=DQjWi7QXn-xYLa2Zagw4v9HOrsExXdWdodqgmfpIJzo&e=>]

??

TLMSP_delegate

-

N

[ETSI TS 103 523-2<https://urldefense.proofpoint.com/v2/url?u=https-3A__docbox.etsi.org_CYBER_CYBER_Open_Latest-5FDrafts_CYBER-2D0027-2D2v020-2DTLMSP-2DTransport-2DLayer-2DMiddlebox-2DSecurity-2DProtocol.pdf&d=DwMGaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=rlqIJ6xS9MsILcMtR4u-PndR3hWt4w1dkF1miThFZFo&s=DQjWi7QXn-xYLa2Zagw4v9HOrsExXdWdodqgmfpIJzo&e=>]

Best regards.

ETSI ● www.etsi.org<https://urldefense.proofpoint.com/v2/url?u=http-3A__www.etsi.org_&d=DwMGaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=rlqIJ6xS9MsILcMtR4u-PndR3hWt4w1dkF1miThFZFo&s=_9HjObRgTIbV2uPyDS5KEA3Na0EvdTp-Kotp99rc09A&e=> ● [email-masked]<mailto:[email-masked]>

Best regards.

---

From: Miguel Angel Reina Ortega <[email-masked]>
Date: Tue, 16 Jun 2020 07:53:55 +0000

Dear Rich,

I am consulting other delegates for that.

In the meanwhile, would that be required for this registration? Or can that be done later?

Best regards.

Sent: 15 June 2020 15:13

Thanks.

From: Miguel Angel Reina Ortega <[email-masked]<mailto:[email-masked]>>
Date: Friday, June 12, 2020 at 2:16 AM
To: Rich Salz <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Tls-reg-review] Request to register 3 values in TLS ExtensionType Values registry

Dear Rich,

Value
Extension name
TLS 1.3
Recommended
Reference
??
TLMSP
-
N

Best regards.

From: Salz, Rich <[email-masked]<mailto:[email-masked]>>
Sent: 11 June 2020 16:49
To: Miguel Angel Reina Ortega <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Tls-reg-review] Request to register 3 values in TLS ExtensionType Values registry

Best regards.

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 16 Jun 2020 13:38:02 +0000

I don’t think it’s  blocker for this registration, but it would be good to know asap.

From: Miguel Angel Reina Ortega <[email-masked]>
Date: Tuesday, June 16, 2020 at 3:54 AM
To: Rich Salz <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: [Tls-reg-review] Request to register 3 values in TLS ExtensionType Values registry

Dear Rich,

Best regards.

ETSI ● www.etsi.org<https://urldefense.proofpoint.com/v2/url?u=http-3A__www.etsi.org_&d=DwMGaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=gOxY_QjEJNNy5mQlRE5uBaClzTZtDLv1ncWDmAdQKbQ&s=WNFNucit6VWzmyMxbVktFwpPW2T-bce45qtXqTvQ6O0&e=> ● [email-masked]<mailto:[email-masked]>

Thanks.

Dear Rich,

Value

Extension name

TLS 1.3

Recommended

Reference

??

TLMSP

-

N

??

TLMSP_proxying

-

N

??

TLMSP_delegate

-

N

Best regards.

Best regards.

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 22 Jun 2020 15:28:44 +0000

Any update?

We would like to know all the registrations for a document and process them at once.

Dear Rich,

Best regards.

Thanks.

Dear Rich,

Value

Extension name

TLS 1.3

Recommended

Reference

??

TLMSP

-

N

??

TLMSP_proxying

-

N

??

TLMSP_delegate

-

N

Best regards.

Best regards.

---

From: Miguel Angel Reina Ortega <[email-masked]>
Date: Tue, 23 Jun 2020 14:40:11 +0000

Dear Rich,

Yes, I have just got some update. It seems that the intention was to not register the handshake types for the time being. I guess that needs more discussion within the group.

So, as you said that’s not a blocking issue, I think we could proceed with the registration of the ExtensionType values only for now.

Best regards.

Sent: 22 June 2020 17:29

Any update?

Dear Rich,

Best regards.

Thanks.

Dear Rich,

Value
Extension name
TLS 1.3
Recommended
Reference
??
TLMSP
-
N

Best regards.

Best regards.

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 23 Jun 2020 18:35:47 +0000

Okay.

From: Miguel Angel Reina Ortega <[email-masked]>
Date: Tuesday, June 23, 2020 at 10:40 AM
To: Rich Salz <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Tls-reg-review] Request to register 3 values in TLS ExtensionType Values registry

Dear Rich,

Best regards.

ETSI ● www.etsi.org<https://urldefense.proofpoint.com/v2/url?u=http-3A__www.etsi.org_&d=DwMGaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=upI9O7t15M5PlogSPmnxfgpDu5dvrS7bntJuh_Pq_K4&s=NU-_h7Dwa2zgw4-x1VIYWiH057klWCjwQqKms0Kp4tk&e=> ● [email-masked]<mailto:[email-masked]>

Any update?

Dear Rich,

Best regards.

Thanks.

Dear Rich,

Value

Extension name

TLS 1.3

Recommended

Reference

??

TLMSP

-

N

??

TLMSP_proxying

-

N

??

TLMSP_delegate

-

N

Best regards.

Best regards.

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 23 Jun 2020 18:40:52 +0000

So folks, you okay with this?

How about values 36 37 38 ?

Dear Rich,

Value

Extension name

TLS 1.3

Recommended

Reference

??

TLMSP

-

N

??

TLMSP_proxying

-

N

??

TLMSP_delegate

-

N

Best regards.

Best regards.

---

From: Yoav Nir <[email-masked]>
Date: Tue, 23 Jun 2020 22:30:22 +0300

WFM

> On 23 Jun 2020, at 21:40, Salz, Rich <rsalz=[email-masked]> wrote:
> 
> From: Miguel Angel Reina Ortega <[email-masked] <mailto:[email-masked]>>
> To: Rich Salz <[email-masked] <mailto:[email-masked]>>, "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
> [ETSI TS 103 523-2 <https://urldefense.proofpoint.com/v2/url?u=https-3A__docbox.etsi.org_CYBER_CYBER_Open_Latest-5FDrafts_CYBER-2D0027-2D2v020-2DTLMSP-2DTransport-2DLayer-2DMiddlebox-2DSecurity-2DProtocol.pdf&d=DwMGaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=rlqIJ6xS9MsILcMtR4u-PndR3hWt4w1dkF1miThFZFo&s=DQjWi7QXn-xYLa2Zagw4v9HOrsExXdWdodqgmfpIJzo&e=>]
> ??
> TLMSP_proxying
> -
> N
> [ETSI TS 103 523-2 <https://urldefense.proofpoint.com/v2/url?u=https-3A__docbox.etsi.org_CYBER_CYBER_Open_Latest-5FDrafts_CYBER-2D0027-2D2v020-2DTLMSP-2DTransport-2DLayer-2DMiddlebox-2DSecurity-2DProtocol.pdf&d=DwMGaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=rlqIJ6xS9MsILcMtR4u-PndR3hWt4w1dkF1miThFZFo&s=DQjWi7QXn-xYLa2Zagw4v9HOrsExXdWdodqgmfpIJzo&e=>]
> ??
> TLMSP_delegate
> -
> N
> [ETSI TS 103 523-2 <https://urldefense.proofpoint.com/v2/url?u=https-3A__docbox.etsi.org_CYBER_CYBER_Open_Latest-5FDrafts_CYBER-2D0027-2D2v020-2DTLMSP-2DTransport-2DLayer-2DMiddlebox-2DSecurity-2DProtocol.pdf&d=DwMGaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=rlqIJ6xS9MsILcMtR4u-PndR3hWt4w1dkF1miThFZFo&s=DQjWi7QXn-xYLa2Zagw4v9HOrsExXdWdodqgmfpIJzo&e=>]
>  
>  
>  
>  
>  
> ETSI ● www.etsi.org <https://urldefense.proofpoint.com/v2/url?u=http-3A__www.etsi.org_&d=DwMGaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=rlqIJ6xS9MsILcMtR4u-PndR3hWt4w1dkF1miThFZFo&s=_9HjObRgTIbV2uPyDS5KEA3Na0EvdTp-Kotp99rc09A&e=> ● [email-masked] <mailto:[email-masked]>
> From: Salz, Rich <[email-masked] <mailto:[email-masked]>> 
> Sent: 11 June 2020 16:49
> To: Miguel Angel Reina Ortega <[email-masked] <mailto:[email-masked]>>; [email-masked] <mailto:[email-masked]>
> From: Miguel Angel Reina Ortega <[email-masked] <mailto:[email-masked]>>
> To: "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
> ETSI TC CYBER is about to approve the final draft TS 103 523-2 for publication and then requests the registration of 3 TLS ExtensionType Values as defined in the final draft TS 103 523-2 available athttps://docbox.etsi.org/CYBER/CYBER/Open/Latest_Drafts/CYBER-0027-2v020-TLMSP-Transport-Layer-Middlebox-Security-Protocol.pdf <https://urldefense.proofpoint.com/v2/url?u=https-3A__docbox.etsi.org_CYBER_CYBER_Open_Latest-5FDrafts_CYBER-2D0027-2D2v020-2DTLMSP-2DTransport-2DLayer-2DMiddlebox-2DSecurity-2DProtocol.pdf&d=DwMGaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=oQMPGfGgrdxWDPibuv7xZmkvs4QwZHGAlXPJhbmALhg&s=7BhZBrWwPqaCtDCObi_1lvKoXHZTiYCo_c2qzo6vQhE&e=>.
> ETSI ● www.etsi.org <https://urldefense.proofpoint.com/v2/url?u=http-3A__www.etsi.org_&d=DwMGaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=oQMPGfGgrdxWDPibuv7xZmkvs4QwZHGAlXPJhbmALhg&s=Dhex2E0fq6_9W63p8udrlFYOi5gTkDRSlvGzf6w4CVU&e=> ● [email-masked] <mailto:[email-masked]>
> _______________________________________________
> tls-reg-review mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls-reg-review

---

From: "Salz, Rich" <[email-masked]>
Date: Fri, 26 Jun 2020 20:24:05 +0000

+Amanda.

From: Yoav Nir <[email-masked]>
Date: Tuesday, June 23, 2020 at 3:30 PM
To: Rich Salz <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, Michelle Cotton <[email-masked]>
Subject: Re: [Tls-reg-review] Request to register 3 values in TLS ExtensionType Values registry

WFM

On 23 Jun 2020, at 21:40, Salz, Rich <rsalz=[email-masked]<mailto:rsalz=[email-masked]>> wrote:

Dear Rich,

Value

Extension name

TLS 1.3

Recommended

Reference

??

TLMSP

-

N

[ETSI TS 103 523-2<https://urldefense.proofpoint.com/v2/url?u=https-3A__docbox.etsi..org_CYBER_CYBER_Open_Latest-5FDrafts_CYBER-2D0027-2D2v020-2DTLMSP-2DTransport-2DLayer-2DMiddlebox-2DSecurity-2DProtocol.pdf&d=DwMGaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=rlqIJ6xS9MsILcMtR4u-PndR3hWt4w1dkF1miThFZFo&s=DQjWi7QXn-xYLa2Zagw4v9HOrsExXdWdodqgmfpIJzo&e=>]

??

TLMSP_proxying

-

N

[ETSI TS 103 523-2<https://urldefense.proofpoint.com/v2/url?u=https-3A__docbox.etsi..org_CYBER_CYBER_Open_Latest-5FDrafts_CYBER-2D0027-2D2v020-2DTLMSP-2DTransport-2DLayer-2DMiddlebox-2DSecurity-2DProtocol.pdf&d=DwMGaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=rlqIJ6xS9MsILcMtR4u-PndR3hWt4w1dkF1miThFZFo&s=DQjWi7QXn-xYLa2Zagw4v9HOrsExXdWdodqgmfpIJzo&e=>]

??

TLMSP_delegate

-

N

[ETSI TS 103 523-2<https://urldefense.proofpoint.com/v2/url?u=https-3A__docbox.etsi..org_CYBER_CYBER_Open_Latest-5FDrafts_CYBER-2D0027-2D2v020-2DTLMSP-2DTransport-2DLayer-2DMiddlebox-2DSecurity-2DProtocol.pdf&d=DwMGaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=rlqIJ6xS9MsILcMtR4u-PndR3hWt4w1dkF1miThFZFo&s=DQjWi7QXn-xYLa2Zagw4v9HOrsExXdWdodqgmfpIJzo&e=>]

Best regards.

ETSI TC CYBER is about to approve the final draft TS 103 523-2 for publication and then requests the registration of 3 TLS ExtensionType Values as defined in the final draft TS 103 523-2 available athttps://docbox.etsi.org/CYBER/CYBER/Open/Latest_Drafts/CYBER-0027-2v020-TLMSP-Transport-Layer-Middlebox-Security-Protocol.pdf<https://urldefense.proofpoint.com/v2/url?u=https-3A__docbox.etsi..org_CYBER_CYBER_Open_Latest-5FDrafts_CYBER-2D0027-2D2v020-2DTLMSP-2DTransport-2DLayer-2DMiddlebox-2DSecurity-2DProtocol.pdf&d=DwMGaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=oQMPGfGgrdxWDPibuv7xZmkvs4QwZHGAlXPJhbmALhg&s=7BhZBrWwPqaCtDCObi_1lvKoXHZTiYCo_c2qzo6vQhE&e=>.

Best regards.

_______________________________________________
tls-reg-review mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tls-reg-review<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_tls-2Dreg-2Dreview&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=VlxsG-l3Gno8HV6stjeLlw3xSjmnqCbC3VyOpMTZLoo&s=IdRKCA5Zlf9QEyobs5c_WjHhHkIVYtJh_zhpnLBLacM&e=>