Subject: [Tls-reg-review] Request to register 3 values in TLS ExtensionType Values registry

From: Miguel Angel Reina Ortega <[email-masked]>
Date: Thu, 11 Jun 2020 07:59:56 +0000

Dear TLS ExtensionType Values Registry Experts,

ETSI TC CYBER has developed a Technical Specification TS 103 523-2 "Transport Layer Middlebox Security Protocol (TLMSP)" specifying a protocol to enable secure transparent communication sessions between network endpoints with one or more middleboxes between these endpoints, using data encryption and integrity protection, as well as authentication of the identity of the endpoints and the identity of any middlebox present. The Middlebox Security Protocol builds on TLS 1.2.

ETSI TC CYBER is about to approve the final draft TS 103 523-2 for publication and then requests the registration of 3 TLS ExtensionType Values as defined in the final draft TS 103 523-2 available at https://docbox.etsi.org/CYBER/CYBER/Open/Latest_Drafts/CYBER-0027-2v020-TLMSP-Transport-Layer-Middlebox-Security-Protocol.pdf.

The 3 extensions are defined in the following clauses:

     * clause 4.3.5 extension named TLSMP

     * clause C.2.3 extensions named TLMSP_proxying and TLMSP_delegate

     * IANA considerations in annex I

Please, note that we will be able to provide the final URL of the published TS only after its publication.

Best regards.

-----------------------------------------------------------------------------------------------------------------
Miguel Angel Reina Ortega – Testing Expert
Centre for Testing and Interoperability (CTI)
ETSI ● www.etsi.org<http://www.etsi.org/> ● [email-masked]<mailto:[email-masked]>
Phone: +33 (0)4 92 94 43 49 ● Mobile: +33 (0)6 76 73 60 99

This email may contain confidential information and is intended for
the use of the addressee only. Any unauthorized use may be unlawful.
If you receive this email by mistake, please advise the sender
immediately by using the reply facility in your email software.
Thank you for your co-operation.

---

From: Yoav Nir <[email-masked]>
Date: Thu, 11 Jun 2020 19:23:10 +0300

So a protocol for the endpoints to talk to the middle-box and allow it read, read+delete, or read+delete+write access to the data stream?

I think we’ve yelled at people who brought this kind of thing to the IETF in the past.

Does this count as “mostly harmless” because they just want an extension number, not an RFC number?

> On 11 Jun 2020, at 10:59, Miguel Angel Reina Ortega <[email-masked]> wrote:
> 
> ETSI TC CYBER is about to approve the final draft TS 103 523-2 for publication and then requests the registration of 3 TLS ExtensionType Values as defined in the final draft TS 103 523-2 available athttps://docbox.etsi.org/CYBER/CYBER/Open/Latest_Drafts/CYBER-0027-2v020-TLMSP-Transport-Layer-Middlebox-Security-Protocol.pdf <https://docbox.etsi.org/CYBER/CYBER/Open/Latest_Drafts/CYBER-0027-2v020-TLMSP-Transport-Layer-Middlebox-Security-Protocol.pdf>.
> ETSI ● www.etsi.org <http://www.etsi.org/> ● [email-masked] <mailto:[email-masked]>
> _______________________________________________
> tls-reg-review mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/tls-reg-review <https://www.ietf.org/mailman/listinfo/tls-reg-review>

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 11 Jun 2020 16:29:55 +0000

Yes, this is where interceptible TLS went after we discarded it.

I don’t think we get a moral vote, tho.

From: Yoav Nir <[email-masked]>
Date: Thursday, June 11, 2020 at 12:23 PM
To: "[email-masked]" <[email-masked]>
Subject: Re: [Tls-reg-review] Request to register 3 values in TLS ExtensionType Values registry

On 11 Jun 2020, at 10:59, Miguel Angel Reina Ortega <[email-masked]<mailto:[email-masked]>> wrote:

ETSI TC CYBER is about to approve the final draft TS 103 523-2 for publication and then requests the registration of 3 TLS ExtensionType Values as defined in the final draft TS 103 523-2 available athttps://docbox.etsi.org/CYBER/CYBER/Open/Latest_Drafts/CYBER-0027-2v020-TLMSP-Transport-Layer-Middlebox-Security-Protocol.pdf<https://urldefense.proofpoint.com/v2/url?u=https-3A__docbox.etsi.org_CYBER_CYBER_Open_Latest-5FDrafts_CYBER-2D0027-2D2v020-2DTLMSP-2DTransport-2DLayer-2DMiddlebox-2DSecurity-2DProtocol.pdf&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=GjSQtH4oNcSoW9gjQc3NeYlpnrqE2zr8mclZf37nr1A&s=qCl0DYOmf9Uc-Y3Rj5hJpWz3Xq4-ge_D1GFn2zOREWY&e=>.

Best regards.

ETSI ● www.etsi.org<https://urldefense.proofpoint.com/v2/url?u=http-3A__www.etsi.org_&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=GjSQtH4oNcSoW9gjQc3NeYlpnrqE2zr8mclZf37nr1A&s=GhLs_FLSmA-osQ0cKbcT5kqmBsljznhTtIDuG7xtD1k&e=> ● [email-masked]<mailto:[email-masked]>

_______________________________________________
tls-reg-review mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tls-reg-review<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_tls-2Dreg-2Dreview&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=GjSQtH4oNcSoW9gjQc3NeYlpnrqE2zr8mclZf37nr1A&s=LnFG7aJJ4aJxaWIHASh9HIFTPgnsq62YSGZwB9dNIzY&e=>

---

From: Yoav Nir <[email-masked]>
Date: Fri, 12 Jun 2020 22:44:02 +0300

I tend to agree, although that leads me to question the value of what we’re doing here.

Anyway, I think this is going to lead to yelling, so we might as well get in front of it. I’d like to post a message to the TLS mailing list before we instruct IANA to assign values.

Objections?

Yoav

> On 11 Jun 2020, at 19:29, Salz, Rich <[email-masked]> wrote:
> 
>> On 11 Jun 2020, at 10:59, Miguel Angel Reina Ortega <[email-masked] <mailto:[email-masked]>> wrote:
>>  
>> ETSI TC CYBER is about to approve the final draft TS 103 523-2 for publication and then requests the registration of 3 TLS ExtensionType Values as defined in the final draft TS 103 523-2 available athttps://docbox.etsi.org/CYBER/CYBER/Open/Latest_Drafts/CYBER-0027-2v020-TLMSP-Transport-Layer-Middlebox-Security-Protocol.pdf <https://urldefense.proofpoint.com/v2/url?u=https-3A__docbox.etsi.org_CYBER_CYBER_Open_Latest-5FDrafts_CYBER-2D0027-2D2v020-2DTLMSP-2DTransport-2DLayer-2DMiddlebox-2DSecurity-2DProtocol.pdf&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=GjSQtH4oNcSoW9gjQc3NeYlpnrqE2zr8mclZf37nr1A&s=qCl0DYOmf9Uc-Y3Rj5hJpWz3Xq4-ge_D1GFn2zOREWY&e=>.
>> ETSI ● www.etsi.org <https://urldefense.proofpoint.com/v2/url?u=http-3A__www.etsi.org_&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=GjSQtH4oNcSoW9gjQc3NeYlpnrqE2zr8mclZf37nr1A&s=GhLs_FLSmA-osQ0cKbcT5kqmBsljznhTtIDuG7xtD1k&e=> ● [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/tls-reg-review <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_tls-2Dreg-2Dreview&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=GjSQtH4oNcSoW9gjQc3NeYlpnrqE2zr8mclZf37nr1A&s=LnFG7aJJ4aJxaWIHASh9HIFTPgnsq62YSGZwB9dNIzY&e=>

---

From: "Salz, Rich" <[email-masked]>
Date: Sat, 13 Jun 2020 13:11:53 +0000

Go for it.

From: Yoav Nir <[email-masked]>
Date: Friday, June 12, 2020 at 3:44 PM
To: Rich Salz <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [Tls-reg-review] Request to register 3 values in TLS ExtensionType Values registry

Objections?

Yoav

On 11 Jun 2020, at 19:29, Salz, Rich <[email-masked]<mailto:[email-masked]>> wrote:

From: Yoav Nir <[email-masked]<mailto:[email-masked]>>
Date: Thursday, June 11, 2020 at 12:23 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Tls-reg-review] Request to register 3 values in TLS ExtensionType Values registry

Best regards.

---

From: Benjamin Kaduk <[email-masked]>
Date: Sun, 14 Jun 2020 21:53:06 -0700

> Does this count as “mostly harmless” because they just want an extension number, not an RFC number?

The extension-number requests seem to be "the process is working as
intended".  I am more concerned about the Handshake message types in §
4.3.4 (but did not attempt to determine to what extent they might need to
coexist with IANA-managed handshake types, which may be quite different
from "mostly harmless".  Someone would have to read more of the doc to
tell.

-Ben

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 15 Jun 2020 13:13:40 +0000

Yeah, I had forgotten to ask them about the handshake types.  I just did.

On 6/15/20, 12:53 AM, "Benjamin Kaduk" <[email-masked]> wrote:

    -Ben

    _______________________________________________
    tls-reg-review mailing list
    [email-masked]
    https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_tls-2Dreg-2Dreview&d=DwIGaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=Z3EA6SAB52xeB9Oy6czmMnR76Klv50QtA9MX4WKeM24&s=ycdZizo2jvaTG9RP6ycFmQ3-QHk7O17O48iT2XZEPk0&e=

---

From: Yoav Nir <[email-masked]>
Date: Mon, 22 Jun 2020 00:14:30 +0300

I suppose we got a reluctant nod from the community.

> On 13 Jun 2020, at 16:11, Salz, Rich <[email-masked]> wrote:
> 
> Go for it.
>  
>> On 11 Jun 2020, at 19:29, Salz, Rich <[email-masked] <mailto:[email-masked]>> wrote:
>>  
>> From: Yoav Nir <[email-masked] <mailto:[email-masked]>>
>> To: "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 22 Jun 2020 13:15:44 +0000

It’s a nod :)

Waiting to hear back from them about the handshake values.  Ben Kaduk asked.

Date: Sunday, June 21, 2020 at 5:14 PM

On 13 Jun 2020, at 16:11, Salz, Rich <[email-masked]<mailto:[email-masked]>> wrote:

Go for it.

From: Yoav Nir <[email-masked]<mailto:[email-masked]>>
Date: Friday, June 12, 2020 at 3:44 PM
To: Rich Salz <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Tls-reg-review] Request to register 3 values in TLS ExtensionType Values registry

Objections?

Yoav

Best regards.