Subject: Re: [Tls-reg-review] request to register a label in the TLS Exporter Labels registry (resending due to no response)

From: "Salz, Rich" <[email-masked]>
Date: Thu, 20 Aug 2020 14:04:31 +0000

Sorry for the delay.

I approve this (needs two of three).  Nick, Yoav – okay?

From: "Zugenmaier, Alf" <[email-masked]>
Date: Thursday, August 20, 2020 at 9:10 AM
To: "[email-masked]" <[email-masked]>
Subject: [Tls-reg-review] request to register a label in the TLS Exporter Labels registry (resending due to no response)

I have the impression my previous email might have been lost due the summer break.
Therefore I am resending.

Best regards,
    Alf Zugenmaier

Von: Zugenmaier, Alf
Gesendet: Donnerstag, 23. Juli 2020 19:54
An: [email-masked]' <[email-masked]>
Betreff: request to register a TLS exporter label

Dear IANA,

3GPP has defined a protocol „PRINS”, for which the key is derived from a TLS key. For this, a TLS exporter shall use the label
"EXPORTER_3GPP_N32_MASTER", which we (3GPP SA3) would like to register with IANA.
The specification is 3GPP TS 33..501: Security architecture and procedures for 5G system, which can be downloaded from http://www.3gpp.org/ftp/Specs/archive/33_series/33.501/33501-f90.zip<https://urldefense.proofpoint.com/v2/url?u=http-3A__www.3gpp.org_ftp_Specs_archive_33-5Fseries_33.501_33501-2Df90..zip&d=DwMFAg&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=0Oovu1G9U53HlaNtNxPRNUwDniBh_Z9nKVW7qcGjR8M&s=WGCduxaZLBTXfKsUOEnn6ukK7yp6RQn3oT3m5AyRxVk&e=>
The relevant text is in clause 13.2.4.4.1

Please let me know whether you require any additional information.

Best regards,
   Alf Zugenmaier
Rapporteur for 33.501

---

From: Yoav Nir <[email-masked]>
Date: Fri, 21 Aug 2020 00:47:10 +0300

Yes

> On 20 Aug 2020, at 17:04, Salz, Rich <rsalz=[email-masked]> wrote:
> 
> Sorry for the delay.
>  
> The specification is 3GPP TS 33..501: Security architecture and procedures for 5G system, which can be downloaded fromhttp://www.3gpp.org/ftp/Specs/archive/33_series/33.501/33501-f90.zip <https://urldefense.proofpoint.com/v2/url?u=http-3A__www.3gpp.org_ftp_Specs_archive_33-5Fseries_33.501_33501-2Df90..zip&d=DwMFAg&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=0Oovu1G9U53HlaNtNxPRNUwDniBh_Z9nKVW7qcGjR8M&s=WGCduxaZLBTXfKsUOEnn6ukK7yp6RQn3oT3m5AyRxVk&e=>
> _______________________________________________
> tls-reg-review mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls-reg-review

---

From: "Sabrina Tanamal via RT" <[email-masked]>
Date: Thu, 20 Aug 2020 23:27:38 +0000

Hi all, 

How should we fill in the 'DTLS-OK' and 'Recommended' columns for this registration? 

Thanks,

Sabrina Tanamal
Senior IANA Services Specialist

On Thu Aug 20 21:47:20 2020, [email-masked] wrote:
> Yes
> 
> > On 20 Aug 2020, at 17:04, Salz, Rich
> > <rsalz=[email-masked]> wrote:
> >
> > Sorry for the delay.
> >
> > Subject: [Tls-reg-review] request to register a label in the TLS
> > Exporter Labels registry (resending due to no response)
> >
> > 3GPP has defined a protocol „PRINS”, for which the key is derived
> > from a TLS key. For this, a TLS exporter shall use the label
> > The specification is 3GPP TS 33..501: Security architecture and
> > procedures for 5G system, which can be downloaded
> > fromhttp://www.3gpp.org/ftp/Specs/archive/33_series/33.501/33501-
> > f90.zip <https://urldefense.proofpoint.com/v2/url?u=http-
> > 3A__www.3gpp.org_ftp_Specs_archive_33-5Fseries_33.501_33501-
> > 2Df90..zip&d=DwMFAg&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-
> > w&m=0Oovu1G9U53HlaNtNxPRNUwDniBh_Z9nKVW7qcGjR8M&s=WGCduxaZLBTXfKsUOEnn6ukK7yp6RQn3oT3m5AyRxVk&e=>

---

From: Yoav Nir <[email-masked]>
Date: Fri, 21 Aug 2020 11:24:33 +0300

I don’t think 3GPP currently plan to use it in DTLS, but there’s no reason why it would not be appropriate for DTLS.  So I think DTLS-OK should be set to YES.

Mr. Zugenmaier, do you agree?

Yoav

> On 21 Aug 2020, at 2:27, Sabrina Tanamal via RT <[email-masked]> wrote:
> 
> Hi all, 
> 
> On Thu Aug 20 21:47:20 2020, [email-masked] <mailto:[email-masked]> wrote:
>> Yes
>> 
>>> f90.zip <https://urldefense.proofpoint.com/v2/url?u=http- <https://urldefense.proofpoint.com/v2/url?u=http->
>>> [email-masked] <mailto:[email-masked]>
>>> https://www.ietf.org/mailman/listinfo/tls-reg-review <https://www.ietf.org/mailman/listinfo/tls-reg-review>

---

From: "Salz, Rich" <[email-masked]>
Date: Fri, 21 Aug 2020 13:14:50 +0000

Not recommended.  DLTS-OK NO, unless Alf says otherwise.

On 8/20/20, 7:27 PM, "Sabrina Tanamal via RT" <[email-masked]> wrote:

    Hi all, 

    Thanks,

    Sabrina Tanamal

    On Thu Aug 20 21:47:20 2020, [email-masked] wrote:
    > > https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_tls-2Dreg-2Dreview&d=DwIDaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=tITAqUw1EXm98XjwcZM1Vv1ZJXTcQraWEpy9vUgAsJ0&s=1q22TtQzZbl2BNkafA6Z0ggy-DylJDq42iTsCGAd9x0&e=

---

From: "Salz, Rich" <[email-masked]>
Date: Fri, 21 Aug 2020 13:31:53 +0000

Seeing yoav's responses, I'm fine with whatever DTLS-OK value he and Alf agree on :)

But "Recommended N"

On 8/21/20, 9:15 AM, "Salz, Rich" <rsalz=[email-masked]> wrote:

        Hi all, 

        Thanks,

        Sabrina Tanamal

    _______________________________________________
    tls-reg-review mailing list
    [email-masked]
    https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_tls-2Dreg-2Dreview&d=DwIGaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=tRXuYy0BDAPoj4wr6kDgkGqyM-o6gki-_l1QyrBUAPU&s=qW7BDc0iynkc33T6BvK4NYVxBhjzHYS4u5zYSQuECg4&e=

---

From: "Zugenmaier, Alf" <[email-masked]>
Date: Fri, 21 Aug 2020 13:48:36 +0000

Hi everyone,

thank you for the quick responses. Would it be possible to upgrade the DLTS-OK value later (no->yes), or would this require a new TLS exporter label?

Best regards,
   Alf

-----Ursprüngliche Nachricht-----
Von: Salz, Rich <[email-masked]> 
Gesendet: Freitag, 21. August 2020 15:32
An: Salz, Rich <rsalz=[email-masked]>; [email-masked]; [email-masked]
Cc: [email-masked]; Zugenmaier, Alf <[email-masked]>
Betreff: Re: [Tls-reg-review] [IANA #1176427] Re: request to register a label in the TLS Exporter Labels registry (resending due to no response)

But "Recommended N"

        Hi all, 

        Thanks,

        Sabrina Tanamal

---

From: "Michelle Cotton via RT" <[email-masked]>
Date: Fri, 21 Aug 2020 18:01:14 +0000

Hi all,

We've added the following entry to the TLS Exporter Labels registry:

Value: EXPORTER_3GPP_N32_MASTER	
DTLS-OK: N	
Recommended: N	
Reference: [3GPP TS 33.501]

Please see
https://www.iana.org/assignments/tls-parameters

Let us know if there is anything that requires changing.

Best regards,

Michelle Cotton
Protocol Parameters Engagement Sr. Manager
IANA Services