Subject: [Tls-reg-review] [IANA #1184473] Early allocation request for TLS extension type for QUIC

From: "Michelle Cotton via RT" <[email-masked]>
Date: Tue, 08 Dec 2020 22:58:34 +0000

Hi Rich, Yoav, Nick,

Thank you for all your help during 2020!

For the request you recently approved for a TLS ExtensionType Value registration in 
draft-ietf-quic-tls, we received a request to add it to the registry now.

Shall we continue to fill in the gaps and assign 46?

Thanks,
Michelle

Michelle Cotton
Protocol Parameters Engagement Sr. Manager
IANA Services

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 8 Dec 2020 23:50:57 +0000

46 is fine with me.

And thanks to you and the team for making this so simple!

On 12/8/20, 5:58 PM, "Michelle Cotton via RT" <[email-masked]> wrote:

    Hi Rich, Yoav, Nick,

    Thanks,
    Michelle

    Michelle Cotton

    _______________________________________________
    tls-reg-review mailing list
    [email-masked]
    https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/tls-reg-review__;!!GjvTz_vk!DCtTOOjfHq9dpceKE9r6hpljAQ9LaF9lbiP7ZKwHyjuWkt0xnYeNLe2PcrYB$

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 10 Dec 2020 14:25:40 +0000

>    So,  I'm going to request a new allocation for this codepoint.  57 seems to be the next one, but I really don't care what you select.  It might be better to have something chosen at random even.

57 seems pretty random to me :)

>    I am ALSO going to request that IANA mark the codepoint 46 as reserved, as well as the codepoint 40.  I don't know how to formally do that; I'm prepared to write an internet-draft for that purpose if that is necessary.

That makes sense but I don't know the process either.

---

From: "Michelle Cotton via RT" <[email-masked]>
Date: Thu, 10 Dec 2020 16:30:31 +0000

Hello all,

We have changed the assignment for the TLS extension type from 46 to

57	quic_transport_parameters	CH, EE	       N

See: https://www.iana.org/assignments/tls-extensiontype-values

On Thu Dec 10 14:27:12 2020, [email-masked] wrote:
> > So,  I'm going to request a new allocation for this codepoint.  57
> > seems to be the next one, but I really don't care what you select.
> > It might be better to have something chosen at random even.
> 
> > I am ALSO going to request that IANA mark the codepoint 46 as
> > reserved, as well as the codepoint 40.  I don't know how to formally
> > do that; I'm prepared to write an internet-draft for that purpose if
> > that is necessary.
> 

As this is a Specification Required registry, we need something to point to for a reference for a Reserved value.  This can be accomplished by a brief internet-draft that describes the 2 reservations.  Alternatively, the experts could post a message to the mailing list documenting the reservation of 40 and 46 along with the reasoning.  In the registry, we could point to the mail in the archive.  It is up to the experts to determine if that is sufficient documentation.

I'm going to resolve this request as it was for the registration for quic_transport_parameters.  We can open a new request for the reservations.

Please let us know if you have any questions.

Thank you,

Michelle Cotton

********

Michelle Cotton

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 10 Dec 2020 16:37:42 +0000

Martin, how about you post to the email list and we'll followup and that can be the documentation that's needed?

On 12/10/20, 11:30 AM, "Michelle Cotton via RT" <[email-masked]> wrote:

    Hello all,

    See: https://urldefense.com/v3/__https://www.iana.org/assignments/tls-extensiontype-values__;!!GjvTz_vk!DBAWg95Neuz9z9WYORpXzYFS5BjhOrQTZcz4bnIFGw_NC3LezcxJW32dqj0W$ 

    Thank you,

    Michelle Cotton

    ********

    Michelle Cotton

    _______________________________________________
    tls-reg-review mailing list
    [email-masked]
    https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/tls-reg-review__;!!GjvTz_vk!DBAWg95Neuz9z9WYORpXzYFS5BjhOrQTZcz4bnIFGw_NC3LezcxJW6KQWQJ2$