Subject: [Tls-reg-review] [IANA #1192847] expert review for draft-ietf-tls-dtls-connection-id (tls-extensiontype-values)

From: "Sabrina Tanamal via RT" <[email-masked]>
Date: Thu, 25 Mar 2021 18:29:47 +0000

Yoav, Rich, and Nick, 

Since we made the early allocation for draft-ietf-tls-dtls-connection-id in the TLS ExtensionType Values registry, the entries for the TLS 1.3 and Recommended columns have been updated. Can you confirm that this is still OK? 

https://datatracker.ietf.org/doc/draft-ietf-tls-dtls-connection-id/

The registry is here:

https://www.iana.org/assignments/tls-extensiontype-values

Thanks,
Sabrina

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 25 Mar 2021 19:06:29 +0000

Since it's DTLS, the TLS 1.3 columns are N and empty.  So yes, looks good.

On 3/25/21, 2:29 PM, "Sabrina Tanamal via RT" <[email-masked]> wrote:

    Yoav, Rich, and Nick, 

    https://urldefense.com/v3/__https://datatracker.ietf.org/doc/draft-ietf-tls-dtls-connection-id/__;!!GjvTz_vk!CJ8eRiCWgGTTOgionTDXP3n9xgGDAIDZj70qb-Y3zuDd7bho6ztR3phGAOkJ$ 

    The registry is here:

    https://urldefense.com/v3/__https://www.iana.org/assignments/tls-extensiontype-values__;!!GjvTz_vk!CJ8eRiCWgGTTOgionTDXP3n9xgGDAIDZj70qb-Y3zuDd7bho6ztR3mJa8lfW$ 

    Thanks,
    Sabrina

---

From: "Sabrina Tanamal via RT" <[email-masked]>
Date: Thu, 25 Mar 2021 22:24:50 +0000

Hi Rich, 

Thanks for the quick review. Just to confirm, the TLS 1.3 column will be updated to "CH, SH," while the Recommended column will remain as "N" when the document is approved for publication. Is this OK, or should one of the columns be empty? 

Thanks,
Sabrina

On Thu Mar 25 19:06:57 2021, [email-masked] wrote:
> Since we made the early allocation for draft-ietf-tls-dtls-connection-
> id in the TLS ExtensionType Values registry, the entries for the TLS
> 1.3 and Recommended columns have been updated. Can you confirm that
> this is still OK?
> 
> https://urldefense.com/v3/__https://datatracker.ietf.org/doc/draft-
> ietf-tls-dtls-connection-
> id/__;!!GjvTz_vk!CJ8eRiCWgGTTOgionTDXP3n9xgGDAIDZj70qb-
> Y3zuDd7bho6ztR3phGAOkJ$
> 
> The registry is here:
> 
> https://urldefense.com/v3/__https://www.iana.org/assignments/tls-
> extensiontype-
> values__;!!GjvTz_vk!CJ8eRiCWgGTTOgionTDXP3n9xgGDAIDZj70qb-
> Y3zuDd7bho6ztR3mJa8lfW$
> 
> Thanks,
> Sabrina
> 
>

---

From: "Salz, Rich" <[email-masked]>
Date: Fri, 26 Mar 2021 00:12:30 +0000

Fine with me.

On 3/25/21, 6:24 PM, "Sabrina Tanamal via RT" <[email-masked]> wrote:

    Hi Rich, 

    Thanks,
    Sabrina

---

From: "Sabrina Tanamal via RT" <[email-masked]>
Date: Fri, 26 Mar 2021 16:24:02 +0000

Thanks Rich! 

Yoav or Nick, can one you join Rich in approving this one? 

Thank you,
Sabrina

On Fri Mar 26 00:12:57 2021, [email-masked] wrote:
> Thanks for the quick review. Just to confirm, the TLS 1.3 column will
> be updated to "CH, SH," while the Recommended column will remain as
> "N" when the document is approved for publication. Is this OK, or
> should one of the columns be empty?
> 
> Thanks,
> Sabrina
>

---

From: Yoav Nir <[email-masked]>
Date: Sat, 27 Mar 2021 00:20:04 +0300

Sure. I approve.

> On 26 Mar 2021, at 19:24, Sabrina Tanamal via RT <[email-masked]> wrote:
> 
> Thanks Rich! 
>

---

From: Benjamin Kaduk <[email-masked]>
Date: Fri, 26 Mar 2021 15:16:58 -0700

I think there has been some discussion about maybe letting the early
allocation expire and getting a new codepoint for the final RFC version,
since we changed the MAC calcluation and it would not be interoperable with
the earlier drafts.

I will check with the authors, but Sabrina if you could let us know the
best way to indicate what we want to happen, that would be helpful.

Thanks,

Ben

On Sat, Mar 27, 2021 at 12:20:04AM +0300, Yoav Nir wrote:
> _______________________________________________
> tls-reg-review mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls-reg-review

---

From: "Sabrina Tanamal via RT" <[email-masked]>
Date: Fri, 26 Mar 2021 23:23:53 +0000

Hi Ben, 

If you don't want the early allocation to expire until the document is approved and we make the new assignment, one option is for the document to say, "once it's approved for publication, the early allocation will be deprecated. The following new assignment will be made:" or something similar.

We can add the current version number -10 to the reference for the early allocation, unless an earlier version number would be more appropriate. If you prefer not to deprecate the current assignment (whether now or in the document), it can also be left to expire without making any changes (except to add a version number to the reference). Please let us know which version number we should include in the reference. 

Thanks,
Sabrina

On Fri Mar 26 22:17:30 2021, [email-masked] wrote:
> > >>> Since it's DTLS, the TLS 1.3 columns are N and empty.  So yes,
> > >>> looks
> > >>> good.
> > >>>
> > >>> On 3/25/21, 2:29 PM, "Sabrina Tanamal via RT" <drafts-expert-
> > >>> review-
> > >>> [email-masked]> wrote:
> > >>>
> > >>> Yoav, Rich, and Nick,
> > >>>