Subject: Re: [Tls-reg-review] IANA TLS ALPN registry for SIP

From: "Olle E. Johansson" <[email-masked]>
Date: Tue, 17 Aug 2021 15:12:08 +0200

Hi!
Still waiting for responses on this.

/O

> On 1 Jul 2021, at 11:09, Olle E. Johansson <[email-masked]> wrote:
> 
> Hi!
> Sorry if I have missed mails, but I don’t see any follow-up on this issue.
> Any outstanding questions?
> 
> Cheers,
> /O
> 
>> On 1 May 2021, at 18:01, Olle E. Johansson <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> 
>> 
>>> On 1 May 2021, at 17:15, Yoav Nir <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
>>> Is RFC 3261 a valid reference?  It’s valid for SIP, but doesn’t describe using ALPN.  In fact, what it says about TLS is that by default, proxies should be listening on port 5061 for TLS, not sharing some common port with other services.
>>> 
>>> Is there some document that talks about sharing a port between SIP and other services?
>> There is a document covering STUN on the same port, but it doesn’t really answer your question.
>> 
>> What I was thinking about is a few implementations
>> that server HTTPS and SIP/TLS on the same socket in order to support both SIP over websockets
>> and SIP/TLS. One that I’m involved with is Kamailio at kamailio.org <http://kamailio.org/> which would be helped by ALPN
>> usage.
>> 
>> I did not see a requirement for an RFC that covers ALPN usage in the referenced protocol
>> in the requirement texts for IANA ALPN registration, but if that’s the case I guess we have to produce something.
>> 
>> /O
>>> 
>>> Yoav
>>> 
>>>> On 30 Apr 2021, at 18:21, Salz, Rich <rsalz=[email-masked] <mailto:rsalz=[email-masked]>> wrote:
>>>> 
>>>> This looks good to me.  Will need Yoav or Nick to also approve.
>>>> 
>>>> On 4/30/21, 3:12 AM, "Olle E. Johansson" <[email-masked] <mailto:[email-masked]>> wrote:
>>>> 
>>>>   I would like to register a TLS ALPN registry entry for the Session Initiation Protocol according to the following entry:
>>>> 
>>>>      Protocol:  SIP
>>>>      Identification Sequence:
>>>>         0x73 0x69 0x70  (“sip")
>>>>      Reference:  [RFC3261]
>>>> 
>>>>   Best regards,
>>>>   /Olle E. Johansson
>>>>   _______________________________________________
>>>>   tls-reg-review mailing list
>>>>   [email-masked] <mailto:[email-masked]>
>>>>   https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/tls-reg-review__;!!GjvTz_vk!BzhIvT8_gOqJ8H95ghJps9NOZ-nnsQ6GnSGICKr3XFzpOHVoa0Zkn-6s6p0K$ <https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/tls-reg-review__;!!GjvTz_vk!BzhIvT8_gOqJ8H95ghJps9NOZ-nnsQ6GnSGICKr3XFzpOHVoa0Zkn-6s6p0K$> 
>>>> 
>>>> _______________________________________________
>>>> tls-reg-review mailing list
>>>> [email-masked] <mailto:[email-masked]>
>>>> https://www.ietf.org/mailman/listinfo/tls-reg-review <https://www.ietf.org/mailman/listinfo/tls-reg-review>
>>> 
>> 
>

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 17 Aug 2021 13:26:51 +0000

You don’t need an RFC, you need a document.  It could just be a draft.

From: Olle Johansson <[email-masked]>
Date: Tuesday, August 17, 2021 at 9:12 AM
To: Yoav Nir <[email-masked]>
Cc: Rich Salz <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Tls-reg-review] IANA TLS ALPN registry for SIP

Hi!

/O

On 1 Jul 2021, at 11:09, Olle E. Johansson <[email-masked]<mailto:[email-masked]>> wrote:

Hi!

Cheers,
/O

On 1 May 2021, at 18:01, Olle E. Johansson <[email-masked]<mailto:[email-masked]>> wrote:

On 1 May 2021, at 17:15, Yoav Nir <[email-masked]<mailto:[email-masked]>> wrote:

What I was thinking about is a few implementations
that server HTTPS and SIP/TLS on the same socket in order to support both SIP over websockets
and SIP/TLS. One that I’m involved with is Kamailio at kamailio.org<https://urldefense.com/v3/__http:/kamailio.org/__;!!GjvTz_vk!CO4UdcOQmXPUG_jJOMlK2aJr7w35q5A3xwrJupget_kqsxr5ji6z7y3F5c8E$> which would be helped by ALPN
usage.

/O

Yoav

On 30 Apr 2021, at 18:21, Salz, Rich <rsalz=[email-masked]<mailto:rsalz=[email-masked]>> wrote:

On 4/30/21, 3:12 AM, "Olle E. Johansson" <[email-masked]<mailto:[email-masked]>> wrote:

     Protocol:  SIP
     Identification Sequence:
        0x73 0x69 0x70  (“sip")
     Reference:  [RFC3261]

  Best regards,
  /Olle E. Johansson
  _______________________________________________
  tls-reg-review mailing list
  [email-masked]<mailto:[email-masked]>
  https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/tls-reg-review__;!!GjvTz_vk!BzhIvT8_gOqJ8H95ghJps9NOZ-nnsQ6GnSGICKr3XFzpOHVoa0Zkn-6s6p0K$<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/tls-reg-review__;!!GjvTz_vk!BzhIvT8_gOqJ8H95ghJps9NOZ-nnsQ6GnSGICKr3XFzpOHVoa0Zkn-6s6p0K$>

_______________________________________________
tls-reg-review mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tls-reg-review<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/tls-reg-review__;!!GjvTz_vk!CO4UdcOQmXPUG_jJOMlK2aJr7w35q5A3xwrJupget_kqsxr5ji6z78p-5w03$>

---

From: "Olle E. Johansson" <[email-masked]>
Date: Tue, 17 Aug 2021 15:31:04 +0200

> On 17 Aug 2021, at 15:26, Salz, Rich <[email-masked]> wrote:
> 
So the IRC registration (which is a very old RFC) had a draft too? Just curious.
Again, I saw nothing in the ALPN registration requirements about this, but I’m fine with it :-)

I’ll write something up.

/O
>  
>  
> From: Olle Johansson <[email-masked] <mailto:[email-masked]>>
> To: Yoav Nir <[email-masked] <mailto:[email-masked]>>
> Cc: Rich Salz <[email-masked] <mailto:[email-masked]>>, "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
>> On 1 Jul 2021, at 11:09, Olle E. Johansson <[email-masked] <mailto:[email-masked]>> wrote:
>>  
>> Hi! 
>>> and SIP/TLS. One that I’m involved with is Kamailio at kamailio.org <https://urldefense.com/v3/__http:/kamailio.org/__;!!GjvTz_vk!CO4UdcOQmXPUG_jJOMlK2aJr7w35q5A3xwrJupget_kqsxr5ji6z7y3F5c8E$> which would be helped by ALPN
>>> usage.
>>>  
>>>>>   https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/tls-reg-review__;!!GjvTz_vk!BzhIvT8_gOqJ8H95ghJps9NOZ-nnsQ6GnSGICKr3XFzpOHVoa0Zkn-6s6p0K$ <https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/tls-reg-review__;!!GjvTz_vk!BzhIvT8_gOqJ8H95ghJps9NOZ-nnsQ6GnSGICKr3XFzpOHVoa0Zkn-6s6p0K$> 
>>>>> 
>>>>> https://www.ietf.org/mailman/listinfo/tls-reg-review <https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/tls-reg-review__;!!GjvTz_vk!CO4UdcOQmXPUG_jJOMlK2aJr7w35q5A3xwrJupget_kqsxr5ji6z78p-5w03$>

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 17 Aug 2021 13:40:16 +0000

*   So the IRC registration (which is a very old RFC) had a draft too? Just curious.

The IRC registration probably pre-dates the policy.

  *   Again, I saw nothing in the ALPN registration requirements about this, but I’m fine with it :-)

https://datatracker.ietf.org/doc/html/rfc7301#page-7 ☺

---

From: "Olle E. Johansson" <[email-masked]>
Date: Tue, 17 Aug 2021 15:55:43 +0200

> On 17 Aug 2021, at 15:40, Salz, Rich <[email-masked]> wrote:
> 
> https://datatracker.ietf.org/doc/html/rfc7301#page-7 <https://datatracker.ietf.org/doc/html/rfc7301#page-7> ☺

Well, the reference is just defined “a reference to a specification that defines the protocol”,
which RFC 3261 does for SIP. The TLS spec in that and following docs are just bad,
and should not be read or implemented ;-) Like the SIPS: uri.

Life.

/O

---

From: "Olle E. Johansson" <[email-masked]>
Date: Tue, 17 Aug 2021 17:28:07 +0200

Hello again,
Inspired by Rich’s feedback I’ve written a very short IETF draft
https://datatracker.ietf.org/doc/draft-johansson-sip-alpn/

I am not very well trained in draft-writing so if anything is missing, just give me feedback.

Best regards,
/O