Subject: Re: [Tls-reg-review] Continue to use the one-byte registry for TLSHashAlgorithm identifier

From: "Salz, Rich" <[email-masked]>
Date: Mon, 17 Jan 2022 15:23:39 +0000

I don’t believe this is a decision for the experts to make, but rather must be a TLS WG decision.

From: "Joe Clarke (jclarke)" <jclarke=[email-masked]>
Date: Sunday, January 16, 2022 at 2:06 PM
To: "[email-masked]" <[email-masked]>
Cc: Ken Vaughn <[email-masked]>
Subject: [Tls-reg-review] Continue to use the one-byte registry for TLSHashAlgorithm identifier

Hello, experts.  Opsawg has adopted work to add (D)TLS 1.3 support for SNMP.  One of the pending items in the draft is to see if the one-byte hash registry at https://www.iana.org/assignments/tls-parameters/tls-parameters.xhtml#tls-parameters-18<https://urldefense.com/v3/__https:/www.iana.org/assignments/tls-parameters/tls-parameters.xhtml*tls-parameters-18__;Iw!!GjvTz_vk!GymXMXA_8YuetHpfxBiXcLQdQgh9Vjkl1Gpal3UHTu0dRuPMCmJq8r3B2PBB$> can continue to be used for the TLSHashAlgorithm identifier?

I know RFC8447 stipulates that this registry is for TLS versions prior to 1.3 whereas TLS 1.3 should use the two-byte SignatureScheme.  However, the current  SNMP-TLS-TM-MIB defines the fingerprint to be one byte hash identifier.  If we can continue to assign hashes one-byte identifiers, this would greatly simplify the currently proposed work.  And there does seem to be quite a bit of space left in the TLS HashAlgorithm registry.

Any expert insight you can provide would be appreciated.

Joe

---

From: Yoav Nir <[email-masked]>
Date: Mon, 17 Jan 2022 23:27:55 +0200

That registry is for TLS 1.2 and earlier. It’s very unlikely to ever receive any more updates for TLS 1.2.

If others want to use it as-is, there is nothing for the TLS working group to say about this. But adding any value to this implies that this is a valid value for TLS 1.2, and I don’t think we’re ever going to have implementations of these algorithms. People who want to use new algorithms in TLS do so in the latest protocol version - 1.3 for now.

So I would be OK with re-use, but not so OK with extending it.

I would also not want to become an SNMP IANA expert.

Yoav

> On 17 Jan 2022, at 17:23, Salz, Rich <rsalz=[email-masked]> wrote:
> 
> Hello, experts.  Opsawg has adopted work to add (D)TLS 1.3 support for SNMP.  One of the pending items in the draft is to see if the one-byte hash registry at https://www.iana.org/assignments/tls-parameters/tls-parameters.xhtml#tls-parameters-18 <https://urldefense.com/v3/__https:/www.iana.org/assignments/tls-parameters/tls-parameters.xhtml*tls-parameters-18__;Iw!!GjvTz_vk!GymXMXA_8YuetHpfxBiXcLQdQgh9Vjkl1Gpal3UHTu0dRuPMCmJq8r3B2PBB$> can continue to be used for the TLSHashAlgorithm identifier?  
> 
> _______________________________________________
> tls-reg-review mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls-reg-review

---

From: Benjamin Kaduk <[email-masked]>
Date: Mon, 17 Jan 2022 13:45:43 -0800

As some extra background for Joe, the precursor of this draft was presented
at SECDISPATCH at IETF 111, and the result of that discussion (from memory)
was that:

- the SNMP bits in the draft are more complicated than the TLS bits in the
  draft

- we expected that the TLS WG could be consulted for ideas on how to
  resolve the question of the TLS HashAlgorithm registry usage in SNMP

- we didn't really want to allocate new codepoints in the TLS 1.2 registry,
  as doing so would require allocating a block of 256 codepoints in the TLS
  1.3 SignatureScheme registry to avoid collisions.

So, I would advise starting a thread on the TLS WG list and not pursuing
allocation from the TLS HashAlgorithms registry at this time.

-Ben

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Tue, 18 Jan 2022 19:50:28 +0000

Thanks, Ben, Rich and Yoav.  I'll follow back up on opsawg@ with this,
and Ken, if you can start a thread on tls@, that would be great.

Joe