Subject: [Tls-reg-review] [IANA #1228180] [Errata Verified] RFC9102 (6860)

From: "Sabrina Tanamal via RT" <[email-masked]>
Date: Mon, 21 Mar 2022 12:31:01 +0000

Yoav, Rich, and Nick,

We've received an errata report to update the following entry in the TLS ExtensionType Values registry: 

OLD: 

Value: 59	
Extension Name: dnssec_chain
TLS 1.3: CH	
DTLS-Only: N	
Recommended: N	
Reference: [RFC9102]

NEW (adding "CT"): 

Value: 59	
Extension Name: dnssec_chain
TLS 1.3: CH, CT	
DTLS-Only: N	
Recommended: N	
Reference: [RFC9102][RFC Errata 6860]

Can you confirm that this is OK? 

The registry is here: 

https://www.iana.org/assignments/tls-extensiontype-values

Thanks,
Sabrina

On Thu Mar 17 06:23:25 2022, [email-masked] wrote:
> The following errata report has been verified for RFC9102,
>  "TLS DNSSEC Chain Extension".
> 
> --------------------------------------
> You may review the report below and at:
> https://www.rfc-editor.org/errata/eid6860
> 
> --------------------------------------
> Status: Verified
> Type: Technical
> 
> Reported by: Shumon Huque <[email-masked]>
> Date Reported: 2022-02-24
> Verified by: Eliot Lear (ISE) (ISE & Editorial Board)
> 
> Section: 12
> 
> Original Text
> -------------
> IANA has made the following assignment in the "TLS ExtensionType
> Values" registry:
> 
> +=======+================+=========+=============+===========+
> | Value | Extension Name | TLS 1.3 | Recommended | Reference |
> +=======+================+=========+=============+===========+
> | 59 | dnssec_chain   | CH      | No          | RFC 9102  |
> +-------+----------------+---------+-------------+-----------+
> 
> 
> Corrected Text
> --------------
> IANA has made the following assignment in the "TLS ExtensionType
> Values" registry:
> 
> +=======+================+=========+=============+===========+
> | Value | Extension Name | TLS 1.3 | Recommended | Reference |
> +=======+================+=========+=============+===========+
> | 59 | dnssec_chain   | CH, CT  | No          | RFC 9102  |
> +-------+----------------+---------+-------------+-----------+
> 
> 
> Notes
> -----
> In TLS1.3, the dnssec_chain extension appears in the Certificate
> message from the server. Hence "CT" needs to be added to the "TLS 1.3"
> column.
> 
> --------------------------------------
> RFC9102 (draft-dukhovni-tls-dnssec-chain-08)
> --------------------------------------
> Title               : TLS DNSSEC Chain Extension
> Publication Date    : August 2021
> Author(s)           : V. Dukhovni, S. Huque, W. Toorop, P. Wouters, M.
> Shore
> Category            : EXPERIMENTAL
> Source              : INDEPENDENT
> Area                : N/A
> Stream              : INDEPENDENT
> Verifying Party     : ISE & Editorial Board

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 21 Mar 2022 12:36:43 +0000

I tracked down the docs and errata and YES the change seems  correct.

On 3/21/22, 8:31 AM, "Sabrina Tanamal via RT" <[email-masked]> wrote:

    Yoav, Rich, and Nick,

    OLD: 

    Value: 59	

    NEW (adding "CT"): 

    Value: 59	

    The registry is here: 

    https://urldefense.com/v3/__https://www.iana.org/assignments/tls-extensiontype-values__;!!GjvTz_vk!FXAa2KyJAuXfHUCp3schgBgknBFPnJIe2iTT-v5_jDIitLBfe5UNU_pUwcqU$ 

    Thanks,
    Sabrina

    On Thu Mar 17 06:23:25 2022, [email-masked] wrote:
    > https://urldefense.com/v3/__https://www.rfc-editor.org/errata/eid6860__;!!GjvTz_vk!FXAa2KyJAuXfHUCp3schgBgknBFPnJIe2iTT-v5_jDIitLBfe5UNU9iylbNN$ 
    >