Subject: Re: [Tls-reg-review] Request to register value in TLS Exporter Labels registry

From: Barbara Stark <[email-masked]>
Date: Mon, 7 Mar 2022 12:07:53 -0600

Based on this preliminary judgment, BBF has published its specification 
that describes use of the TLS Exporter Label "EXPORTER-BBF-USP-Record". 
BBF would like to get this value placed in the IANA TLS Exporter Labels 
registry 
(https://www.iana.org/assignments/tls-parameters/tls-parameters.xml#exporter-labels). 

The registry entry values are unchanged from the preliminary request and 
are:

     Value: EXPORTER-BBF-USP-Record

     DTLS-OK: N

     Recommended: N

     Reference: [TR-369](https://usp.technology/specification)

The specific section in the referenced specification where use of this 
TLS Exporter Label is described is:

https://usp.technology/specification/06-index-e2e-message-exchange.html#sec:validating-the-integrity-of-the-usp-record

Thx,

Barbara (requesting for BBF, unaffiliated)

On 12/10/2021 9:12 AM, Salz, Rich wrote:
> I skimmed the page you mentioned in the draft.  There should be no problems adding the value you want.
>
>
> On 12/9/21, 4:03 PM, "Barbara Stark" <[email-masked]> wrote:
>
>      Hi all,
>
>      Broadband Forum would like to register the following in the TLS Exporter
>      Labels registry:
>
>      Value: EXPORTER-BBF-USP-Record
>
>      DTLS-OK: N
>
>      Recommended: N
>
>      Reference: [TR-369](https://usp.technology/specification)
>
>      However, the updated specification with a reference to the Exporter
>      Label is not yet published at that location. It is currently undergoing
>      final review. But before we can approve for publication, we need to know
>      that there will be no problem with adding this registry value. We are
>      fine if adding it to the registry is delayed until the spec is fully
>      published, or if the registry entry is added pointing to the draft and
>      subsequently updated to point to the published version 1.2 of the
>      specification.
>
>      The draft (under final review) version of the specification is currently at:
>
>      https://github.com/BroadbandForum/usp/blob/master/resources/wt-369-1-2-draft1.pdf
>
>      The reference to EXPORTER-BBF-USP-Record is in section 6.3.2 (page 82)
>      of this draft PDF. In TR-369 (which defines a protocol named "USP"), TLS
>      can be used *inside* a USP Record to encrypt the payload USP Message.
>      The Exporter Label is used to set up this TLS-encrypted session inside
>      the USP Record.
>
>      Thx,
>
>      Barbara
>
>      Barbara Stark (requesting for BBF)
>
>
>      _______________________________________________
>      tls-reg-review mailing list
>      [email-masked]
>      https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/tls-reg-review__;!!GjvTz_vk!F-9xRrEzj9rduUkD3mpfH4Sp-KYhFThgALPK81XDDs7D5hs4Cwczy1vb6hPG$
>

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 7 Mar 2022 18:16:51 +0000

I approve.  Still need an approval from Nick and/or Yoav.

Please excuse the mangled URL's. :(

On 3/7/22, 1:12 PM, "Barbara Stark" <[email-masked]> wrote:

    Based on this preliminary judgment, BBF has published its specification 
    that describes use of the TLS Exporter Label "EXPORTER-BBF-USP-Record". 
    BBF would like to get this value placed in the IANA TLS Exporter Labels 
    registry 
    (https://urldefense.com/v3/__https://www.iana.org/assignments/tls-parameters/tls-parameters.xml*exporter-labels__;Iw!!GjvTz_vk!CM7TlnempevJ3ASyL8QVQw9FwHcnT6K5b--fg_DfAy05ULn98NTXZduPLem5$ ). 

         DTLS-OK: N

         Recommended: N

         Reference: [TR-369](https://urldefense.com/v3/__https://usp.technology/specification__;!!GjvTz_vk!CM7TlnempevJ3ASyL8QVQw9FwHcnT6K5b--fg_DfAy05ULn98NTXZQNgwu4c$ )

    https://urldefense.com/v3/__https://usp.technology/specification/06-index-e2e-message-exchange.html*sec:validating-the-integrity-of-the-usp-record__;Iw!!GjvTz_vk!CM7TlnempevJ3ASyL8QVQw9FwHcnT6K5b--fg_DfAy05ULn98NTXZYSaGz1k$ 

    Thx,

    On 12/10/2021 9:12 AM, Salz, Rich wrote:
    >      Reference: [TR-369](https://urldefense.com/v3/__https://usp.technology/specification__;!!GjvTz_vk!CM7TlnempevJ3ASyL8QVQw9FwHcnT6K5b--fg_DfAy05ULn98NTXZQNgwu4c$ )
    >
    >      https://urldefense.com/v3/__https://github.com/BroadbandForum/usp/blob/master/resources/wt-369-1-2-draft1.pdf__;!!GjvTz_vk!CM7TlnempevJ3ASyL8QVQw9FwHcnT6K5b--fg_DfAy05ULn98NTXZc5eKxxo$ 
    >

    _______________________________________________
    tls-reg-review mailing list
    [email-masked]
    https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/tls-reg-review__;!!GjvTz_vk!CM7TlnempevJ3ASyL8QVQw9FwHcnT6K5b--fg_DfAy05ULn98NTXZepCDcB-$

---

From: Barbara Stark <[email-masked]>
Date: Wed, 9 Mar 2022 09:58:53 -0600

Thanks Rich.

Yoav or Nick, do either of you approve?

We have the published specification and the correct label syntax. As 
mentioned before, this BBF device management protocol (called USP) is 
using TLS *inside* a USP Record to encrypt the payload USP Message. The 
Exporter Label is used to set up this TLS-encrypted session inside the 
USP Record.

Thx,

Barbara

On 3/7/2022 12:16 PM, Salz, Rich wrote:
>      https://usp.technology/specification/06-index-e2e-message-exchange.html#sec:using-tls-to-validate-the-integrity-of-usp-records
>
>      Thx,
>

---

From: Yoav Nir <[email-masked]>
Date: Thu, 10 Mar 2022 20:38:39 +0200

Yes. I approve too.

> On 9 Mar 2022, at 17:58, Barbara Stark <[email-masked]> wrote:
> 
> Thanks Rich.
> 
> We have the published specification and the correct label syntax. As mentioned before, this BBF device management protocol (called USP) is using TLS *inside* a USP Record to encrypt the payload USP Message. The Exporter Label is used to set up this TLS-encrypted session inside the USP Record.
> 
> Thx,
> 
> Barbara
>