Subject: Re: [TLS] draft-chudov-cryptopro-tlsprfneg-00.txt

From: "Gregory S. Chudov" <[email-masked]>
Date: Fri, 3 Jun 2005 22:00:01 +0400

Greetings.
Unfortunately, TLS does not allow a ciphersuite to choose a different PRF.

Quote from rfc2246:

   HMAC can be used with a variety of different hash algorithms. TLS
   uses it in the handshake with two different algorithms: MD5 and SHA-
   1, denoting these as HMAC_MD5(secret, data) and HMAC_SHA(secret,
   data). Additional hash algorithms can be defined by cipher suites and
   used to protect record data, but MD5 and SHA-1 are hard coded into
   the description of the handshaking for this version of the protocol.

So adding a cipher suite, which uses different PRF means breaking a
protocol.
Such cipher suites will not be "legitimate" without the support and analysis
from
this working group.

Good luck!
Greg Chudov

----- Original Message ----- 
From: <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Sent: Monday, May 30, 2005 8:58 AM
Subject: RE: [TLS] draft-chudov-cryptopro-tlsprfneg-00.txt

Hi,

It does seem that having a way to use some other PRF than the
standard one would be useful in some (very limited)
circumstances.

However, I'm not so sure about the usefulness of adding a
new negotiation mechanism for it. It was proposed earlier
that we could simply define the PRF (and the hash used when
calculating Finished messages) to be part of the ciphersuite;
this sounds like a reasonable and simple approach to me.

(Of course, for those ciphersuites that don't say anything
about the PRF, it would be the standard TLS-PRF, so there's
no need to have this included in 2246bis.)

Best regards,
Pasi

_______________________________________________
TLS mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tls

---

From: Kais Belgaied <[email-masked]>
Date: Fri, 03 Jun 2005 11:10:01 -0700

> So adding a cipher suite, which uses different PRF means breaking a

or introduce the new/negotiated PRF with a new minor version number of the
protocol: TLS1.1

	Kais.