Subject: [TLS] Re: 'ECC Cipher Suites for TLS' to Informational RFC

From: Vipul Gupta <[email-masked]>
Date: Fri, 07 Apr 2006 12:21:47 -0700

[Resending with a shortened cc list. My previous attempt 3 days
bounced with a "too many recipients" message. I had cc'd both
ADs, both co-chairs and the coauthors.]

Here's another note in the same vein as

http://www1.ietf.org/mail-archive/web/tls/current/msg00538.html
http://www1.ietf.org/mail-archive/web/tls/current/msg00489.html

identifying minor fixes that will be included in the
ECC in TLS spec before RFC publication. Details of the
change and Russ's note approving it are attached below
(the change has also been approved by Eric Rescorla).

The coauthors have tried their best to coordinate these
changes with all known implementors of this spec (including
Certicom, OpenSSL, Microsoft, Red Hat, Sun) but we apologize
for any inconvenience this causes to implementors we might
have overlooked.

[If you have an implementation and would like to participate
in interoperability testing, please send me email, see:
http://www1.ietf.org/mail-archive/web/tls/current/msg00535.html ]

thank you,

vipul

Begin forwarded message:

> From: Russ Housley <[email-masked]>
> Date: April 5, 2006 4:55:54 PM PDT
> To: Vipul Gupta <[email-masked]>, Eric Rescorla  
> <[email-masked]>, [email-masked],  
> [email-masked]
> Cc: Simon Blake-Wilson <[email-masked]>, Bodo Moeller  
> <[email-masked]>, Nelson B Bolyard <[email-masked]>, Chris  
> Hawk <[email-masked]>, Bob Lord <[email-masked]>, Nelson  
> Bolyard <[email-masked]>, Ari Medvinsky  
> <[email-masked]>, 'Bodo Moeller' <[email-masked]>,  
> Douglas Stebila <[email-masked]>, Rob Dugal  
> <[email-masked]>, Kenneth Zhang <[email-masked]>, Vipul  
> Gupta <[email-masked]>, [email-masked]
> Subject: Re: 'ECC Cipher Suites for TLS' to Informational RFC
>
> This is fine.
>
> At 06:00 PM 4/5/2006, Vipul Gupta wrote:
>
>> Hi Eric, Pasi, Sam and Russ,
>>
>>    Thanks for your prompt response. As you suggested,
>> we've posted a notification of this change (see
>> http://www1.ietf.org/mail-archive/web/tls/current/msg00538.html)
>>
>> Subsequently, we've become aware of two other places
>> (both in Section 5.4, Server Key Exchange) where the
>> draft can use additional clarification:
>>
>> 1) On page 22, it ought to point out that the "sha_hash"
>> in the "Signature" definition isn't a simple hash of the
>> EC params alone. Rather, it is the data structure defined
>> in Section 7.4.3 of the main TLS spec and includes
>> the client and server random values in addition to the
>> server params.
>>
>> 2) On page 22, it should say that the "r" and "s"
>> components of the ECDSA signature are DER encoded
>> (to be consistent with DSA).
>>
>> All implementations of this spec that we are aware of
>> (including those from Certicom, OpenSSL, Microsoft,
>> Red Hat and Sun) already encode this behavior (or plan
>> to do so soon).
>>
>> We (the coauthors and implementers on the cc list)
>> seek your permission to include these clarifications
>> during AUTH48.
>>
>> vipul
>>
>> On Mar 29, 2006, at 6:36 AM, Russ Housley wrote:
>>
>>
>>> I see no problem making this correction.  However, please post a
>>> message to the TLS WG mail list to notify everyone that this will
>>> happen.
>>>
>>> Russ
>>>
>>> At 06:23 PM 3/24/2006, Vipul Gupta wrote:
>>>
>>>> Hi Eric, Pasi, Sam and Russ,
>>>>
>>>>   We (the authors and implementers on the cc list)
>>>> have recently become aware of an inconsistency
>>>> in the latest version of the specification and seek
>>>> your permission to fix it during the AUTH48 period.
>>>>
>>>> When going from draft-ietf-tls-ecc-10.txt to
>>>> draft-ietf-tls-ecc-11.txt, the encoding of named
>>>> curves was changed from 1 byte to 2 bytes in response
>>>> to WG feedback. However, the corresponding change
>>>> in the encoding of the EllipticCurveList length
>>>> from 1 to 2 bytes was reflected in the examples
>>>> but not in the EllipticCurveList definition. This
>>>> made the examples in Section 5.1.1 inconsistent
>>>> with the adjacent text. We propose fixing the text
>>>> as follows:
>>>>
>>>>         struct {
>>>> -           NamedCurve elliptic_curve_list<1..2^8-1>
>>>> +           NamedCurve elliptic_curve_list<1..2^16-1>
>>>>         } EllipticCurveList;
>>>>
>>>> This change is consistent with the implementation
>>>> plans for Microsoft, Redhat, Sun and OpenSSL.
>>>>
>>>> We'd appreciate a quick response so we can bring
>>>> this resolution to the attention of other folks who
>>>> might be implementing this specification. Thank you
>>>> for your time.
>>>>
>>>> vipul
>>>>
>>
>>
>
>

_______________________________________________
TLS mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tls

---

From: Vipul Gupta <[email-masked]>
Date: Fri, 07 Apr 2006 15:16:16 -0700

A document incorporating the changes to draft-ietf-tls-ecc-12.txt
described in:
    http://www1.ietf.org/mail-archive/web/tls/current/msg00555.html
    http://www1.ietf.org/mail-archive/web/tls/current/msg00538.html
    http://www1.ietf.org/mail-archive/web/tls/current/msg00489.html
is now available at:
    http://dev.experimentalstuff.com:8082/DRAFT3-draft-ietf-tls- 
ecc-13.txt

vipul

p.s. Thanks Bodo!