Subject: [TLS] Looking for Test cases or Documents with Byte Samples

From: "Ron Teitelbaum" <[email-masked]>
Date: Wed, 26 Jul 2006 22:51:54 -0400

All,

I have Yngve Pettersen document but I've been looking for other test cases.
Are test cases being collected anywhere, or are there other documents with
sample bytes that someone can point me too?  Specifically right now I'm
looking to test my parsing of the hello extensions.  

There were some good examples in Yngve's document of server name and status
request OCSP PKIX extensions that were very useful for testing. 

Thank you for your help and any suggestions.

Ron Teitelbaum
President / Principal Software Engineer
US Medical Record Specialists
[email-masked] 

> -----Original Message-----
> From: Yngve N. Pettersen 
> Sent: Friday, July 21, 2006 8:34 PM
> 
> 
> You might also want to check this Internet-Draft that I recently
> published:
> 
>     http://www.ietf.org/internet-drafts/draft-pettersen-tls-interop-
> experience-00.txt
> 

_______________________________________________
TLS mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tls

---

From: "Ron Teitelbaum" <[email-masked]>
Date: Fri, 28 Jul 2006 12:08:23 -0400

Brian,

Thank you for your suggestion I will contact your sales team to inquire
about special pricing for open source projects.

Ron Teitelbaum
Squeak Cryptography Team Leader
www.squeak.org 
President / Principal Software Engineer
US Medical Record Specialists
[email-masked] 

> From: Brian Minard 
> Sent: Thursday, July 27, 2006 9:28 PM
> 
> I had a discussion with Yngve on making test servers publicly
> available--he doesn't have anything presently, but had some
> ideas on what might need to be built. Yngve tells me that
> [email-masked] is working on something--unclear if it's
> publicly available.
> 
> If you have cash, you might look at Codenomicon's TLS Test tool
> (http://www.codenomicon.com/). It doesn't cover Yngve's draft but
> it's a step in the same direction.
> 
> --
> Brian Minard ([email-masked])
> Engineering Manager, Connection Security Team, Certicom Corp.
> cel: 416-579-4637
> tel: 905-501-3858
> http://www.certicom.com