Subject: [TLS] I got error message : [tls/tls_init.o] Error 1....Please help me..please

From: Ferianto siregar <[email-masked]>
Date: Fri, 30 Jun 2006 22:35:50 -0700 (PDT)

Dear all,
     
When i try to compile again  TLS ( I have disabled Kerberos) by using Command ,TLS=1 make install, I got an error message. 
  It is the error message :
     
make: *** [tls/tls_init.o] Error 1
     
 What should i do else? I am very confused. This is my first time to build TLS. Please help me..Please…..
   
  Note: Below is the message shown when i compile TLS support
     gcc -g -O9 -funroll-loops  -Wcast-align  -Wall   -minline-all-stringops -malign-double -         falign-loops -mcpu=athlon      -DNAME='"openser"' -DVERSION='"1.0.1-tls"' -DARCH='"i386"' -DOS='"linux"' -DCOMPILER='"gcc 3.2.2"' -D__CPU_i386 -D__OS_linux -DCFG_DIR='"/usr/local/etc/openser/"' -DPKG_MALLOC -DSHM_MEM  -DSHM_MMAP -DDNS_IP_HACK -DUSE_IPV6 -DUSE_MCAST -DUSE_TCP -DDISABLE_NAGLE -DHAVE_RESOLV_RES -DF_MALLOC -DOPENSSL_NO_KRB5  -DUSE_TLS -DFAST_LOCK -DADAPTIVE_WAIT -DADAPTIVE_WAIT_LOOPS=1024  -DHAVE_GETHOSTBYNAME2 -DHAVE_UNION_SEMUN -DHAVE_SCHED_YIELD -DHAVE_MSG_NOSIGNAL -DHAVE_MSGHDR_MSG_CONTROL -DHAVE_ALLOCA_H -I/usr/local/ssl/include -c tls/tls_init.c -o tls/tls_init.o
  tls/tls_init.c:373:25: directives may not be used inside a macro argument
  tls/tls_init.c:372:56: unterminated argument list invoking macro "SSL_CTX_set_options"
  tls/tls_init.c: In function `init_ssl_ctx_behavior':
  tls/tls_init.c:376: `SSL_CTX_set_options' undeclared (first use in this function)
  tls/tls_init.c:376: (Each undeclared identifier is reported only once
  tls/tls_init.c:376: for each function it appears in.)
  tls/tls_init.c:376: parse error before ')' token
  make: *** [tls/tls_init.o] Error 1
       
Thank you very much. If I make any mistake...Please forgive me..Thanks

     Regards,
   
  Ferianto

---------------------------------
Talk is cheap. Use Yahoo! Messenger to make PC-to-Phone calls.  Great rates starting at 1¢/min.

_______________________________________________
TLS mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tls

---

From: "Kyle Hamilton" <[email-masked]>
Date: Fri, 30 Jun 2006 23:23:10 -0700

This is not a support mailing list.  Please do not send requests for
help with any given implementation here.

This list is for the discussion of the underlying network protocol
called TLS.  Please obtain support from the software vendor, or
software author's designated support mechanism.  We cannot help you,
here.

-Kyle H

On 6/30/06, Ferianto siregar <[email-masked]> wrote:
>
> Dear all,
>
> When i try to compile again  TLS ( I have disabled Kerberos) by using
> Command ,TLS=1 make install, I got an error message.
>  gcc -g -O9 -funroll-loops  -Wcast-align  -Wall   -minline-all-stringops
> -malign-double -         falign-loops -mcpu=athlon      -DNAME='"openser"'
> -DVERSION='"1.0.1-tls"' -DARCH='"i386"' -DOS='"linux"' -DCOMPILER='"gcc
> 3.2.2"' -D__CPU_i386 -D__OS_linux
> -DCFG_DIR='"/usr/local/etc/openser/"' -DPKG_MALLOC
> -DSHM_MEM  -DSHM_MMAP -DDNS_IP_HACK -DUSE_IPV6 -DUSE_MCAST -DUSE_TCP
> -DDISABLE_NAGLE -DHAVE_RESOLV_RES -DF_MALLOC -DOPENSSL_NO_KRB5  -DUSE_TLS
> -DFAST_LOCK -DADAPTIVE_WAIT -DADAPTIVE_WAIT_LOOPS=1024
> -DHAVE_GETHOSTBYNAME2 -DHAVE_UNION_SEMUN -DHAVE_SCHED_YIELD
> -DHAVE_MSG_NOSIGNAL -DHAVE_MSGHDR_MSG_CONTROL -DHAVE_ALLOCA_H
> -I/usr/local/ssl/include -c tls/tls_init.c -o tls/tls_init.o
>  ________________________________