Subject: [TLS] TLS WG Summary

From: EKR <[email-masked]>
Date: Thu, 13 Jul 2006 04:51:54 -0700

The TLS WG WG met at 3:20 on Tuesday.

The major topic of discussion was TLS 1.2. There were no major
comments on the current status of the document. We discussed
a bunch of options on negotiating PRFs and backward compatibility
and expect to meet our milestones.

TLS Counter Mode is basically done and the chairs will be taking
it to WG Last Call immediately after IETF.

Andrea Doherty presented OTP for PSK for IETF. Group read was
that this wasn't secure enough in its current form to take
on.

Uri Blumenthal presented on TLS-PSK NULL encryption mode.
The WG agreed this was a good idea and Pasi and Joe Salowey
agreed to review it

Yngve Pettersen presented his work on TLS interop. This was
considered good and the TLS WG agreed to take it on. Ben Laurie
and Stefan Santesson are going to provide more examples
of interoperability.

Michael Tuexen presented on running DTLS over SCTP. The issue
is that SCTP has a partially reliable mode and they need to
protect against packet drops. SCTP AUTH does this but needs
keying material. They want to extract it from DTLS, but this
has layering issues. Michael Tuexen to post about this to the
DTLS mailing list.

_______________________________________________
TLS mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tls

---

From: Nikos Mavrogiannopoulos <[email-masked]>
Date: Tue, 18 Jul 2006 09:02:33 +0200

> it to WG Last Call immediately after IETF.

I have a question on the design of ctr.
According to the text:

3.1.3.  Counter Block Construction

   To construct the counter block, the leftmost 48-bits of the counter
   block are set to the rightmost 48-bits of the client_write_IV (for
   the half-duplex stream originated by the client) or the rightmost 48-
   bits of the server_write_IV (for the half-duplex stream originated by
   [...]

This would mean that say for AES an 128-bit IV is generated just to use 
the 48 rightmost bits. Why is this done? Wouldn't it be simpler to say
that the IV is 48 bits in CTR mode?

regards,
Nikos