Subject: [TLS] I put up a TLS test server

From: Mike <[email-masked]>
Date: Wed, 22 Nov 2006 13:08:06 -0800

There is a TLS 1.2 (draft) test server running at:

     https://www.mikestoolbox.net:4433/

It also supports TLS 1.1, 1.0, and SSL3 (and SSL2
client hello).  The server name, max fragment length,
and truncated HMAC extensions are also implemented.

It supports RSA, DHE_RSA, and DHE_DSS key exchange
methods, and AES_256, AES_128, and DES3 encryption.

If you connect to it at:

     https://www.mikestoolbox.org:4433/

and send it a server name extension, it will return
a different certificate.  I just changed the DNS, so
if you can't connect, try 24.234.114.35.

Note the server is iterative, so only one connection
will be handled at a time.  It will return some info
about the TLS session if negotiation succeeds.

The server should be able to handle any pathological
fragmentation of handshake messages.

Please let me know if you have any problems negotiating
a session.

Thanks,

Mike

_______________________________________________
TLS mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tls

---

From: Mike <[email-masked]>
Date: Thu, 23 Nov 2006 14:04:10 -0800

I neglected to install a DSA certificate chain, so the
DHE_DSS cipher suites weren't working.  I have fixed
it, so it should work now.  Note that there is only
one DSA certificate chain, so to test the server name
extension, you need to negotiate with RSA or DHE_RSA.

Mike