Subject: RE: [TLS] Truncated HMAC recommendation

From: "Blumenthal, Uri" <[email-masked]>
Date: Mon, 27 Nov 2006 13:37:23 -0500

MAC truncation is not done to save bytes over the wire.

-----Original Message-----
From: Mike [mailto:[email-masked]] 
Sent: Monday, November 27, 2006 1:35 PM
To: [email-masked]
Subject: [TLS] Truncated HMAC recommendation

I think it would be good to add a recommendation
that when the truncated HMAC extension is used,
the amount of padding added for block ciphers
should be the minimum required.  It seems silly
to save 10 bytes of MAC data and then add 250+
extra padding bytes.

Mike

_______________________________________________
TLS mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tls

_______________________________________________
TLS mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tls

---

From: Mike <[email-masked]>
Date: Mon, 27 Nov 2006 11:13:48 -0800

> MAC truncation is not done to save bytes over the wire.

The spec says that "it may be desirable in constrained
environments to save bandwidth by truncating the output
of the hash function to 80 bits when forming MAC tags."

If that weren't the case, why would you want to truncate
the MAC?

Mike