Subject: RE: [TLS] compression

From: Peter Williams <[email-masked]>
Date: Mon, 27 Nov 2006 08:53:06 -0800

It really doesn't provide much practical information - although is mostly correct and excellent, in it own right. It does say in standardese much that was not stated in the implementors/analysts writeup of SSL3, concerning compression and fragmentation/reassembly procedures performed at the SSL Handshake/SSL Record layer boundary. Be aware, that https compression practices are distinct from SSL compression design, understanding that compression is based on the many of the same math principles as type 2 cipher designs, and have many of the same pitfalls when added to packet networking environments.
 
Perhaps, take your new SSL library, and now apply it to class d addressed applications.  Take that code and apply it to the types of streams exchanged between class d addressed applications, and see where it takes you: in the stream-specific compression world, the supprot required of the SSL record layer, the key management, and the socket/API controls. 
 
Never forget that the SSL (and TLS1.0) writeup only ever represented one view of the SSL patent: how to make a lightweight interoperable library, targeting "browsers" and SSL Connection proxies.

> Date: Mon, 27 Nov 2006 16:50:24 +0100> From: [email-masked]> To: [email-masked]> Subject: Re: [TLS] compression> CC: [email-masked]> > On Mon, Nov 27, 2006 at 07:42:01AM -0800, Mike wrote:> > > Are there any specs for standard compression> > schemes for TLS?> > Yes, please take a look at RFC 3749.> > Bodo> > > _______________________________________________> TLS mailing list> [email-masked]> https://www1.ietf.org/mailman/listinfo/tls
_________________________________________________________________
Check the weather nationwide with MSN Search: Try it now!
http://search.msn.com/results.aspx?q=weather&FORM=WLMTAG

_______________________________________________
TLS mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tls

---

From: Mike <[email-masked]>
Date: Mon, 27 Nov 2006 10:09:58 -0800

> Perhaps, take your new SSL library, and now apply it to class d 
> addressed applications.  Take that code and apply it to the types of 
> streams exchanged between class d addressed applications, and see where 
> it takes you: in the stream-specific compression world, the supprot 
> required of the SSL record layer, the key management, and the socket/API 
> controls.

What is a "class d addressed application"?

Thanks,

Mike