Subject: [TLS] compression of certificates

From: Ken Peirce <[email-masked]>
Date: Wed, 8 Aug 2007 13:31:22 -0700 (PDT)

Hi All,
   
  I am a bit confused. If I wish to use non-null compression and non-null encryption with certificates, can I compress the certificates prior to sending them or can compression only run after the handshake is done?
   
  Cheers,
  Ken
   
_______________________________________________
TLS mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tls

---

From: Mike <[email-masked]>
Date: Wed, 08 Aug 2007 13:58:44 -0700

> I am a bit confused. If I wish to use non-null compression and non-null 
> encryption with certificates, can I compress the certificates prior to 
> sending them or can compression only run after the handshake is done?

The certificates are sent during the initial handshake, so they are
not compressed.

There is an extension for client certificate URL's that you may be
interested in.  Instead of sending the certificate, you send a URL
from which it can be retrieved.  See RFC 4366 for details.

Mike