Subject: [TLS] Implementation survey: Client Certificate URL extension

From: <[email-masked]>
Date: Tue, 18 Mar 2008 13:39:49 +0200

Hi,

We currently have two open technical issues for 4366bis,
both related to the Client Certificate URL extension (#45 
about making the hash mandatory; and #46 on how to do
algorithm agility).

The proposal in IETF71 was to make including the hash a MUST
(regardless of TLS version number), and handle algorithm agility 
with a new extension number later (if it turns out something
actually needs to be done).

However, making the hash mandatory has some potential for interop
problems (if there are old implementations which don't send it).

If you have implemented, or have heard of someone implementing, 
the client_certificate_url extension, please send email.  
Additional details (is this a client, server, or both; do you 
send the hash, etc.) are welcome but not required.

Best regards,
Pasi
_______________________________________________
TLS mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tls

---

From: Rob Dugal <[email-masked]>
Date: Tue, 18 Mar 2008 09:09:16 -0400

Certicom's Security Builder SSL-C toolkit supports the 
client_certificate_url extension. Use of the hash is optional but 
recommended.
The toolkit is a C language SDK for creating client or server 
applications,with support for SSLv2, SSLv3, TLS v1.0, TLS v1.1, DTLS v1.0.

-----------------------------------------------
Robert Dugal
Member of Development Group
Certicom Corp.
EMAIL: [email-masked]
PHONE: (905) 501-3848
FAX  : (905) 507-4230
WEBSITE: www.certicom.com

---

From: "Dieter Bratko" <[email-masked]>
Date: Tue, 18 Mar 2008 17:48:16 +0100

Hello,

our IAIK iSaSiLk Java SSL/TLS library supports the 
client_certificate_url extension (client and server side).
Including the hash is optional. 

Regards,
Dieter

---------
Dieter Bratko, <mailto:[email-masked]>
SIC/IAIK - Graz University of Technology
IAIK, Inffeldgasse 16a, 8010 Graz, Austria, http://jce.iaik.tugraz.at/

----- Original Message ----- 
From: [email-masked] 
To: [email-masked] 
Sent: Tuesday, March 18, 2008 12:39 PM
Subject: [TLS] Implementation survey: Client Certificate URL extension

Hi,

Best regards,
Pasi