Subject: [TLS] draft-badra-tls-psk-new-mac-aes-gcm as WG item (was: RE: Re: TLS document status update)

From: <[email-masked]>
Date: Fri, 2 May 2008 12:09:23 +0300

[email-masked] wrote:

> Dear Pasi and Eric,
> 
> I would like to inform you and the WG that I submitted a document
> (draft-badra-tls-psk-new-mac-aes-gcm), which specifies combinations
> of AES_GCM and PSK, and dsecribes a set of ciphersuites with
> stronger digest algorithms.
> 
> http://www.ietf.org/internet-drafts/draft-badra-tls-psk-new-mac-aes-gcm-02.txt
> 
> Since the document is based and heavily borrows from
> draft-ietf-tls-ecc-new-mac and draft-ietf-tls-rsa-aes-gcm, I would
> like to request that the TLS WG adopts this document as a WG item.

Comments from TLS WG members? (E.g., volunteers who promise to 
contribute text during the document's development)

(To take this as a WG item, we actually need a *group* of people
willing to work on this.)

Best regards,
Pasi
_______________________________________________
TLS mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tls

---

From: [email-masked]
Date: Mon, 5 May 2008 14:17:35 +0200 (CEST)

Dear Pasi,

> willing to work on this.)

I asked for volunteers to contribute text during the document
devecopement, and I received promises from:

Pascal Urien, [email-masked]
Alfred Hines, [email-masked]
Hassnaa Moustafa, [email-masked]

I hope other WG members are willing to work on that document.

Best regards,
Badra

---

From: "Joseph Salowey (jsalowey)" <[email-masked]>
Date: Mon, 5 May 2008 08:14:33 -0700

I would review the document.  

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of [email-masked]
> Sent: Monday, May 05, 2008 5:18 AM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]
> Subject: Re: [TLS]  draft-badra-tls-psk-new-mac-aes-gcm as WG 
> item (was: RE: Re:  TLS document status update )
> 
> Dear Pasi,
>

---

From: Simon Josefsson <[email-masked]>
Date: Tue, 06 May 2008 14:27:43 +0200

> contribute text during the document's development)

The document seems basically done to me, so I'm not sure anyone can
provide much additional text to it.

However, for the record, I have and will continue to review the
document.

Badra, there is a problem in the current document.  It is the same
problem I pointed out for TLS-RSA-AES-GCM: The Galois Counter mode can
fail to decrypt, and the document needs to describe how that should be
handled by implementations.  I suggest to adopt the same fix made in

http://www.ietf.org/internet-drafts/draft-ietf-tls-rsa-aes-gcm-03.txt

specifically, to add:

   Implementations MUST send TLS Alert bad_record_mac for all types of
   failures encountered in processing the AES-GCM algorithm.

Thanks,
Simon

---

From: [email-masked]
Date: Tue, 6 May 2008 17:53:30 +0200 (CEST)

Dear Simon,

Thank you for your review.

>    failures encountered in processing the AES-GCM algorithm.

I adopted the same text, it is already included in section 2 (at the end).

Best regards,
Badra

---

From: Simon Josefsson <[email-masked]>
Date: Tue, 06 May 2008 23:58:18 +0200

> I adopted the same text, it is already included in section 2 (at the end).

Duh!  Then I don't have any remaining issues for now, but will review it
again if it is adopted by the WG and moves to WGLC.

Thanks,
Simon

---

From: [email-masked]
Date: Wed, 7 May 2008 00:12:55 +0200 (CEST)

> ... if it is adopted by the WG and moves to WGLC.

It is now up to Eric and Pasi to decide whether to adopt the document or
not :-)

Best regards,
Badra