Subject: [TLS] FW: draft-badra-tls-psk-new-mac-aes-gcm-02

From: "Joseph Salowey (jsalowey)" <[email-masked]>
Date: Fri, 16 May 2008 08:54:52 -0700

Here is a message from Alfred who was having trouble sending to the list. 

-----Original Message-----
From: Alfred HÎnes [mailto:[email-masked]] 
Sent: Thursday, May 15, 2008 2:58 PM
To: Joseph Salowey (jsalowey)
Subject: draft-badra-tls-psk-new-mac-aes-gcm-02

Various work-in-progress documents currently contribute to the definition of TLS ciper suites using the stronger SHA-2 family of cryptographic hashes, which has become viable by the amendments and additional algorithm agility built into TLS 1.2.

The latest revision (-07) of draft-ietf-tls-ecc-new-mac has removed the 'secondary' lists of the newly introduced TLS ECC cipher suites in favor of text explaining the regular CipherSuite naming pattern followed and giving more details on the particular algorithms/mechanisms indicated by the new ciper suite names.  This principle seems to be useful -- easily retainable rules are more friendly to the reader than long tables.

Another I-D offered to the TLS WG,
      draft-badra-tls-psk-new-mac-aes-gcm-02,
aims at defining similar new TLS cipher suites, but for the 'classical' (non-ECC) Pre-Shared Key scenario of RFC 4279.
This draft already follows the above principle in its Section 2.

To achieve a more homogenous style -- within that document and among all similar documents --, and in support of enhanced readability, as noted above, I suggest that a similar change be performed for Sections 3.1 ... 3.3 of draft-badra-tls-psk-new-mac-aes-gcm, i.e.:

- State the rules for deriving the new CipherSuite names from
  existing ones, and which PRF and MAC algorithms are indicated
  by these new name suffixes -- perhaps, a single instance of
  the explanation of PRFs and MACs will suffice;

- remove the 'secondary' tables from Sections 3.1 ... 3.3 which
  presently serve to give a terse, tabular representation of the
  same information.

Alfred.

_______________________________________________
TLS mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tls

---

From: [email-masked]
Date: Sat, 17 May 2008 15:45:05 +0200 (CEST)

Dear Joe and Alfred,

> Here is a message from Alfred who was having trouble sending to the list.

Thank you for the forwarding.

> From: Alfred H�nes [mailto:[email-masked]]

> Various work-in-progress documents currently contribute to the definition
> of TLS ciper suites using the stronger SHA-2 family of cryptographic
> hashes, which has become viable by the amendments and additional algorithm
> agility built into TLS 1.2.
>
> The latest revision (-07) of draft-ietf-tls-ecc-new-mac has removed the
> 'secondary' lists of the newly introduced TLS ECC cipher suites in favor
> of text explaining the regular CipherSuite naming pattern followed and
> giving more details on the particular algorithms/mechanisms indicated by
> the new ciper suite names.  This principle seems to be useful -- easily
> retainable rules are more friendly to the reader than long tables.
>
> aims at defining similar new TLS cipher suites, but for the 'classical'
> (non-ECC) Pre-Shared Key scenario of RFC 4279.
> To achieve a more homogenous style -- within that document and among all
> similar documents --, and in support of enhanced readability, as noted
> above, I suggest that a similar change be performed for Sections 3.1 ...
> 3.3 of draft-badra-tls-psk-new-mac-aes-gcm, i.e.:
>

I submitted an updated version that includes the above comments.

> Alfred.

Many thanks.
Best regards,
Badra