Subject: [TLS] draft-ietf-tls-rfc4347-bis-00.txt

From: Robin Seggelmann <[email-masked]>
Date: Tue, 14 Oct 2008 10:04:37 +0200

Hello all,
I was just checking the draft for changes relevant to DTLS over SCTP  
and came across the following new paragraph:

- For DTLS over TCP or SCTP, which automatically fragment
   and reassemble datagrams, the upper layer protocol
   SHOULD be informed that the PMTU is effectively infinite.

What does 'effectively infinite' mean? TLS limits the message size to  
2^14 bytes, so shouldn't this limit also apply to DTLS? If the  
message size really is arbitrary, doesn't this affect some cipher  
algorithms? Or should the application then ignore the announced  
'infinite' PMTU and limit the message size anyway?

Regards,
Robin
_______________________________________________
TLS mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tls

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 14 Oct 2008 03:46:57 -0700

At Tue, 14 Oct 2008 10:04:37 +0200,
> 'infinite' PMTU and limit the message size anyway?

Yes, that's a fair point. OTOH, this is a maximum message size
which is related to, but not identical to, the PMTU. Operationally
the application needs to restrict itself to 2^14 and associated
limits. I'm tempted to simply add a parenthetical "(though of
course applications still MUST NOT write any record that exceeds
2^14 bytes)"

-Ekr

---

From: Michael Tüxen <[email-masked]>
Date: Tue, 14 Oct 2008 13:40:21 +0200

Hi Eric,

I would prefer something like:

- For DTLS over TCP or SCTP, which automatically fragment
   and reassemble datagrams, the upper layer protocol
   MUST NOT write any record that exceeds 2^14 byte.

The reason is that a while ago it took me some time
to understand that someone talking about small messages
really was talking about messages of 64KB. Large message
were about several MB. I'm not sure what these guys
would understand when reading "effectively infinite".

Best regards
Michael

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 14 Oct 2008 05:00:57 -0700

At Tue, 14 Oct 2008 13:40:21 +0200,
>    MUST NOT write any record that exceeds 2^14 byte.

So, this covers the upper limit, but I think it should
probably also indicate that there is no PMTU limitation.
I.e.,

- For DTLS over TCP or SCTP, which automatically fragment
   and reassemble datagrams, there is no PMTU limitation.
   However, the upper layer protocol MUST NOT write any
   record that exceeds the maximum record size of 2^14 bytes.

-Ekr

---

From: Michael Tüxen <[email-masked]>
Date: Tue, 14 Oct 2008 15:27:04 +0200

>   record that exceeds the maximum record size of 2^14 bytes.
Sounds good to me...

Best regards
Michael