Subject: [TLS] Name suggestions for tls-extractor

From: <[email-masked]>
Date: Thu, 20 Nov 2008 21:34:51 +0200

Some ideas if we want to avoid the word "extractor":

"Exporting Keying Material from Transport Layer Security (TLS)"
(the word "export" is already used in the document)

"Deriving Exported Keying Material from Transport Layer 
Security (TLS) Master Secret"

"TLS Hoover" (or maybe not :-)

Best regards,
Pasi
_______________________________________________
TLS mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tls

---

From: Michael Tüxen <[email-masked]>
Date: Thu, 20 Nov 2008 14:47:07 -0600

Or

Key Material Provider based on Transport Layer Security (TLS)

Best regards
Michael

On Nov 20, 2008, at 1:34 PM, <[email-masked]> <[email-masked] 
 > wrote:

---

From: "Mohamad Badra" <[email-masked]>
Date: Thu, 20 Nov 2008 22:00:56 +0100 (CET)

Hi,

> Key Material Provider based on Transport Layer Security (TLS)

I think it may be better to add a pointer to the TLS Master Secret:

Key Material Provider based on Transport Layer Security (TLS) Master Secret

Best regards,
Badra

-- 
Mohamad Badra
CNRS - LIMOS Laboratory

---

From: Michael Tüxen <[email-masked]>
Date: Thu, 20 Nov 2008 15:27:53 -0600

Sounds good to me...

Best regards
Michael

---

From: Simon Josefsson <[email-masked]>
Date: Thu, 20 Nov 2008 22:42:40 +0100

> Some ideas if we want to avoid the word "extractor":

"Key expansion" is a commonly used term when making new keys from a PRF,
has it been considered?

I guess the more serious aspect is whether the recommended TLS PRF label
prefix should also be modified from EXTRACTOR to something else.

/Simon

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 20 Nov 2008 15:55:18 -0600

At Thu, 20 Nov 2008 22:42:40 +0100,
> "Key expansion" is a commonly used term when making new keys from a PRF,

Yeah, but I'd like a term that indicates that we're moving data
out of TLS into other applications.

> prefix should also be modified from EXTRACTOR to something else.

I think so, yeah.

But that depends on what we use :)

-Ekr

---

From: Florian Weimer <[email-masked]>
Date: Sat, 22 Nov 2008 18:16:27 +0100

> out of TLS into other applications.

Application key derivation?  Isn't it, technically a key agreement
protocol?  What about application key agreement?

-- 
Florian Weimer                <[email-masked]>
BFK edv-consulting GmbH       http://www.bfk.de/
Kriegsstraße 100              tel: +49-721-96201-1
D-76133 Karlsruhe             fax: +49-721-96201-99
_______________________________________________
TLS mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tls

---

From: Eric Rescorla <[email-masked]>
Date: Sat, 22 Nov 2008 13:55:11 -0700

At Sat, 22 Nov 2008 18:16:27 +0100,
> protocol?  What about application key agreement?

Well, there's no real agreement. It's just sucked out of TLS...

-Ekr