Subject: [TLS] consensus on adopting draft-mcgrew-tls-aes-ccm and draft-mcgrew-tls-aes-ccm-ecc

From: Joe Salowey <[email-masked]>
Date: Wed, 30 Nov 2011 13:34:59 -0800

The chairs would like to see if there is consensus in the TLS working group to adopt draft-mcgrew-tls-aes-ccm and draft-mcgrew-tls-aes-ccm-ecc as working group items.  These drafts define AES-CCM cipher suites for TLS.  The Zigbee smart energy group has interest in these drafts.   These drafts only deal with a AES-CCM and not with Zigbee's AES-CCM* which is a super set of AES-CCM.  The authors are requesting standards track for these ciphers.  Please note that there is an IPR declaration listed for draft-mcgrew-tls-aes-ccm-ecc available here:  https://datatracker.ietf.org/ipr/1443/.  This declaration has been updated from previous declarations.   Please respond to the following by December 14, 2011 :

- Do you object to taking these drafts on as working group items? (Please state the reason for you objection)

- Would you contribute time to review and provide text for the documents when needed?

- Do you object to standards track status for these documents?(Please state the reason for you objection)

Cheers,

Joe

---

From: Yoav Nir <[email-masked]>
Date: Thu, 1 Dec 2011 00:20:26 +0200

> - Do you object to taking these drafts on as working group items? (Please state the reason for you objection)

Sort of. These kinds of documents defining new ciphersuites or algorithms ("my-favorite-algorithm and its use in TLS, IPsec, SSH") seldom get meaningful review in the working groups. Most of us are not cryptographers, and those who are usually remain silent. Sometimes you get some objections like why waste 8 whole code points for this group of ciphersuites, wouldn't 4 be enough, but these objections rarely cause a change. IOW I don't think the working group would contribute much to such a document.

> - Would you contribute time to review and provide text for the documents when needed?

Probably not.

> - Do you object to standards track status for these documents?(Please state the reason for you objection)

No objections at all.

---

From: Don Sturek <[email-masked]>
Date: Wed, 30 Nov 2011 14:31:42 -0800

Hi Joe,

Some comments on your questions below (inline):

On 11/30/11 1:34 PM, "Joe Salowey" <[email-masked]> wrote:

>The chairs would like to see if there is consensus in the TLS working
>group to adopt draft-mcgrew-tls-aes-ccm and draft-mcgrew-tls-aes-ccm-ecc
>as working group items.  These drafts define AES-CCM cipher suites for
>TLS.  The Zigbee smart energy group has interest in these drafts.   These
>drafts only deal with a AES-CCM and not with Zigbee's AES-CCM* which is a
>super set of AES-CCM.  The authors are requesting standards track for
>these ciphers.  Please note that there is an IPR declaration listed for
>draft-mcgrew-tls-aes-ccm-ecc available here:
>https://datatracker.ietf.org/ipr/1443/.  This declaration has been
>updated from previous declarations.   Please respond to the following by
>December 14, 2011 :
>

I believe these drafts should be working group items so, no, I don't
object.

>- Would you contribute time to review and provide text for the documents

Yes, I will help David and the draft authors as needed.

>state the reason for you objection)

I believe these drafts should be standards track so, no, I don't object.
The reason for making these standards track is that IEEE 802.15.4 uses
AES-CCM and this will allow existing hardware implementations in IEEE
802.15.4 devices to natively support a TLS cipher suite.

>
>
>Cheers,
>
>Joe
>_______________________________________________
>TLS mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/tls

---

From: Peter Gutmann <[email-masked]>
Date: Thu, 01 Dec 2011 16:52:29 +1300

Joe Salowey <[email-masked]> writes:

>The chairs would like to see if there is consensus in the TLS working group
>to adopt draft-mcgrew-tls-aes-ccm and draft-mcgrew-tls-aes-ccm-ecc as working
>group items.  These drafts define AES-CCM cipher suites for TLS.

Oh, and while that's being done can I add a third one, draft-gutmann-tls-
eccsuites-02.txt, available at
http://tools.ietf.org/html/draft-gutmann-tls-eccsuites-02?  This has already
been discussed on the list in the past, there are interoperable
implementations, it just needs to be moved to the RFC stage to get the
necessary code points allocated.

Peter.

---

From: [email-masked]
Date: Thu, 1 Dec 2011 15:16:00 +0800

[email-masked] 写于 2011-12-01 05:34:59:

> The chairs would like to see if there is consensus in the TLS 
> working group to adopt draft-mcgrew-tls-aes-ccm and draft-mcgrew-
> tls-aes-ccm-ecc as working group items.  These drafts define AES-CCM
> cipher suites for TLS.  The Zigbee smart energy group has interest 
> in these drafts.   These drafts only deal with a AES-CCM and not 
> with Zigbee's AES-CCM* which is a super set of AES-CCM.  The authors
> are requesting standards track for these ciphers.  Please note that 
> there is an IPR declaration listed for draft-mcgrew-tls-aes-ccm-ecc 
> available here:  https://datatracker.ietf.org/ipr/1443/.  This 
> declaration has been updated from previous declarations.   Please 
> respond to the following by December 14, 2011 :
> 
> - Do you object to taking these drafts on as working group items? 
> (Please state the reason for you objection)

No.

> - Would you contribute time to review and provide text for the 

Yes, pleasure.

> 
> - Do you object to standards track status for these documents?
> (Please state the reason for you objection)

No.

-Sujing 

> Joe

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.