Subject: [TLS] ECC key exchange messages

From: Swarupa <[email-masked]>
Date: Wed, 8 May 2013 09:27:22 +0530

Hi ,
I am working on an ECC project, so I wanted to check packet capture for ECC
key exchange,but when I run s_server with cipher as ECDH_RSA cipher set and
try to connect from s_client,I see alert instead of server hello from
server. What is the issue. How can I get openssl to use EDCH ciphers.

Thanks and Regards,
Swarupa

---

From: Juho Vähä-Herttua <[email-masked]>
Date: Wed, 8 May 2013 08:38:42 +0300

On 8.5.2013, at 6.57, Swarupa <[email-masked]> wrote:

> Hi ,
> I am working on an ECC project, so I wanted to check packet capture for ECC key exchange,but when I run s_server with cipher as ECDH_RSA cipher set and try to connect from s_client,I see alert instead of server hello from server. What is the issue. How can I get openssl to use EDCH ciphers.

This might be an irrelevant question, but are you sure you want ECDH_RSA and not ECDHE_RSA? ECDH is a fixed-ECDH cipher suite and requires a server certificate that is signed with RSA and contains an ECDH public key. ECDHE is an ephemeral suite where the keys are generated separately for each new session, this works for "traditional" RSA certificates that contain no ECDH keys.

Juho