Subject: [TLS] Incorporate by reference

From: "Salz, Rich" <[email-masked]>
Date: Thu, 17 Apr 2014 17:58:43 -0400

There are several TLS-related RFC's that we probably want to roll up into TLS 1.3.  One thing we should consider is to incorporate them by reference.  For example, have a section that says

      The TLS padding specification, RFC nnnn, is to be considered part of this document and is incorporated by reference, with the following changes:

1.       .... Whatever... if there are any.

Be more explicit than just an entry in the 'normative reference' list.  And it gives us a chance to explicitly list errata, exceptions, etc.

There cases where this makes sense, and cases (encrypt then mac) where it doesn't.     But I think it's a worthwhile tool to have in the editor's toolbox.

--
Principal Security Engineer
Akamai Technology
Cambridge, MA

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 17 Apr 2014 15:15:37 -0700

On Thu, Apr 17, 2014 at 2:58 PM, Salz, Rich <[email-masked]> wrote:

> There are several TLS-related RFC's that we probably want to roll up into
> TLS 1.3.  One thing we should consider is to incorporate them by
> reference.  For example, have a section that says
>
>
>
>       The TLS padding specification, RFC nnnn, is to be considered part of
> this document and is incorporated by reference, with the following changes:
>
> Be more explicit than just an entry in the 'normative reference' list.
> And it gives us a chance to explicitly list errata, exceptions, etc.
>
>
>
> There cases where this makes sense, and cases (encrypt then mac) where it
> doesn't.     But I think it's a worthwhile tool to have in the editor's
> toolbox.
>

This does seem like a useful tool. We'll need to use some taste to determine
where this is appropriate and where copying the text in is best.

-Ekr

---

From: Paul Hoffman <[email-masked]>
Date: Thu, 17 Apr 2014 15:48:02 -0700

> where this is appropriate and where copying the text in is best.

And for the ones where you thought about it, but didn't pull stuff in, it is still useful to list those RFCs in 1.3. "In addition to the RFCs that have been incorporated into this document, TLS implementers should certainly also consider implementing RFCs abcd and efgh."

--Paul Hoffman

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 17 Apr 2014 15:50:41 -0700

On Thu, Apr 17, 2014 at 3:48 PM, Paul Hoffman <[email-masked]> wrote:

> And for the ones where you thought about it, but didn't pull stuff in, it
> is still useful to list those RFCs in 1.3. "In addition to the RFCs that
> have been incorporated into this document, TLS implementers should
> certainly also consider implementing RFCs abcd and efgh."
>

+1.

-Ekr