Subject: [TLS] registering x-509 mime types

From: "[email-masked]" <[email-masked]>
Date: Wed, 2 Apr 2014 08:30:52 +0200

Hi,

  The HTML5 keygen element [1] works by having the browser send a public key to the
server which can then return an X509 certificate back to the browser using one of the
following mime types [2]

    (a) application/x-x509-user-cert 
    (b) application/x-x509-ca-cert 
    (c) application/x-x509-email-cert

This seems to work for most browsers - Safari, Chrome, Nescape, Opera - and has
been functioning like this since at least the year 2000 I think. The keygen tag
was only added to html officially a few years ago.

  What is missing though is that these mime types are not registered at IANA.
Is there anyone here ( or perhaps I should look somewhere else ) who would like
to register that at IANA? It would at least make it easier for developers building
web sites to work out what the correct mime type to use is.

  Perhaps one could also then get the html5 people to add a note about this
to their specification.  

   http://lists.whatwg.org/htdig.cgi/whatwg-whatwg.org/2014-April/084613.html

 Henry

[1] http://www.w3.org/html/wg/drafts/html/CR/forms.html#the-keygen-element
[2] https://wiki.mozilla.org/CA:Certificate_Download_Specification
[3] http://www.iana.org/assignments/media-types/media-types.xhtml

Social Web Architect
http://bblfish.net/

---

From: Anders Rundgren <[email-masked]>
Date: Wed, 02 Apr 2014 09:42:25 +0200

Henry,

There was a looooooooong discussion about these types in PKIX
but the WG rejected supporting existing practices and insisted
that those who "violate" the standard (which came much too late)
should be punished.

That is, there *are* already IANA definitions for certificate
MIME types, but they are hardly ever used.

AFAIK, the "x-" actually means non-standard.

Anders

On 2014-04-02 08:30, [email-masked] wrote:
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>

---

From: Bjoern Hoehrmann <[email-masked]>
Date: Thu, 03 Apr 2014 13:54:56 +0200

>AFAIK, the "x-" actually means non-standard.

There is some truth in that, but note http://tools.ietf.org/html/rfc6838

  Note that types with names beginning with "x-" are no longer
  considered to be members of this tree (see [RFC6648]).  Also note
  that if a generally useful and widely deployed type incorrectly ends
  up with an "x-" name prefix, it MAY be registered using its current
  name in an alternative tree by following the procedure defined in
  Appendix A.
-- 
Björn Höhrmann · mailto:[email-masked] · http://bjoern.hoehrmann.de
Am Badedeich 7 · Telefon: +49(0)160/4415681 · http://www.bjoernsworld.de
25899 Dagebüll · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/

---

From: Anders Rundgren <[email-masked]>
Date: Thu, 03 Apr 2014 15:08:20 +0200

>   name in an alternative tree by following the procedure defined in

So it took a decade for the IETF to find out that pragmatism MAY be useful :-)

Anders