Subject: Re: [TLS] Bakeoffs

From: "Salz, Rich" <[email-masked]>
Date: Thu, 17 Apr 2014 10:42:59 -0400

I got some questions off-list about my comments on "not meeting the charter."  I should clarify.

It's okay if we aren't able to meet all the goals of the charter.  I could charter a WG to solve the four-color map problem and prove P=NP, and conclude with only one goal met.  :)

                /r$

--
Principal Security Engineer
Akamai Technology
Cambridge, MA

---

From: Trevor Perrin <[email-masked]>
Date: Thu, 17 Apr 2014 09:19:19 -0700

On Thu, Apr 17, 2014 at 7:42 AM, Salz, Rich <[email-masked]> wrote:
>
> It's okay if we aren't able to meet all the goals of the charter.  I could
> charter a WG to solve the four-color map problem and prove P=NP, and
> conclude with only one goal met.  J

Hi Rich,

You've argued before that "if we got rid of the SNI encryption :) the
number of changes being considered is pretty small in both number and
scope." [1].

I don't think that's true.  For example, the EKR draft introduces
"semi-static" public keys used for 0-RTT as well as handshake
encryption.  Removing handshake encryption alone wouldn't eliminate
this mechanism.

Trevor

[1] http://www.ietf.org/mail-archive/web/tls/current/msg12037.html

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 17 Apr 2014 12:23:15 -0400

You're probably right in that I'm probably wrong, hence my initial smiley.  Just trying to be good-humoured about all this