Subject: [TLS] Removing support for custom unnamed DIffie-Hellman groups

From: "Joseph Salowey (jsalowey)" <[email-masked]>
Date: Mon, 21 Jul 2014 14:45:12 +0000

At the interim there was support for removing support for custom unnamed Diffie-Hellman groups from TLS 1.3.  If you have an objection please respond on the list by July 25, 2014.

Thanks,

Joe 
[For the chairs]

---

From: Russ Housley <[email-masked]>
Date: Mon, 21 Jul 2014 10:51:21 -0400

I think this means that only well-known groups will be used.  I am assuming that an IANA registry will be used to provide identifiers for these well-known groups.  If that is correct, then I fully support this direction.

Russ

---

From: Eric Rescorla <[email-masked]>
Date: Mon, 21 Jul 2014 07:56:02 -0700

On Mon, Jul 21, 2014 at 7:51 AM, Russ Housley <[email-masked]> wrote:

> I think this means that only well-known groups will be used.

Yes.

>  I am assuming that an IANA registry will be used to provide identifiers
> for these well-known groups.  If that is correct, then I fully support this
> direction.

Yes:
http://tools.ietf.org/html/draft-ietf-tls-negotiated-dl-dhe-00#section-7

-Ekr

> > At the interim there was support for removing support for custom unnamed
> Diffie-Hellman groups from TLS 1.3.  If you have an objection please
> respond on the list by July 25, 2014.
> >
> > Thanks,
> >
> > Joe
> > [For the chairs]
>
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>

---

From: Manuel Pégourié-Gonnard <[email-masked]>
Date: Mon, 21 Jul 2014 23:00:54 +0200

On 21/07/2014 16:51, Russ Housley wrote:
> I think this means that only well-known groups will be used.  I am assuming
> that an IANA registry will be used to provide identifiers for these
> well-known groups.  If that is correct, then I fully support this direction.
> 
+1

Manuel.