Subject: [TLS] WG adoption of draft-agl-tls-padding

From: Sean Turner <[email-masked]>
Date: Fri, 23 Jan 2015 15:04:54 -0500

All,

WG adoption of draft-agl-tls-padding [0] seems to have fallen through the cracks.  Back in January 2014, the chairs did a call for an early code point assignment [1], some changes were discussed and adopted in -03, and an early code point assignment was made.  Early code point assignments are only temporary (1 year) and to get it permanently assigned we need to progress the draft.  Back in January 2014, there was a call for objections to WG adoption [2].  There were no objections and the draft should have been adopted, but we (the chairs) dropped the ball and we’d like to remedy that by:

- Requesting that Adam submit an -00 WG draft version based on the -03
  of his individual draft to resuscitate it (i.e., change the name to
  draft-ietf-tls-padding - I’ve already pre-approved that name)
- Adopting -00 as a WG item
- WGLCing -00 shortly thereafter

Thanks,

J&S

[0] http://www.ietf.org/archive/id/draft-agl-tls-padding-03.txt
[1] http://www.ietf.org/mail-archive/web/tls/current/msg11047.html
[2] http://www.ietf.org/mail-archive/web/tls/current/msg11219.html

---

From: Adam Langley <[email-masked]>
Date: Fri, 23 Jan 2015 12:46:52 -0800

>   of his individual draft to resuscitate it (i.e., change the name to

https://datatracker.ietf.org/doc/draft-ietf-tls-padding/

Cheers

AGL

-- 
Adam Langley [email-masked] https://www.imperialviolet.org

---

From: Dave Garrett <[email-masked]>
Date: Fri, 23 Jan 2015 16:23:35 -0500

> https://datatracker.ietf.org/doc/draft-ietf-tls-padding/

A minor suggestion: rename the document to describe it more precisely. It is currently named "A TLS padding extension", however it's not an extension to add any general padding to TLS itself, rather just the ClientHello. Just changing it to "TLS ClientHello Padding Extension" would describe things better.

Dave

---

From: Adam Langley <[email-masked]>
Date: Fri, 23 Jan 2015 13:30:10 -0800

> A minor suggestion: rename the document to describe it more precisely. It is currently named "A TLS padding extension", however it's not an extension to add any general padding to TLS itself, rathe…

I think that's a good point. I've started a repo to batch up any
changes, including this one: https://github.com/agl/tls-padding

Cheers

AGL