Subject: Re: [TLS] Working Group Last Call for draft-ietf-tls-sslv3-diediedie-00

From: Xiaoyin Liu <[email-masked]>
Date: Fri, 23 Jan 2015 16:13:44 -0500

I support this document as well. But I have a question. Since this document prohibits the negotiation of SSL 3.0 from all versions of TLS, should it also update RFC4346 (TLS 1.1) and RFC2246 (TLS 1.0)?

Thanks,
Xiaoyin
________________________________
From: Joseph Salowey<mailto:[email-masked]>
Sent: ‎1/‎23/‎2015 14:30
To: [email-masked]<mailto:[email-masked]>
Subject: [TLS] Working Group Last Call for draft-ietf-tls-sslv3-diediedie-00

This is a working group last call for draft-ietf-tls-sslv3-diediedie-00.
Please reply to the TLS working group list with an indication of whether or
not the draft is ready for publication and any other comments you may
have.  Please respond by February 16, 2015.

Thanks,

S & J
_______________________________________________
TLS mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tls

---

From: Martin Thomson <[email-masked]>
Date: Fri, 23 Jan 2015 14:16:30 -0800

On 23 January 2015 at 13:13, Xiaoyin Liu <[email-masked]> wrote:
> should it also update RFC4346 (TLS 1.1) and RFC2246 (TLS 1.0)?

Those are deprecated, so I think we are safe in not doing so.  But I'm
happy to listen to arguments for that.

---

From: Dave Garrett <[email-masked]>
Date: Fri, 23 Jan 2015 18:31:40 -0500

> happy to listen to arguments for that.

The SSL2 prohibition RFC listed them all.

http://tools.ietf.org/html/rfc6176

Maintaining consistency for SSL3 seems logical.

If the message is that the IETF recommends against the usage of SSL for any reason, then officially updating all three probably makes sense. It's obviously not likely to affect anything in practice, though.

---

From: Martin Thomson <[email-masked]>
Date: Fri, 23 Jan 2015 16:31:28 -0800

> Maintaining consistency for SSL3 seems logical.

I remember a saying about consistency.

> It's obviously not likely to affect anything in practice, though.

That is a great argument. I'm convinced.