Subject: Re: [TLS] comment on draft-ietf-tls-pwd-06

From: Peter Gutmann <[email-masked]>
Date: Fri, 27 Mar 2015 10:43:14 +0000

Aaron Zauner <[email-masked]> writes:

>Sorry for being terse: I'm wondering why the Document still supports AES-
>CBC. Is compatibility down to TLS 1.0 or 1.1 desired? If not; Why not 
>reduce the number of (vulnerable) ciphersuites by removing AES-CBC?

Given that AES-CBC with EtM is a lot less vulnerable to problems than AES-GCM
(and arguably even without EtM it's a lot less brittle than GCM is), why would
you remove it?  It's a much more robust mode than GCM.

Peter.

---

From: Sean Turner <[email-masked]>
Date: Fri, 27 Mar 2015 09:13:11 -0500

We should keep in mind that this document is parked (i.e., it lack consensus to move forward).

spt