Subject: [TLS] I-D Action: draft-ietf-tls-rfc4492bis-02.txt

From: [email-masked]
Date: Mon, 09 Mar 2015 14:23:39 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Transport Layer Security Working Group of the IETF.

        Title           : Elliptic Curve Cryptography (ECC) Cipher Suites for Transport Layer Security (TLS) Versions 1.2 and Earlier
        Author          : Yoav Nir
	Filename        : draft-ietf-tls-rfc4492bis-02.txt
	Pages           : 30
	Date            : 2015-03-09

Abstract:
   This document describes key exchange algorithms based on Elliptic
   Curve Cryptography (ECC) for the Transport Layer Security (TLS)
   protocol.  In particular, it specifies the use of Ephemeral Elliptic
   Curve Diffie-Hellman (ECDHE) key agreement in a TLS handshake and the
   use of Elliptic Curve Digital Signature Algorithm (ECDSA) as a new
   authentication mechanism.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-tls-rfc4492bis/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-tls-rfc4492bis-02

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-tls-rfc4492bis-02

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Peter Dettman <[email-masked]>
Date: Tue, 10 Mar 2015 14:53:48 +0700

On the very last lineof "6. Cipher Suites", the list of cipher suites 
that SHOULD be supported includes TLS_ECDH_ECDSA_WITH_AES_128_CBC_SHA256 
- is that a typo that should be ..._ECDHE_...?

In that same list, should TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA be ..._SHA256?

Regards,
Pete Dettman

On 10/03/2015 4:23 am, [email-masked] wrote:
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls

---

From: Yoav Nir <[email-masked]>
Date: Tue, 10 Mar 2015 13:09:08 +0200

Actually only the last one has issues. Tthe full list should be:

   o  TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256
   o  TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA
   o  TLS_ECDHE_ECDSA_WITH_AES_128_GCM_SHA256
   o  TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA

While there are _SHA256  versions for the second and forth ciphersuites, these are pre-1.2 ciphersuites where the _SHA and _SHA256 refer to HMAC-SHA1 and HMAC-SHA256 respectively as MAC functions. There is no particular reason to switch to HMAC-SHA256, so we’d rather stay with the previous recommendation.

Going forward (1.3+) only the GCM ciphersuites will be supported, so you need those.

Thanks. I’ll fix it in the next version after the meeting.

Yoav

> On Mar 10, 2015, at 9:53 AM, Peter Dettman <[email-masked]> wrote:
> 
> On the very last lineof "6. Cipher Suites", the list of cipher suites that SHOULD be supported includes TLS_ECDH_ECDSA_WITH_AES_128_CBC_SHA256 - is that a typo that should be ..._ECDHE_...?
>