Subject: Re: [TLS] AES-OCB in TLS [New Version Notification for draft-zauner-tls-aes-ocb-03.txt]

From: "Blumenthal, Uri - 0553 - MITLL" <[email-masked]>
Date: Wed, 5 Aug 2015 22:37:00 +0000

Aaron,

Great work! I can't wait to see OCB standardized and implemented.

One thing though. There has been mentioning of Gligor patent(s) - were you able to look into that? Or perhaps Phil or Charanjit could comment on this (though technical people seldom make legal statements :)?

Sent from my BlackBerry 10 smartphone on the Verizon Wireless 4G LTE network.
  Original Message  
From: Aaron Zauner
Sent: Wednesday, August 5, 2015 17:17
To: TLS Mailing List
Subject: Re: [TLS] AES-OCB in TLS [New Version Notification for draft-zauner-tls-aes-ocb-03.txt]

Hi,

A short update on the matter of IPR related to AES-OCB in TLS:

It took some time but over the past couple of weeks all IPR exemptions
have been filed by the original patent holders (Rogaway and IBM
[Jutla]). These IPR exemptions can be viewed over here:
https://datatracker.ietf.org/ipr/search/?submit=draft&id=draft-zauner-tls-aes-ocb

Specifically..
Rogaway: https://datatracker.ietf.org/ipr/2640/
IBM: https://datatracker.ietf.org/ipr/2647/

The current document is available on the IETF website, I've made a few
minor editorial changes in my git repository [0] but not yet uploaded a
new version of the document as I'm still waiting if people would like to
see more substantial changes to the document.

I'd be happy to receive feedback on the document and am looking forward
for people to try out AES-OCB in TLS (an upcoming OpenSSL version will
ship with default-support I am told).

Thanks for your patience,
Aaron

[0] https://github.com/azet/draft-zauner-tls-aes-ocb/commits/master

---

From: Aaron Zauner <[email-masked]>
Date: Thu, 06 Aug 2015 00:48:01 +0200

Hi,

> One thing though. There has been mentioning of Gligor patent(s) - were you able to look into that? Or perhaps Phil or Charanjit could comment on this (though technical people seldom make legal stat…

I've written to Gligor and Donescu (his mail address is bouncing though
and I do not have another/current one). I've not received any replies as
of today. Rogaway, like myself, is not sure if that patent actually
relates to OCB. He's included it in his initial IPR statement on RFC
7253 [0] as a pre caution as far as I can tell. The patent by Gligor and
Donescu will expire on 18th of January 2021.

Aaron

[0] see
https://datatracker.ietf.org/ipr/search/?submit=draft&id=draft-irtf-cfrg-ocb
and https://datatracker.ietf.org/ipr/1682/

---

From: Aaron Zauner <[email-masked]>
Date: Thu, 6 Aug 2015 07:29:25 +0200

PS:

> Donescu will expire on 18th of January 2021.

FYI: It's only been 1.5w since I've written to them (holiday high
season as well). Jutla now also reached out. Let's see how this
goes. I'm optimistic.

Aaron