Subject: [TLS] Number of DTLS sessions/DTLS connections; RE: [rtcweb] What the gateway draft should say about mux/non-mux

From: "Schwarz, Albrecht (Albrecht)" <[email-masked]>
Date: Wed, 5 Aug 2015 08:03:37 +0000

Roman, Bernard,
right, RFC 5764 is too vague on that aspect. Thanks for confirming the number of DTLS sessions, which is inline with our understanding.
Would appreciate if this could be somewhere fixed in an rtcweb draft due to significant side effects.
This topic is also an ongoing FAQ.

The most simple case is given by a scenario with usage of bundling plus usage of RTP/RTCP transport multiplexing, leading to a single DTLS session/DTLS connection, which could be then also shared for WebRTC data.

Both capabilities are mandated in the rtp usage draft:
https://tools.ietf.org/html/draft-ietf-rtcweb-rtp-usage-25#section-4.4
=> bundling
https://tools.ietf.org/html/draft-ietf-rtcweb-rtp-usage-25#section-4.5
=> RTP/RTCP transport multiplexing

Now, IF bundling is not used OR RTP/RTCP transport multiplexing is not used THEN there will be more than one DTLS session/DTLS connection (either 2 or 4 in case of audio & video).
Raising the question which DTLS connection is used for additional WebRTC data traffic? - Because
https://tools.ietf.org/html/draft-ietf-rtcweb-transports-09#section-3.5
indicates the sharing option.
Would then be a 3rd (or 5th) self-contained DTLS session/DTLS connection for WebRTC data traffic?

Proposal:
Add explicit text to clause https://tools.ietf.org/html/draft-ietf-rtcweb-transports-09#section-3.5
about (in red), something like:

   WebRTC implementations MUST support multiplexing of DTLS and RTP over
   the same port pair, as described in the DTLS-SRTP specification
   [RFC5764], section 5.1.2<https://tools.ietf.org/html/rfc5764#section-5.1.2>.  All application layer protocol payloads
   over this DTLS connection are SCTP packets.

   Note 1: There will be two DTLS sessions/DTLS connections when RTP/RTCP transport multiplexing is not applied. WebRTC data traffic could still share one of these DTLS connections … (“which one?”) … or There should be then a separate, self-contained DTLS session/DTLS connection established exclusively for WebRTC data.

   Note 2: There are similar considerations in case of bundling.

   Protocol identification MUST be supplied as part of the DTLS
   handshake, as specified in [I-D.ietf-rtcweb-alpn<https://tools.ietf.org/html/draft-ietf-rtcweb-transports-09#ref-I-D.ietf-rtcweb-alpn>].

Comments?
Regards,
Albrecht

PS
Using (D)TLS terminology according to http://tools.ietf.org/id/draft-guballa-tls-terminology-01.txt

From: Bernard Aboba [mailto:[email-masked]]
Sent: Mittwoch, 5. August 2015 04:04
To: Roman Shpount
Cc: Asveren, Tolga; Christer Holmberg; Eric Rescorla; Schwarz, Albrecht (Albrecht); Rauschenbach, Uwe (Nokia - DE/Munich); <[email-masked]>
Subject: Re: [rtcweb] What the gateway draft should say about mux/non-mux

On Aug 4, 2015, at 16:33, Roman Shpount <[email-masked]<mailto:[email-masked]>> wrote:

Most of the people implement this wrong, since you need to create two DTLS sessions: one for RTP and another for RTCP. And then use different keys or possibly even encryption profiles for RTP and RTCP. I commonly see one session for RTP and keys negotiated there used for both RTP and RTCP, which is wrong.

[BA] Yes, that is only one of several common mistakes.  Unfortunately, RFC 5764 does not rule out all of these and the security documents are not crystal clear on how things must be done. It is much harder to mess up RTP/RTCP mux.  Given what I've seen so far, non-mux could become a support nightmare.

---

From: "Schwarz, Albrecht (Albrecht)" <[email-masked]>
Date: Wed, 5 Aug 2015 08:16:56 +0000

Christer,
do agree of course.
But independent of the RFC 5764 correction, below clarification proposal for rtcweb-transport remains valid (“due to the sharing assumption”).

Regards,
Albrecht

From: Christer Holmberg [mailto:[email-masked]]
Sent: Mittwoch, 5. August 2015 10:13
To: Schwarz, Albrecht (Albrecht); <[email-masked]>
Cc: [email-masked] ([email-masked])
Subject: RE: [rtcweb] Number of DTLS sessions/DTLS connections; RE: What the gateway draft should say about mux/non-mux

Hi,

We shall not make RFC 5764 corrections in the RTCWEB specs.

Regards,

Christer

From: rtcweb [mailto:[email-masked]] On Behalf Of Schwarz, Albrecht (Albrecht)
Sent: 5. elokuuta 2015 11:04
To: <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]> ([email-masked]<mailto:[email-masked]>)
Subject: [rtcweb] Number of DTLS sessions/DTLS connections; RE: What the gateway draft should say about mux/non-mux

Roman, Bernard,

Proposal:

Comments?
Regards,
Albrecht

PS

From: Bernard Aboba [mailto:[email-masked]]
Sent: Mittwoch, 5. August 2015 04:04
To: Roman Shpount
Cc: Asveren, Tolga; Christer Holmberg; Eric Rescorla; Schwarz, Albrecht (Albrecht); Rauschenbach, Uwe (Nokia - DE/Munich); <[email-masked]<mailto:[email-masked]>>
Subject: Re: [rtcweb] What the gateway draft should say about mux/non-mux

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 5 Aug 2015 08:12:34 +0000

Hi,

Regards,

Christer

To: <[email-masked]>

Roman, Bernard,

Proposal:

Comments?
Regards,
Albrecht

PS

---

From: "Asveren, Tolga" <[email-masked]>
Date: Wed, 5 Aug 2015 12:27:17 +0000

Yes, completely agree.

And I think what Albrecht proposes below is the right way of addressing the “no-rtcp-mux implementation difficulties” problem: Adding clarifications/amendments in the respective normative specification rather than disallowing a combination in a profile because it is “confusing”.
Honestly, I think the number of DTLS connections to use, when bundling/muxing is not used, is not really that hard to figure out (for somebody who actually understands the whole story) but obviously no harm of adding some clarifications. DataChannel aspects need to be crisply specified though. What is the main advantage of letting DataChannel potentially use one of the exsiting DTLS connections? Just to save some time on negotiation?

Thanks,
Tolga

From: rtcweb [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: Wednesday, August 05, 2015 4:13 AM
To: Schwarz, Albrecht (Albrecht) <[email-masked]>; <[email-masked]> <[email-masked]>
Cc: [email-masked] ([email-masked]) <[email-masked]>
Subject: Re: [rtcweb] Number of DTLS sessions/DTLS connections; RE: What the gateway draft should say about mux/non-mux

Hi,

Regards,

Christer

Roman, Bernard,

Proposal:

Comments?
Regards,
Albrecht

PS

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 5 Aug 2015 12:39:10 +0000

Hi,

I guess we could add some clarification text to the SDP-DTLS draft.

Regards,

Christer

From: Asveren, Tolga [mailto:[email-masked]]
Sent: 5. elokuuta 2015 15:27
To: Christer Holmberg; Schwarz, Albrecht (Albrecht); <[email-masked]>
Cc: [email-masked] ([email-masked])
Subject: RE: [rtcweb] Number of DTLS sessions/DTLS connections; RE: What the gateway draft should say about mux/non-mux

Yes, completely agree.

Thanks,
Tolga

From: rtcweb [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: Wednesday, August 05, 2015 4:13 AM
To: Schwarz, Albrecht (Albrecht) <[email-masked]<mailto:[email-masked]>>; <[email-masked]<mailto:[email-masked]>> <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]> ([email-masked]<mailto:[email-masked]>) <[email-masked]<mailto:[email-masked]>>
Subject: Re: [rtcweb] Number of DTLS sessions/DTLS connections; RE: What the gateway draft should say about mux/non-mux

Hi,

Regards,

Christer

Roman, Bernard,

Proposal:

Comments?
Regards,
Albrecht

PS