Subject: [TLS] WGLC for draft-ietf-tls-tls13-vectors

From: Sean Turner <[email-masked]>
Date: Tue, 8 May 2018 12:30:54 -0400

All,

This is the working group last call for the "Example Handshake Traces for TLS 1.3" draft available at https://datatracker.ietf.org/doc/draft-ietf-tls-tls13-vectors/.  Please review the document and send your comments to the list by 2359 UTC on 22 May 2018.

Thanks - J&S

---

From: Sean Turner <[email-masked]>
Date: Tue, 8 May 2018 12:49:03 -0400

I noted two things that I didn’t think we needed to wait for:

1. The draft needs an IANA Considerations section to at least get through the GENART process (the section can later be removed during AUTH48 if requested).  I submitted a PR to address this:

https://github.com/tlswg/draft-ietf-tls-tls13-vectors/pull/4

2. Intended RFC status 

I don’t have a strong opinion on this, but many of the “example" drafts are Informational, but some are BCP and this one current indicates Proposed Standard.  Let the list know if you’ve got strong feelings one way or another.  I submitted an issue to make sure we track this this:

https://github.com/tlswg/draft-ietf-tls-tls13-vectors/issues/5

Cheers,

spt

> On May 8, 2018, at 12:30, Sean Turner <[email-masked]> wrote:
> 
> All,
>

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 8 May 2018 16:55:55 +0000

I dislike standard, and am fine with Informational or BCP.

---

From: "Blumenthal, Uri - 0553 - MITLL" <[email-masked]>
Date: Tue, 8 May 2018 20:26:28 +0000

If it's intended to be a "test-vector", then by all means it should be a standard.

If it's just for illustration - Informational or BCP is fine.

My $0.02.
--
Regards,
Uri Blumenthal
On 5/8/18, 12:56, "TLS on behalf of Salz, Rich" <[email-masked] on behalf of [email-masked]> wrote:

    _______________________________________________
    TLS mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/tls

---

From: Martin Thomson <[email-masked]>
Date: Wed, 09 May 2018 00:30:52 +0000

> I dislike standard, and am fine with Informational or BCP.

Agree regarding standard.

I don't understand why BCP would be used for this.  Besides, we probably
don't want to enshrine some of the choices we made in NSS as "best
practice".  I'm not saying that those choices aren't defensible, but that
might be going too far.

---

From: Sean Turner <[email-masked]>
Date: Tue, 29 May 2018 10:35:28 -0400

> On May 8, 2018, at 20:30, Martin Thomson <[email-masked]> wrote:
> 

Since this draft is really about “examples” (i.e., it’s just for illustration), I’m going to suggest that Martin go ahead and merge the following PR that I submitted changing the intended status:
https://github.com/tlswg/draft-ietf-tls-tls13-vectors/pull/6

Once a new version is spun, I’ll push the draft toward Ben.

spt

---

From: Martin Thomson <[email-masked]>
Date: Wed, 30 May 2018 11:05:48 +1000

The thought occurs, do you want a version with the final version number in
it?  I see that TLS 1.3 is in front of the RFC editor right now, so I don't
anticipate any changes and changing the examples creates a lot of churn
(check out the diffs on this draft to get an idea).

> Since this draft is really about “examples” (i.e., it’s just for
illustration), I’m going to suggest that Martin go ahead and merge the

---

From: Sean Turner <[email-masked]>
Date: Tue, 29 May 2018 21:22:26 -0400

I think changing the Intended Status is all we’re looking.

spt

> On May 29, 2018, at 21:05, Martin Thomson <[email-masked]> wrote:
>

---

From: Martin Thomson <[email-masked]>
Date: Wed, 30 May 2018 11:26:52 +1000

Ack, that makes it easier for me :)