Subject: Re: [TLS] New Version Notification for draft-wood-tls-ticketrequests-00.txt

From: Sean Turner <[email-masked]>
Date: Tue, 29 May 2018 11:12:45 -0400

As Martin noted, this seems to be a pretty simple idea, but am curious if others feel that way.

Curious about the choice on the limit of 255 identifiers versus something smaller.  If the max ticket age is one week that could theoretically be almost 5 years of tickets right?

spt

PS - Thanks for not code squatting ;)

> On Apr 12, 2018, at 23:15, Chris Wood <[email-masked]> wrote:
> 
> Hi everyone,
> 
> Below is a pointer to a new I-D describing an approach for clients to request session tickets via a new post-handshake message. This is useful for applications that perform parallel connection establishment and racing, e.g., via Happy Eyeballs. It should also help reduce ticket waste. More uses and details are given in the document. 
> 
> We would very much appreciate feedback on the mechanism utility and design.
> 
> Best,
> Chris 
> 
> Begin forwarded message:
> 
>> From: [email-masked]
>> Date: April 12, 2018 at 8:07:35 PM PDT
>> To: David Schinazi <[email-masked]>, Christopher Wood <[email-masked]>, Tommy Pauly <[email-masked]>, "Christopher A. Wood" <[email-masked]>
>> Subject: New Version Notification for draft-wood-tls-ticketrequests-00.txt
>> 
>> 
>> A new version of I-D, draft-wood-tls-ticketrequests-00.txt
>> has been successfully submitted by Christopher A. Wood and posted to the
>> IETF repository.
>> 
>> Name:        draft-wood-tls-ticketrequests
>> Revision:    00
>> Title:        TLS Ticket Requests
>> Document date:    2018-04-12
>> Group:        Individual Submission
>> Pages:        6
>> URL:            https://www.ietf..org/internet-drafts/draft-wood-tls-ticketrequests-00.txt
>> Status:         https://datatracker.ietf.org/doc/draft-wood-tls-ticketrequests/
>> Htmlized:       https://tools.ietf.org/html/draft-wood-tls-ticketrequests-00
>> Htmlized:       https://datatracker.ietf.org/doc/html/draft-wood-tls-ticketrequests
>> 
>> 
>> Abstract:
>>   TLS session tickets enable stateless connection resumption for
>>   clients without server-side per-client state.  Servers vend session
>>   tickets to clients, at their discretion, upon connection
>>   establishment.  Clients store and use tickets when resuming future
>>   connections.  Moreover, clients should use tickets at most once for
>>   session resumption, especially if such keying material protects early
>>   application data.  Single-use tickets bound the number of parallel
>>   connections a client may initiate by the number of tickets received
>>   from a given server.  To address this limitation, this document
>>   describes a mechanism by which clients may request tickets as needed
>>   during a connection.
>> 
>> 
>> 
>> 
>> Please note that it may take a couple of minutes from the time of submission
>> until the htmlized version and diff are available at tools.ietf.org.
>> 
>> The IETF Secretariat
>> 
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls

---

From: Christopher Wood <[email-masked]>
Date: Tue, 29 May 2018 10:20:31 -0700

> Curious about the choice on the limit of 255 identifiers versus something smaller.  If the max ticket age is one week that could theoretically be almost 5 years of tickets right?

We went with 255 since we did not want anything larger. If others
think the limit should be lowered, we can certainly do so. That said,
the server is free to bound the number of tickets it vends, so this
may not be needed.

Best,
Chris