Subject: [TLS] [Technical Errata Reported] RFC5246 (5352)

From: RFC Errata System <[email-masked]>
Date: Wed, 9 May 2018 09:17:08 -0700 (PDT)

The following errata report has been submitted for RFC5246,
"The Transport Layer Security (TLS) Protocol Version 1.2".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5352

--------------------------------------
Type: Technical
Reported by: Loic Etienne <[email-masked]>

Section: 6.2.3.3.

Original Text
-------------
struct {
    opaque nonce_explicit[SecurityParameters.record_iv_length];
    aead-ciphered struct {
        opaque content[TLSCompressed.length];
    };
} GenericAEADCipher;

Corrected Text
--------------
struct {
    opaque nonce_explicit[SecurityParameters.record_iv_length];
    aead-ciphered struct {
        opaque content[TLSCiphertext.length];
    };
} GenericAEADCipher;

Notes
-----
6.2.3.3. says: "The aead_output consists of the ciphertext output by the AEAD encryption operation. The length will generally be larger than TLSCompressed.length, [...]".

The definition is duplicated at A.1., and needs the same adjustment.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC5246 (draft-ietf-tls-rfc4346-bis-10)
--------------------------------------
Title               : The Transport Layer Security (TLS) Protocol Version 1.2
Publication Date    : August 2008
Author(s)           : T. Dierks, E. Rescorla
Category            : PROPOSED STANDARD
Source              : Transport Layer Security
Area                : Security
Stream              : IETF
Verifying Party     : IESG

---

From: Martin Thomson <[email-masked]>
Date: Thu, 10 May 2018 02:17:45 +0000

Reject.  The text refers to the output of the AEAD.  The contents of the
"aead-cipher struct" are the inputs.
On Thu, May 10, 2018 at 2:17 AM RFC Errata System
<[email-masked]>

> Notes
> -----
> 6.2.3.3. says: "The aead_output consists of the ciphertext output by the
AEAD encryption operation. The length will generally be larger than
TLSCompressed.length, [...]".

> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls