Subject: [TLS] WG adoption call: draft-rescorla-tls-esni

From: Joseph Salowey <[email-masked]>
Date: Tue, 24 Jul 2018 19:16:49 -0700

The sense of the TLS@IETF102 room was the the WG should adopt
https://datatracker.ietf.org/doc/draft-rescorla-tls-esni/ as a WG item.
But, we need to confirm this on list.  If you would like for this draft to
become a WG document and you are willing to review it as it moves through
the process, then please let the list know by 2359UTC 20180807.  If you are
opposed to this being a WG document, please say so (and say why).

Note that the draft has been marked as a "Candidate for WG Adoption” in the
datatracker.

---

From: David Schinazi <[email-masked]>
Date: Tue, 24 Jul 2018 19:18:55 -0700

I support adoption, and I'm happy to review it.

David

> On Jul 24, 2018, at 19:16, Joseph Salowey <[email-masked]> wrote:
> 
> 
> The sense of the TLS@IETF102 room was the the WG should adopt https://datatracker.ietf.org/doc/draft-rescorla-tls-esni/ <https://datatracker.ietf.org/doc/draft-rescorla-tls-esni/> as a WG item.  But, we need to confirm this on list.  If you would like for this draft to become a WG document and you are willing to review it as it moves through the process, then please let the list know by 2359UTC 20180807.  If you are opposed to this being a WG document, please say so (and say why).
> 
> Note that the draft has been marked as a "Candidate for WG Adoption” in the datatracker.
> 
> 
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls

---

From: David Benjamin <[email-masked]>
Date: Tue, 24 Jul 2018 23:08:13 -0400

I too support adoption and am happy to review it.

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 24 Jul 2018 20:26:00 -0700

Unsurprisingly, I support adoption

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 25 Jul 2018 09:27:42 +0100

Yeah, adopt it. I'll review.

S

---

From: Patrick McManus <[email-masked]>
Date: Wed, 25 Jul 2018 08:23:01 -0400

I support adoption of this document and I will review and provide
contributions to it as it evolves in the WG - its important work.

-Patrick

---

From: Mike Bishop <[email-masked]>
Date: Wed, 25 Jul 2018 13:37:07 +0000

+1 – there are certainly kinks to work out, but this is a worthwhile direction.

From: TLS <[email-masked]> On Behalf Of Patrick McManus
Sent: Wednesday, July 25, 2018 8:23 AM
To: Joseph Salowey <[email-masked]>
Cc: <[email-masked]> <[email-masked]>
Subject: Re: [TLS] WG adoption call: draft-rescorla-tls-esni

I support adoption of this document and I will review and provide contributions to it as it evolves in the WG - its important work.

-Patrick

On Tue, Jul 24, 2018 at 10:16 PM, Joseph Salowey <[email-masked]<mailto:[email-masked]>> wrote:

The sense of the TLS@IETF102 room was the the WG should adopt https://datatracker.ietf.org/doc/draft-rescorla-tls-esni/ as a WG item.  But, we need to confirm this on list.  If you would like for this draft to become a WG document and you are willing to review it as it moves through the process, then please let the list know by 2359UTC 20180807.  If you are opposed to this being a WG document, please say so (and say why).

_______________________________________________
TLS mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tls

---

From: Christian Huitema <[email-masked]>
Date: Wed, 25 Jul 2018 07:31:10 -0700

+1. I support adoption and will review.

-- Christian Huitema 

> On Jul 25, 2018, at 6:37 AM, Mike Bishop <[email-masked]> wrote:
>

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 25 Jul 2018 15:43:28 +0000

I am in favor of adoption and will work on it.  It’s use of DNS is problematic for cases that are important to us.

---

From: Joseph Lorenzo Hall <[email-masked]>
Date: Wed, 25 Jul 2018 12:32:57 -0400

support, will review

-- 
Joseph Lorenzo Hall
Chief Technologist, Center for Democracy & Technology [https://www.cdt.org]
1401 K ST NW STE 200, Washington DC 20005-3497
e: [email-masked], p: 202.407.8825, pgp: https://josephhall.org/gpg-key
Fingerprint: 3CA2 8D7B 9F6D DBD3 4B10  1607 5F86 6987 40A9 A871

---

From: Petr Špaček <[email-masked]>
Date: Thu, 26 Jul 2018 08:44:00 +0200

I support this & will review DNS parts.

Petr Špaček  @  CZ.NIC

On 25.7.2018 04:16, Joseph Salowey wrote:
> 
> The sense of the TLS@IETF102 room was the the WG should
> adopt https://datatracker.ietf.org/doc/draft-rescorla-tls-esni/
> <https://datatracker.ietf.org/doc/draft-rescorla-tls-esni/> as a WG
> item.  But, we need to confirm this on list.  If you would like for this
> draft to become a WG document and you are willing to review it as it
> moves through the process, then please let the list know by 2359UTC
> 20180807.  If you are opposed to this being a WG document, please say so
> (and say why).
>

---

From: "Short, Todd" <[email-masked]>
Date: Thu, 26 Jul 2018 17:20:35 +0000

I support WG adoption.

--
-Todd Short
// [email-masked]
// "One if by land, two if by sea, three if by the Internet."

From: Joseph Salowey <[email-masked]>
Date: Tuesday, July 24, 2018 at 10:18 PM
To: "<[email-masked]>" <[email-masked]>
Subject: [TLS] WG adoption call: draft-rescorla-tls-esni

The sense of the TLS@IETF102 room was the the WG should adopt https://datatracker.ietf.org/doc/draft-rescorla-tls-esni/<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Drescorla-2Dtls-2Desni_&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=QBEcQsqoUDdk1Q26CzlzNPPUkKYWIh1LYsiHAwmtRik&m=H-qBcqGDTpJOkTiN4pP4LMShPRLwa6IhpT6VhdkWzHA&s=1X7lJv1ZD1E5o-hDg9ofZqeqAxUrWEruJNkTlxn8SfA&e=> as a WG item.  But, we need to confirm this on list.  If you would like for this draft to become a WG document and you are willing to review it as it moves through the process, then please let the list know by 2359UTC 20180807.  If you are opposed to this being a WG document, please say so (and say why).

---

From: Loganaden Velvindron <[email-masked]>
Date: Thu, 26 Jul 2018 21:23:31 +0400

I support the adoption as well.

---

From: Victor Vasiliev <[email-masked]>
Date: Fri, 27 Jul 2018 23:22:35 -0400

I support adoption of this draft and would be happy to review it.

---

From: Tim Wicinski <[email-masked]>
Date: Sat, 28 Jul 2018 04:08:44 -0400

I support adoption of this draft, but as a consumer of SSL certificates
which have *17* wildcards on one certificate, I feel that the handling of
wildcard DNS records in this draft needs some more thought.

Tim