Subject: Re: [TLS] Request to register value in TLS extension registry

From: "Salz, Rich" <[email-masked]>
Date: Wed, 3 Oct 2018 16:28:12 +0000

Yoav and I (two of the three designated experts) approve the assignment of 26 for TLS-LTS.

Sorry for the delays in getting the workflow worked out, Peter.

On 9/25/18, 2:32 PM, "Peter Gutmann" <[email-masked]> wrote:

    >Now that RFC 8447 is published, I'd like to request the addition of extension
    >ID 26 for TLS-LTS:
    >
    >https://datatracker.ietf.org/doc/draft-gutmann-tls-lts/
    >
    >This extension has been waiting for quite some time for the publication of
    >8447, so it's already in use by implementations.
    
    As per RFC 8447, I requested allocation of extension ID 26 for TLS-LTS on 20
    August. The RFC says:
    
    Specification Required [RFC8126] registry requests are registered after a
    three-week review period
    
    It's now been more than the three weeks listed in the RFC, what happens now?
    Can I list the extension as allocated in the LTS draft?
    
    Peter.

---

From: "Amanda Baber via RT" <[email-masked]>
Date: Wed, 03 Oct 2018 18:52:24 +0000

Hi all,

We've registered the following TLS ExtensionType Value:

Value: 26
Extension Name: tls_lts	
TLS 1/3: -	
Recommended: N
Reference: [draft-gutmann-tls-lts]

Please see
https://www.iana.org/assignments/tls-extensiontype-values

Our preference is that the contents of the "TLS 1.3" and "Recommended" fields be added to the IANA Considerations section.

Best regards,

Amanda Baber
Lead IANA Services Specialist

---

From: Peter Gutmann <[email-masked]>
Date: Thu, 4 Oct 2018 02:56:00 +0000

>Sorry for the delays in getting the workflow worked out, Peter.

No problem, someone had to be the beta tester :-).

Peter.