Subject: [TLS] HELLO_VERIFY_REQUEST during abbreviated handshake (session resumption)

From: Simon Bernard <[email-masked]>
Date: Wed, 3 Oct 2018 16:04:07 +0200

Hi,

    In DTLS 1.2 over UDP, I would like to know what is the 
recommendation about using HELLO_VERIFY_REQUEST during an abbreviated 
handshake.

    Should we send it all the time ? or could we avoid to send it if 
SESSION ID is known ?

Thx,

Simon

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 16 Oct 2018 13:18:27 -0700

Hi Simon,

I don't think we specified a concrete recommendation, but I think the
answer is probably no. The reason is that:

(a) a resumed handshake is very cheap, so it's not really saving CPU
(b) the server's first flight is small in resumption, so amplification
isn't much of an issue.

Maybe I'm missing something though.

-Ekr

On Wed, Oct 3, 2018 at 7:05 AM Simon Bernard <[email-masked]>
wrote:

> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>

---

From: Simon Bernard <[email-masked]>
Date: Fri, 19 Oct 2018 16:20:34 +0200

Thx Ekr. Here is a discussion about our concerns : 
https://github.com/eclipse/californium/pull/751

Le 16/10/2018 à 22:18, Eric Rescorla a écrit :
> On Wed, Oct 3, 2018 at 7:05 AM Simon Bernard <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Hi,
>
>     [email-masked] <mailto:[email-masked]>