Subject: Re: [TLS] WGLC for draft-ietf-tls-dtls-connection-id

From: "Salz, Rich" <[email-masked]>
Date: Wed, 5 Dec 2018 18:15:03 +0000

Still stuck in that five-day-behind timezone, but I read this doc and have no problems.  Advance it.

From: Joseph Salowey <[email-masked]>
Date: Wednesday, November 7, 2018 at 2:40 AM
To: "[email-masked]" <[email-masked]>
Subject: [TLS] WGLC for draft-ietf-tls-dtls-connection-id

This is the working group last call for the "Connection Identifiers for DTLS 1.2" draft available at https://datatracker.ietf.org/doc/draft-ietf-tls-dtls-connection-id/<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dtls-2Ddtls-2Dconnection-2Did_&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=iqBSgMFiImiHzfVRyybXVZ-sDu8u_4S7Arwhr9LoYCk&s=2lKHSWzhVyvp_ezQjZN3wJWpxINMJ4H-xR_9VPxzIjA&e=>. Please review the document and send your comments to the list by 2359 UTC on 30 November 2018.

Thanks,
Chris, Joe, and Sean

---

From: "Kraus Achim (INST/ECS4)" <[email-masked]>
Date: Thu, 6 Dec 2018 08:19:18 +0000

Hi List,

I put some comments and question on the github page,

https://github.com/tlswg/dtls-conn-id/issues/15

https://github.com/tlswg/dtls-conn-id/issues/25

and still wait for feedback and comments. FMPOV, the last changes

https://github.com/tlswg/dtls-conn-id/pull/13

seems to be not complete worked out.

Mit freundlichen Grüßen / Best regards

Achim Kraus

(INST/ECS4)
Bosch Software Innovations GmbH | Stuttgarter Straße 130 | 71332 Waiblingen | GERMANY | www.bosch-si.com<http://www.bosch-si.com>

Sitz: Berlin, Registergericht: Amtsgericht Charlottenburg; HRB 148411 B
Aufsichtsratsvorsitzender: Dr.-Ing. Thorsten Lücke; Geschäftsführung: Dr. Stefan Ferber, Michael Hahn, Dr. Aleksandar Mitrovic

From: TLS <[email-masked]> On Behalf Of Salz, Rich
Sent: Mittwoch, 5. Dezember 2018 19:15
To: Joseph Salowey <[email-masked]>; <[email-masked]> <[email-masked]>
Subject: Re: [TLS] WGLC for draft-ietf-tls-dtls-connection-id

From: Joseph Salowey <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, November 7, 2018 at 2:40 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [TLS] WGLC for draft-ietf-tls-dtls-connection-id

Thanks,
Chris, Joe, and Sean

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 6 Dec 2018 05:43:57 -0800

> https://github.com/tlswg/dtls-conn-id/issues/15

This is IANA considerations. I will fix.

> https://github.com/tlswg/dtls-conn-id/issues/25

This is just a bit incomplete in terms of explaining how the MAC works for
other ciphers. I'll fix. I've explained in the issue why the CID needs to
be in the MAC.

> seems to be not complete worked out.
Are there other concerns

-Ekr

>
>
> *Achim Kraus *
> (INST/ECS4)
> Bosch Software Innovations GmbH | Stuttgarter Straße 130 | 71332
> Waiblingen | GERMANY | www.bosch-si.com
>
> Aufsichtsratsvorsitzender: Dr.-Ing. Thorsten Lücke; Geschäftsführung: Dr.
> Stefan Ferber, Michael Hahn, Dr. Aleksandar Mitrovic
>
>
>
> *From:* TLS <[email-masked]> *On Behalf Of * Salz, Rich
> *Sent:* Mittwoch, 5. Dezember 2018 19:15
> *To:* Joseph Salowey <[email-masked]>; <[email-masked]> <[email-masked]>
> *Subject:* Re: [TLS] WGLC for draft-ietf-tls-dtls-connection-id
>
>
>
> *From: *Joseph Salowey <[email-masked]>
> *Date: *Wednesday, November 7, 2018 at 2:40 AM
> *To: *"[email-masked]" <[email-masked]>
> *Subject: *[TLS] WGLC for draft-ietf-tls-dtls-connection-id
>
>
>
> This is the working group last call for the "Connection Identifiers for
> DTLS 1.2" draft available at
> https://datatracker.ietf.org/doc/draft-ietf-tls-dtls-connection-id/
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dtls-2Ddtls-2Dconnection-2Did_&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=iqBSgMFiImiHzfVRyybXVZ-sDu8u_4S7Arwhr9LoYCk&s=2lKHSWzhVyvp_ezQjZN3wJWpxINMJ4H-xR_9VPxzIjA&e=>.
> Please review the document and send your comments to the list by 2359 UTC
> on 30 November 2018.
>
> Thanks,
> Chris, Joe, and Sean
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>

---

From: "Kraus Achim (INST/ECS4)" <[email-masked]>
Date: Thu, 6 Dec 2018 14:07:46 +0000

Hello Eric,

> Are there other concerns

No, there are no other concerns, these two issues addresses my findings.

Achim Kraus

(INST/ECS4) 
Bosch Software Innovations GmbH | Stuttgarter Straße 130 | 71332 Waiblingen | GERMANY | http://www.bosch-si.com 

From: Eric Rescorla <[email-masked]> 
Sent: Donnerstag, 6. Dezember 2018 14:44
To: Kraus Achim (INST/ECS4) <[email-masked]>
Cc: <[email-masked]> <[email-masked]>
Subject: Re: [TLS] WGLC for draft-ietf-tls-dtls-connection-id

On Thu, Dec 6, 2018 at 12:19 AM Kraus Achim (INST/ECS4) <mailto:[email-masked]> wrote:
Hi List,

This is just a bit incomplete in terms of explaining how the MAC works for other ciphers. I'll fix. I've explained in the issue why the CID needs to be in the MAC.

 

Are there other concerns

-Ekr

Achim Kraus

(INST/ECS4) 
Bosch Software Innovations GmbH | Stuttgarter Straße 130 | 71332 Waiblingen | GERMANY | http://www.bosch-si.com 

From: TLS <mailto:[email-masked]> On Behalf Of Salz, Rich
Sent: Mittwoch, 5. Dezember 2018 19:15
To: Joseph Salowey <mailto:[email-masked]>; <mailto:[email-masked]> <mailto:[email-masked]>
Subject: Re: [TLS] WGLC for draft-ietf-tls-dtls-connection-id

From: Joseph Salowey <mailto:[email-masked]>
Date: Wednesday, November 7, 2018 at 2:40 AM
To: "mailto:[email-masked]" <mailto:[email-masked]>
Subject: [TLS] WGLC for draft-ietf-tls-dtls-connection-id
 
This is the working group last call for the "Connection Identifiers for DTLS 1.2" draft available at https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dtls-2Ddtls-2Dconnection-2Did_&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=iqBSgMFiImiHzfVRyybXVZ-sDu8u_4S7Arwhr9LoYCk&s=2lKHSWzhVyvp_ezQjZN3wJWpxINMJ4H-xR_9VPxzIjA&e=. Please review the document and send your comments to the list by 2359 UTC on 30 November 2018.

Thanks,
Chris, Joe, and Sean
mailto:[email-masked]

---

From: Joseph Salowey <[email-masked]>
Date: Mon, 10 Dec 2018 21:18:52 -0800

The WGLC for draft-ietf-tls-dtls-connection-id has completed.   There were
some minor issued raised that require a new revision of the draft before
progressing to the ISEG.

Thanks,

Chris, Joe, and Sean

On Thu, Dec 6, 2018 at 6:08 AM Kraus Achim (INST/ECS4) <
[email-masked]> wrote:

> Waiblingen | GERMANY | http://www.bosch-si.com
>
> Waiblingen | GERMANY | http://www.bosch-si.com
>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dtls-2Ddtls-2Dconnection-2Did_&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=iqBSgMFiImiHzfVRyybXVZ-sDu8u_4S7Arwhr9LoYCk&s=2lKHSWzhVyvp_ezQjZN3wJWpxINMJ4H-xR_9VPxzIjA&e=.