Subject: [TLS] TLSv1.3 - purpose of _0 in {client, server}_application_traffic_secret_0

From: M K Saravanan <[email-masked]>
Date: Wed, 3 Apr 2019 00:20:26 +0800

Hi,

In TLSv1.3, what is the purpose of _0 suffix in the following:

client_application_traffic_secret_0
server_application_traffic_secret_0

with regards,
Saravanan

---

From: Steven Valdez <[email-masked]>
Date: Tue, 2 Apr 2019 12:29:39 -0400

They indicate that those are the initial client/server application traffic
secrets, which are then updated via KeyUpdates (section 7.2,
https://tools.ietf.org/html/draft-ietf-tls-tls13#section-7.2).

On Tue, Apr 2, 2019 at 12:20 PM M K Saravanan <[email-masked]> wrote:

> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>

-- 

Steven Valdez |  Chrome Networking |  [email-masked] |  210-692-4742