Subject: [TLS] I-D Action: draft-ietf-tls-certificate-compression-05.txt

From: [email-masked]
Date: Fri, 05 Apr 2019 03:03:27 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Transport Layer Security WG of the IETF.

        Title           : TLS Certificate Compression
        Authors         : Alessandro Ghedini
                          Victor Vasiliev
	Filename        : draft-ietf-tls-certificate-compression-05.txt
	Pages           : 7
	Date            : 2019-04-05

Abstract:
   In TLS handshakes, certificate chains often take up the majority of
   the bytes transmitted.

   This document describes how certificate chains can be compressed to
   reduce the amount of data transmitted and avoid some round trips.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-tls-certificate-compression/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-tls-certificate-compression-05
https://datatracker.ietf.org/doc/html/draft-ietf-tls-certificate-compression-05

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-tls-certificate-compression-05

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Alessandro Ghedini <[email-masked]>
Date: Fri, 5 Apr 2019 11:11:42 +0100

>    reduce the amount of data transmitted and avoid some round trips.

This new version addresses the latest round of comments from both the session
at IETF 104 as well as varios discussions on the list.

CHanges include:

* Fix in the definition of CertificateCompressionAlgorithms.
* Clarifications on certain design decisions behnd the spec.
* Definition of requirements on the allowed compression functions.
* Inclusion of code point for the zstd compression algorithm.

We think all of the outstanding issues have now been addressed, so WGLC maybe?

Cheers

---

From: Jeremy Harris <[email-masked]>
Date: Fri, 5 Apr 2019 11:34:34 +0100

>    reduce the amount of data transmitted and avoid some round trips.

Reducing the number of bytes (and possibly packets) is a good thing,
but how does this reduce roundtrips?
-- 
Thanks,
  Jeremy

---

From: John Mattsson <[email-masked]>
Date: Fri, 5 Apr 2019 11:03:58 +0000

If fragmentation is used on some layer, lowering the number of bytes can definitely reduce the number of round-trips. This should probably be explained a bit more.

If used in any of the TLS based EAP methods, the use of compression may even be needed to make the handshake complete at all as many access points drop EAP connections after 40-50 packets.
https://tools.ietf.org/html/draft-ms-emu-eaptlscert-02

John

-----Original Message-----
From: TLS <[email-masked]> on behalf of Jeremy Harris <[email-masked]>
Date: Friday, 5 April 2019 at 12:35
To: "[email-masked]" <[email-masked]>
Subject: Re: [TLS] I-D Action: draft-ietf-tls-certificate-compression-05.txt

    
    _______________________________________________
    TLS mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/tls

---

From: Patrick McManus <[email-masked]>
Date: Fri, 5 Apr 2019 13:44:37 +0200

also congestion control interaction will typically cause more bytes to
incur extra round trips - especially early in the connection.

On Fri, Apr 5, 2019 at 1:04 PM John Mattsson <[email-masked]>
wrote:

> If fragmentation is used on some layer, lowering the number of bytes can
> definitely reduce the number of round-trips. This should probably be
> explained a bit more.
>
> If used in any of the TLS based EAP methods, the use of compression may
> even be needed to make the handshake complete at all as many access points
> drop EAP connections after 40-50 packets.
> Subject: Re: [TLS] I-D Action:
> draft-ietf-tls-certificate-compression-05.txt
>