Subject: [TLS] TLS Flags extension - not sure it makes sense

From: Chris Inacio <[email-masked]>
Date: Tue, 23 Jul 2019 22:09:29 +0000

I really want the savings on the wire that TLS flags extension provides – and so I think it’s really good for the future cTLS but I’m not sure when I get to use it in TLS 1.3 negotiation.  It goes in the clientHello message, but how will I know that the server uses this extension?  I envision a future where we will add the flags extension along with the more expensive 4-bytes version for a REALLY long time.

Is there a plan / ability to turn off the 4-byte version?

(BTW: I’m happy if people who really work the details of TLS tell me I mis-understand.  I hope I do.)

---

From: Adam Langley <[email-masked]>
Date: Tue, 23 Jul 2019 18:18:00 -0700

> I really want the savings on the wire that TLS flags extension provides – and so I think it’s really good for the future cTLS but I’m not sure when I get to use it in TLS 1.3 negotiation.  It goes…

The expectation is that applicable future extensions will be defined
as flags. Therefore, if the server supports the extension that you're
interested in then it'll also have to support the flags extension. If
it doesn't, then the extension will be ignored as normal.

Cheers

AGL