Subject: [TLS] Comments on draft-ietf-tls-tls13-cert-with-extern-psk-02

From: "Hammell, Jonathan F" <[email-masked]>
Date: Thu, 18 Jul 2019 16:01:12 +0000

Classification: UNCLASSIFIED

I realize publication has been requested for this draft, but I have a few comments that the author might want to address, if still possible.

1. The draft says that if none of the PSKs provided by the client are acceptable to the server, then the extension must be omitted from the ServerHello message.  Nothing is said about how the client should behave if it receives this: continue or abort with what error code?

2. It can be detected if two PSK identifiers sent in the same ClientHello have the same PSK value by observing the binder values.  Granted, I can't think why this would occur, but it might be important to point this out in the Security Considerations in order for implementers to be clear about security guarantees.

3. Section 4, paragraph 3 states that "If none of the external
   PSKs in the list provided by the client is acceptable to the server,
   then the "tls_cert_with_extern_psk" extension is omitted from the
   ServerHello message."

Section 5 has a similar statement but using the word "MUST": "If none of the
   offered external PSKs in the list provided by the client are
   acceptable to the server, then the "tls_cert_with_extern_psk"
   extension MUST be omitted from the ServerHello message."

These statements should be consistent in the requirement language.

4. Section 5, paragraph starting with "The identities are a list of external PSK identities...": s/identities may be know to other parties/identities may be known to other parties

Best regards,
Jonathan

--
Jonathan Hammell
Canadian Centre for Cyber Security
[email-masked]

---

From: Russ Housley <[email-masked]>
Date: Thu, 18 Jul 2019 15:39:13 -0400

The document s with the IESG, and it should soon be in IETF Last Call.  I will address these as early IETF Last Call comments when that happens.

Russ

> On Jul 18, 2019, at 12:01 PM, Hammell, Jonathan F <[email-masked]> wrote:
> 
>  <>Classification: UNCLASSIFIED
>  
> [email-masked] <mailto:[email-masked]>
>  
>  
>  
> _______________________________________________
> TLS mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/tls <https://www.ietf.org/mailman/listinfo/tls>