Subject: [TLS] Weekly github digest (TLS Working Group Drafts)

From: Repository Activity Summary Bot <[email-masked]>
Date: Sun, 12 Apr 2020 03:32:44 -0400 (EDT)

Issues
------
* tlswg/draft-ietf-tls-esni (+2/-0/💬1)
  2 issues created:
  - Limit "Don't stick out" to explicit signals (by chris-wood)
    https://github.com/tlswg/draft-ietf-tls-esni/issues/215 
  - Clarify whether ClientHelloInner can support TLS 1.2. (by chris-wood)
    https://github.com/tlswg/draft-ietf-tls-esni/issues/214 

  1 issues received 1 new comments:
  - #204 Anonymity sets (1 by ret394)
    https://github.com/tlswg/draft-ietf-tls-esni/issues/204 

* tlswg/draft-ietf-tls-external-psk-importer (+0/-1/💬1)
  1 issues received 1 new comments:
  - #26 Clarify MUSTs (1 by chris-wood)
    https://github.com/tlswg/draft-ietf-tls-external-psk-importer/issues/26 

  1 issues closed:
  - Clarify MUSTs https://github.com/tlswg/draft-ietf-tls-external-psk-importer/issues/26 

* tlswg/tls-exported-authenticator (+1/-0/💬1)
  1 issues created:
  - Generalize authentication terminology (by chris-wood)
    https://github.com/tlswg/tls-exported-authenticator/issues/56 

  1 issues received 1 new comments:
  - #56 Generalize authentication terminology (1 by chris-wood)
    https://github.com/tlswg/tls-exported-authenticator/issues/56 

Pull requests
-------------
* tlswg/draft-ietf-tls-esni (+1/-0/💬4)
  1 pull requests submitted:
  - README: fix links to WG docs (by Lekensteyn)
    https://github.com/tlswg/draft-ietf-tls-esni/pull/213 

  1 pull requests received 4 new comments:
  - #209 padding scheme text (4 by chris-wood, sayrer, sftcd)
    https://github.com/tlswg/draft-ietf-tls-esni/pull/209 

* tlswg/draft-ietf-tls-external-psk-importer (+1/-1/💬0)
  1 pull requests submitted:
  - Tighten up IANA considerations (by jsalowey)
    https://github.com/tlswg/draft-ietf-tls-external-psk-importer/pull/29 

  1 pull requests merged:
  - Editorial pass to simplify text and unify terminology.
    https://github.com/tlswg/draft-ietf-tls-external-psk-importer/pull/28 

* tlswg/draft-ietf-tls-ticketrequest (+1/-0/💬4)
  1 pull requests submitted:
  - Use two counters for fresh and resumed connections (by chris-wood)
    https://github.com/tlswg/draft-ietf-tls-ticketrequest/pull/19 

  1 pull requests received 4 new comments:
  - #19 Use two counters for fresh and resumed connections (4 by chris-wood, martinthomson, tfpauly)
    https://github.com/tlswg/draft-ietf-tls-ticketrequest/pull/19 

* tlswg/dtls13-spec (+0/-0/💬1)
  1 pull requests received 1 new comments:
  - #129 Removed term "deprotection" (1 by ekr)
    https://github.com/tlswg/dtls13-spec/pull/129 

Repositories tracked by this digest:
-----------------------------------
* https://github.com/tlswg/draft-ietf-tls-semistatic-dh
* https://github.com/tlswg/draft-ietf-tls-md5-sha1-deprecate
* https://github.com/tlswg/draft-ietf-tls-esni
* https://github.com/tlswg/certificate-compression
* https://github.com/tlswg/draft-ietf-tls-external-psk-importer
* https://github.com/tlswg/draft-ietf-tls-ticketrequest
* https://github.com/tlswg/tls-flags
* https://github.com/tlswg/dtls13-spec
* https://github.com/tlswg/dtls-conn-id
* https://github.com/tlswg/tls-subcerts
* https://github.com/tlswg/oldversions-deprecate
* https://github.com/tlswg/sniencryption
* https://github.com/tlswg/tls-exported-authenticator
* https://github.com/tlswg/draft-ietf-tls-grease

---

From: Darin Pettis <[email-masked]>
Date: Sun, 12 Apr 2020 16:24:08 -0500

Hi - trying to understand the intent of this:  “Don’t stick out” approach
to eSNI, now being called ECHO apparently.

About a year ago, the understanding was that eSNI would be identifiable and
that enterprises wouldn’t need to use it internally and that it would only
be used on the Internet.

Is that not the case anymore?

On Sun, Apr 12, 2020 at 2:33 AM Repository Activity Summary Bot <
[email-masked]> wrote:

> Sunday April 12, 2020 Issues tlswg/draft-ietf-tls-esni (+2/-0/💬1)
>
> 2 issues created:
>
>    - #215 Limit "Don't stick out" to explicit signals
>    <https://github.com/tlswg/draft-ietf-tls-esni/issues/215> (by
>    chris-wood)
>    - #214 Clarify whether ClientHelloInner can support TLS 1.2.
>    <https://github.com/tlswg/draft-ietf-tls-esni/issues/214> (by
>    chris-wood)
>
>    - #204 Anonymity sets
>    <https://github.com/tlswg/draft-ietf-tls-esni/issues/204> (1 by
>    ret394)
>
> tlswg/draft-ietf-tls-external-psk-importer (+0/-1/💬1)
>
>    - #26 Clarify MUSTs
>    <https://github.com/tlswg/draft-ietf-tls-external-psk-importer/issues/26>
>    (1 by chris-wood)
>
> 1 issues closed:
>
>    - #26 Clarify MUSTs
>    <https://github.com/tlswg/draft-ietf-tls-external-psk-importer/issues/26>
>
> tlswg/tls-exported-authenticator (+1/-0/💬1)
>
> 1 issues created:
>
>    - #56 Generalize authentication terminology
>    <https://github.com/tlswg/tls-exported-authenticator/issues/56> (by
>    chris-wood)
>
>    - #56 Generalize authentication terminology
>    <https://github.com/tlswg/tls-exported-authenticator/issues/56> (1 by
>    chris-wood)
>
> Pull requests tlswg/draft-ietf-tls-esni (+1/-0/💬4)
>
>    - #213 README: fix links to WG docs
>    <https://github.com/tlswg/draft-ietf-tls-esni/pull/213> (by
>    Lekensteyn)
>
>    - #209 padding scheme text
>    <https://github.com/tlswg/draft-ietf-tls-esni/pull/209> (4 by
>    chris-wood, sayrer, sftcd)
>
> tlswg/draft-ietf-tls-external-psk-importer (+1/-1/💬0)
>
>    - #29 Tighten up IANA considerations
>    <https://github.com/tlswg/draft-ietf-tls-external-psk-importer/pull/29>
>    (by jsalowey)
>
> 1 pull requests merged:
>
>    - #28 Editorial pass to simplify text and unify terminology.
>    <https://github.com/tlswg/draft-ietf-tls-external-psk-importer/pull/28>
>
> tlswg/draft-ietf-tls-ticketrequest (+1/-0/💬4)
>
>    - #19 Use two counters for fresh and resumed connections
>    <https://github.com/tlswg/draft-ietf-tls-ticketrequest/pull/19> (by
>    chris-wood)
>
>    - #19 Use two counters for fresh and resumed connections
>    <https://github.com/tlswg/draft-ietf-tls-ticketrequest/pull/19> (4 by
>    chris-wood, martinthomson, tfpauly)
>
> tlswg/dtls13-spec (+0/-0/💬1)
>
>    - #129 Removed term "deprotection"
>    <https://github.com/tlswg/dtls13-spec/pull/129> (1 by ekr)
>
>    - https://github.com/tlswg/draft-ietf-tls-semistatic-dh
>    - https://github.com/tlswg/draft-ietf-tls-md5-sha1-deprecate
>    - https://github.com/tlswg/draft-ietf-tls-esni
>    - https://github.com/tlswg/certificate-compression
>    - https://github.com/tlswg/draft-ietf-tls-external-psk-importer
>    - https://github.com/tlswg/draft-ietf-tls-ticketrequest
>    - https://github.com/tlswg/tls-flags
>    - https://github.com/tlswg/dtls13-spec
>    - https://github.com/tlswg/dtls-conn-id
>    - https://github.com/tlswg/tls-subcerts
>    - https://github.com/tlswg/oldversions-deprecate
>    - https://github.com/tlswg/sniencryption
>    - https://github.com/tlswg/tls-exported-authenticator
>    - https://github.com/tlswg/draft-ietf-tls-grease
>
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 13 Apr 2020 18:06:45 +0000

*   About a year ago, the understanding was that eSNI would be identifiable and that enterprises wouldn’t need to use it internally and that it would only be used on the Internet.

It was always my understanding that the information would be hidden, but that you could always tell it was there.  That is still the case. Only used on the Internet?  Do you have a link to that?

I expect, for example, some browsers will always send it, even if pointing to the same site.