Subject: Re: [TLS] Virtual TLS Interim Meeting

From: Joseph Salowey <[email-masked]>
Date: Fri, 3 Apr 2020 10:15:59 -0700

On Tue, Mar 24, 2020 at 7:54 PM Joseph Salowey <[email-masked]> wrote:

> The chairs think it would be good to schedule a virtual TLS interim
> focused on ECHO and also have a readout from the PSK design team.  We have
> some dates that the IESG has recommended for us.  The proposal is:
>
>         1900 - 2100 UTC  April 27
>
> Please use the following form to let us know if you can attend:
>
>        https://forms.gle/Wkk7dsx9q1ipmi2B9
>
>
[Joe] Of the 26 responses only 1 indicated that the time did not work so we
are moving forward with requesting this meeting time.  More details will
follow once the meeting is scheduled.

> Thanks,
> Chris, Joe, and Sean

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 3 Apr 2020 20:50:01 +0100

Hi Joe,

Pre-agenda bashing question for chairs and authors of
the ESNI/ECHO draft...

I'd like to try again to suggest simplifications for
ECHOConfig (e.g. no extensions, just one public key
per RR VALUE etc.) and perhaps also some more rules
constraining inner/outer CH variances.

How would you prefer those be raised? As issues in GH
or threads on the list and would you rather I try group
'em as much as possible or make each issue as fine-grained
as possible?

Optimistically, this meeting might be the one where we
mostly tie this stuff down, so I hope it's ok that some
of these issues have been raised before in one form or
another. The move from ESNI->ECHO and to HTTPSSVC and
the goal to get to WGLC I think justifies re-checking
if we really need the current level of (what I claim is
too much:-) complexity in ECHO.

Ta,
S.

On 03/04/2020 18:15, Joseph Salowey wrote:
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>

---

From: "Christopher Wood" <[email-masked]>
Date: Sat, 04 Apr 2020 07:36:36 -0700

> 'em as much as possible or make each issue as fine-grained

Fine-grained issues on GitHub would be my preference! Thanks in advance for filing them.

> too much:-) complexity in ECHO.

Hmm... the issues you note above seem somewhat orthogonal to these two changes. The ESNI->ECHO change doesn't seem to affect ECHOConfig contents or extensibility. (We effectively renamed the struct while making the change.) Similarly, HTTPSSVC has more or less the same extensibility properties as the old ESNI RR. That said, I think if there's new data or information that suggests we collectively made poor design decisions, raising them would be helpful. I'll leave it to Sean and Joe to determine whether or not re-hashing some of these issues is appropriate.

Rules around inner/outer CH variance are ripe for discussion, though!

Best,
Chris (no hat)

---

From: Stephen Farrell <[email-masked]>
Date: Sat, 4 Apr 2020 16:21:58 +0100

Hiya,

Ack wrt fine-grained issues. If nobody says otherwise I'll
do that.

On 04/04/2020 15:36, Christopher Wood wrote:
> I'll leave it to Sean and Joe to determine whether or not re-hashing
> some of these issues is appropriate.
Yeah, I figured asking would be best. For a bunch of these
issues, there were mail threads that were (I think, but I'm
biased:-) inconclusive. So in one sense no harm to bottom
out on 'em, but I don't wanna rehash if the chairs figure
things are settled enough.

How about: I'll create GH issues, but I'll not whine if, as
chairs, you decide to just zap some of 'em as repetitive?

Cheers,
S.