Subject: [TLS] Moving SHA-1 signature schemes to not recommended in draft-ietf-tls-md5-sha1-deprecate

From: Joseph Salowey <[email-masked]>
Date: Wed, 24 Jun 2020 22:10:28 -0700

Hi All,

I submitted a PR [1] for draft-ietf-tls-md5-sha1-deprecate to move the
recommended IANA registry entries for  rsa_pkcs1_sha1 and ecdsa_sha1 in the
Signature Scheme registry from Y to N.   This change can be incorporated
with any updates from the AD review.

Please post to this thread if you have any concerns with this change.

Cheers,

Joe

[1] https://github.com/tlswg/draft-ietf-tls-md5-sha1-deprecate/pull/7

---

From: Kathleen Moriarty <[email-masked]>
Date: Thu, 25 Jun 2020 07:32:33 -0400

Thank you, Joe.

Sent from my mobile device

> On Jun 25, 2020, at 1:10 AM, Joseph Salowey <[email-masked]> wrote:
> 
> 
> Hi All,
> 
> I submitted a PR [1] for draft-ietf-tls-md5-sha1-deprecate to move the recommended IANA registry entries for  rsa_pkcs1_sha1 and ecdsa_sha1 in the Signature Scheme registry from Y to N.   This change can be incorporated with any updates from the AD review.  
>

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 25 Jun 2020 12:35:22 +0000

*   I submitted a PR [1] for draft-ietf-tls-md5-sha1-deprecate to move the recommended IANA registry entries for  rsa_pkcs1_sha1 and ecdsa_sha1 in the Signature Scheme registry from Y to N.   This change can be incorporated with any updates from the AD review.

Yes yes yes.

Or no no no?

I think it is remove the “Y” and leave blank, right?

---

From: [email-masked] <[email-masked]>
Date: Tue, 30 Jun 2020 12:07:05 +0200

Looks good to me.