Subject: [TLS] Fwd: [tlswg/draft-ietf-tls-esni] Fix superfluous padding edge cases. (#258)

From: Stephen Farrell <[email-masked]>
Date: Tue, 11 Aug 2020 20:10:19 +0100

I count 32 messages like this, relating to the ESNI draft,
as github discussion, in the last 24 hours.

Some of those do not need to be reflected to the TLS WG
list, but I suspect others do, and before discussion
resolves into an unchangeable outcome on github.

Note: when I say "suspect" I don't mean anyone's being
tricky, I just don't keep open browser tabs for all this
stuff because I prefer to handle substantive discussion
via email on the list.

Are the chairs actively checking that issue-discussion on
github is being properly brought to the mailing list as and
when needed?

Am I alone in being concerned that the efficiency of github
for some is leading to others with different workflows
being left out of discussion?

Ta,
S.

-------- Forwarded Message --------
Subject: [tlswg/draft-ietf-tls-esni] Fix superfluous padding edge cases.
(#258)
Date: Tue, 11 Aug 2020 06:54:08 -0700
From: Christopher Wood <[email-masked]>
Reply-To: tlswg/draft-ietf-tls-esni
<[email-masked]>
To: tlswg/draft-ietf-tls-esni <[email-masked]>
CC: Subscribed <[email-masked]>

Thanks, @bemasc, for raising this! You can view, comment on, or merge
this pull request online at:

  https://github.com/tlswg/draft-ietf-tls-esni/pull/258

-- Commit Summary --

  * Fix superfluous padding edge cases.

-- File Changes --

    M draft-ietf-tls-esni.md (6)

-- Patch Links --

https://github.com/tlswg/draft-ietf-tls-esni/pull/258.patch
https://github.com/tlswg/draft-ietf-tls-esni/pull/258.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/tlswg/draft-ietf-tls-esni/pull/258

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 11 Aug 2020 19:18:42 +0000

You are not alone. :)

---

From: Christopher Patton <[email-masked]>
Date: Tue, 11 Aug 2020 12:33:09 -0700

HI all,

>     being left out of discussion?

This is probably my fault, I apologize. I've been working with Chris Wood
on editorial changes to the draft. These are intended to be purely
presentational-- I figured it was OK to proceed off-list, since we haven't
changed the spec at all. Does anyone object to us proceeding?

Thanks,
Chris Patton

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 11 Aug 2020 12:37:33 -0700

> stuff because I prefer to handle substantive discussion

I note that draft-ietf-git-github explicitly permits discussion on the
issues, with confirmation on-list:

https://datatracker.ietf.org/doc/html/draft-ietf-git-using-github-06#section-5.3

We have found this to be quite efficient in QUIC. While the conventions in
TLS predate the approval of this document, I think this would be good to
adopt here

As far as browser tabs, GitHub allows you to watch the repository and be
notified by email of any discussion. You can also reply by email

-Ekr

> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>

---

From: "Christopher Wood" <[email-masked]>
Date: Tue, 11 Aug 2020 13:00:09 -0700

> stuff because I prefer to handle substantive discussion

For what it's worth, we did plan to email the list for wider discussion before fixing this issue. 

Best,
Chris (no hat)

> Attachments:
> * 0x5AB2FAF17B172BEA.asc
> * signature.asc

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 11 Aug 2020 21:23:53 +0100

Hi,

On 11/08/2020 20:33, Christopher Patton wrote:
> This is probably my fault, I apologize.

No need! It looks like a lot of the editorial/lint
stuff wouldn't need to be brought to the list but
that one looked like it might. And since Chris says
they're gonna mail the list anyway, that'll be fine
then.

The volume is still a bit of a concern though tbh.
Between this and the draft formerly known as httpssvc
there's an awful lot of hopefully non-substantive
changes happening offlist that affect ESNI and more.
I do worry about that "hopefully."

On 11/08/2020 20:37, Eric Rescorla wrote:
> issues, 

Well, sure. I know that some people like that, and
it does have benefits. But also downsides that I'm
sure will be discussed when/if that draft goes to
IETF LC.

> with confirmation on-list:
> 
> 

I do. The mails often have URLs and no substantive body
so it's often not possible to actually take part in a
real discussion that way. And the visibility of the
overall context is very different. In the end github
issues and list discussion are just different, both
with pros and cons. And the latter, as of now, is how
we formally do business. But that's for another place
and time - if the chairs are doing the extra work of
ensuring github-based discussions do get confirmed on
the list in a timely fashion then we'll be ok.

Cheers,
S.

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 11 Aug 2020 13:44:34 -0700

> sure will be discussed when/if that draft goes to

Huh? It's been approved by the IESG and is in AUTH48.
https://datatracker.ietf.org/doc/draft-ietf-git-using-github/

-Ekr

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 11 Aug 2020 21:56:44 +0100

> https://datatracker.ietf.org/doc/draft-ietf-git-using-github/

Shows how much I keep up to speed with github:-)

S.