Subject: Re: [TLS] comments on draft-subcerts

From: Russ Housley <[email-masked]>
Date: Fri, 14 Aug 2020 12:59:49 -0400

I have two comments:

1) The OID assignment for the ASN.1 module was assigned already by IANA.  Please fill it in.

2) I think it would be very helpful to have an example of the extension in an Appendix.  There was discussion on the list about it, and an error was found in the proposed example, which proves the need for an example.

Russ

---

From: Nick Sullivan <[email-masked]>
Date: Wed, 19 Aug 2020 19:32:21 -0700

Thank you Russ and Rich for your comments,

I've attempted to address the comments here:
https://github.com/tlswg/tls-subcerts/pull/80, save for the one about the
example extension.

Russ, which format do you think would be most useful for the extension? I'm
having a hard time finding another extension to model this after.

On Fri, Aug 14, 2020 at 10:00 AM Russ Housley <[email-masked]> wrote:

> 2) I think it would be very helpful to have an example of the extension in
> an Appendix.  There was discussion on the list about it, and an error was
> found in the proposed example, which proves the need for an example.
>
> Russ
>
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 20 Aug 2020 13:19:22 +0000

*   I've attempted to address the comments here: https://github.com/tlswg/tls-subcerts/pull/80<https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_tlswg_tls-2Dsubcerts_pull_80&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=Hixf15djhWIija9QJkTI4w7whANztt9hjISFuzRGo2Q&s=6RyMUabBpLVBxZFPpTn7au08k57raGHF3yKohxFtwq4&e=>, save for the one about the example extension.

Thanks for responding; looks good.

---

From: Russ Housley <[email-masked]>
Date: Thu, 20 Aug 2020 12:01:15 -0400

There are many RFCs that use the PEM encoding to provide example certificates:
     -----BEGIN CERTIFICATE-----
     -----END CERTIFICATE-----

Others use the output of dumpasn1 from Peter Gutmann.

Either one would be fine with me.

Russ

> On Aug 19, 2020, at 10:32 PM, Nick Sullivan <[email-masked]> wrote:
> 
> I've attempted to address the comments here: https://github.com/tlswg/tls-subcerts/pull/80 <https://github.com/tlswg/tls-subcerts/pull/80>, save for the one about the example extension.
> 
> Russ, which format do you think would be most useful for the extension? I'm having a hard time finding another extension to model this after.
> 
> On Fri, Aug 14, 2020 at 10:00 AM Russ Housley <[email-masked] <mailto:[email-masked]>> wrote:
> I have two comments:
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/tls <https://www.ietf.org/mailman/listinfo/tls>

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 20 Aug 2020 16:04:24 +0000

*   There are many RFCs that use the PEM encoding to provide example certificates:
     -----BEGIN CERTIFICATE-----
     -----END CERTIFICATE-----

  *   Others use the output of dumpasn1 from Peter Gutmann.

If you ask I prefer PEM style, but can live with either.

---

From: Russ Housley <[email-masked]>
Date: Thu, 20 Aug 2020 12:10:34 -0400

Yes, my first comment was addressed.

Russ

> On Aug 20, 2020, at 9:19 AM, Salz, Rich <[email-masked]> wrote:
> 
> I've attempted to address the comments here: https://github.com/tlswg/tls-subcerts/pull/80 <https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_tlswg_tls-2Dsubcerts_pull_80&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=Hixf15djhWIija9QJkTI4w7whANztt9hjISFuzRGo2Q&s=6RyMUabBpLVBxZFPpTn7au08k57raGHF3yKohxFtwq4&e=>, save for the one about the example extension.
>

---

From: Nick Sullivan <[email-masked]>
Date: Thu, 20 Aug 2020 09:18:48 -0700

For some reason, I misinterpreted this request as putting a representation
of the TLS extension into the document. An ASN.1 representation of the OID
in the certificate is forthcoming.

Nick

On Thu, Aug 20, 2020 at 9:04 AM Salz, Rich <[email-masked]> wrote:

>
>
>    - There are many RFCs that use the PEM encoding to provide example
>    certificates:
>
>    - Others use the output of dumpasn1 from Peter Gutmann.
>
>
>