Subject: [TLS] Adoption call for draft-rescorla-tls-rfc8446-bis

From: "Christopher Wood" <[email-masked]>
Date: Wed, 02 Sep 2020 09:17:37 -0700

This email begins the adoption call for draft-rescorla-tls-rfc8446-bis. As mentioned [1], this updates language and fixes some errata against RFC8446 (as identified below). No other semantic changes were made.

Errata fixed:
- https://www.rfc-editor.org/errata/eid6141, via https://github.com/ekr/tls13-spec/issues/54
- https://www.rfc-editor.org/errata/eid6205, via https://github.com/ekr/tls13-spec/issues/53
- https://www.rfc-editor.org/errata/eid6204, via https://github.com/ekr/tls13-spec/issues/52
- https://www.rfc-editor.org/errata/eid6150, via https://github.com/ekr/tls13-spec/issues/51
- https://www.rfc-editor.org/errata/eid6147, via https://github.com/ekr/tls13-spec/issues/49
- https://www.rfc-editor.org/errata/eid6139, via https://github.com/ekr/tls13-spec/issues/46
- https://www.rfc-editor.org/errata/eid6138, via https://github.com/ekr/tls13-spec/issues/45
- https://www.rfc-editor.org/errata/eid6137, via https://github.com/ekr/tls13-spec/issues/44
- https://www.rfc-editor.org/errata/eid6135, via https://github.com/ekr/tls13-spec/issues/43
- https://www.rfc-editor.org/errata/eid6128, via https://github.com/ekr/tls13-spec/issues/42
- https://www.rfc-editor.org/errata/eid6125, via https://github.com/ekr/tls13-spec/issues/39
- https://www.rfc-editor.org/errata/eid6122, via https://github.com/ekr/tls13-spec/issues/37
- https://www.rfc-editor.org/errata/eid6152, via https://github.com/ekr/tls13-spec/issues/33
- https://www.rfc-editor.org/errata/eid6146, via https://github.com/ekr/tls13-spec/issues/31
- https://www.rfc-editor.org/errata/eid6145, via https://github.com/ekr/tls13-spec/issues/30
- https://www.rfc-editor.org/errata/eid6142, via https://github.com/ekr/tls13-spec/issues/28
- https://www.rfc-editor.org/errata/eid6136, via https://github.com/ekr/tls13-spec/issues/27
- https://www.rfc-editor.org/errata/eid6123, via https://github.com/ekr/tls13-spec/issues/26
- https://www.rfc-editor.org/errata/eid5868, via https://github.com/ekr/tls13-spec/issues/24
- https://www.rfc-editor.org/errata/eid5682, via https://github.com/ekr/tls13-spec/issues/23
- https://www.rfc-editor.org/errata/eid5483, via https://github.com/ekr/tls13-spec/issues/22
- https://www.rfc-editor.org/errata/eid5627
- https://www.rfc-editor.org/errata/eid5976

Errata ready to close with no action:
- https://www.rfc-editor.org/errata/eid6148
- https://www.rfc-editor.org/errata/eid6144
- https://www.rfc-editor.org/errata/eid6140
- https://www.rfc-editor.org/errata/eid6127
- https://www.rfc-editor.org/errata/eid6126
- https://www.rfc-editor.org/errata/eid6124
- https://www.rfc-editor.org/errata/eid6121
- https://www.rfc-editor.org/errata/eid6120
- https://www.rfc-editor.org/errata/eid5717
- https://www.rfc-editor.org/errata/eid6151
- https://www.rfc-editor.org/errata/eid6143
- https://www.rfc-editor.org/errata/eid5874

Please let the WG know if you support adoption, and if so, are willing to contribute to the discussion and review changes going forward. If you oppose adoption, please explain why. 

The document may be found here:

   https://datatracker.ietf.org/doc/draft-rescorla-tls-rfc8446-bis/

This call for adoption will conclude on September 16.

Best,
Chris, on behalf of the chairs

[1] https://mailarchive.ietf.org/arch/msg/tls/bLPs94FGzzmjNirCn2yf-FFPfqo/

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 2 Sep 2020 16:20:26 +0000

I support this and will help work on it.

---

From: Eric Rescorla <[email-masked]>
Date: Wed, 2 Sep 2020 09:30:17 -0700

Unsurprisingly, I support adoption. My hope here is that we can quickly
flush out remaining issues that could cause confusion and get this to the
IESG.

-Ekr

On Wed, Sep 2, 2020 at 9:20 AM Salz, Rich <rsalz=[email-masked]>
wrote:

> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>

---

From: Tim Wicinski <[email-masked]>
Date: Wed, 2 Sep 2020 12:36:15 -0400

I support adoption on this.

Yes, I'll assist in reviews, etc.

tim

On Wed, Sep 2, 2020 at 12:18 PM Christopher Wood <[email-masked]>
wrote:

> This email begins the adoption call for draft-rescorla-tls-rfc8446-bis. As
> mentioned [1], this updates language and fixes some errata against RFC8446
> (as identified below). No other semantic changes were made.
>
> Errata fixed:
> - https://www.rfc-editor.org/errata/eid6141, via
> https://github.com/ekr/tls13-spec/issues/54
> - https://www.rfc-editor.org/errata/eid6205, via
> https://github.com/ekr/tls13-spec/issues/53
> - https://www.rfc-editor.org/errata/eid6204, via
> https://github.com/ekr/tls13-spec/issues/52
> - https://www.rfc-editor.org/errata/eid6150, via
> https://github.com/ekr/tls13-spec/issues/51
> - https://www.rfc-editor.org/errata/eid6147, via
> https://github.com/ekr/tls13-spec/issues/49
> - https://www.rfc-editor.org/errata/eid6139, via
> https://github.com/ekr/tls13-spec/issues/46
> - https://www.rfc-editor.org/errata/eid6138, via
> https://github.com/ekr/tls13-spec/issues/45
> - https://www.rfc-editor.org/errata/eid6137, via
> https://github.com/ekr/tls13-spec/issues/44
> - https://www.rfc-editor.org/errata/eid6135, via
> https://github.com/ekr/tls13-spec/issues/43
> - https://www.rfc-editor.org/errata/eid6128, via
> https://github.com/ekr/tls13-spec/issues/42
> - https://www.rfc-editor.org/errata/eid6125, via
> https://github.com/ekr/tls13-spec/issues/39
> - https://www.rfc-editor.org/errata/eid6122, via
> https://github.com/ekr/tls13-spec/issues/37
> - https://www.rfc-editor.org/errata/eid6152, via
> https://github.com/ekr/tls13-spec/issues/33
> - https://www.rfc-editor.org/errata/eid6146, via
> https://github.com/ekr/tls13-spec/issues/31
> - https://www.rfc-editor.org/errata/eid6145, via
> https://github.com/ekr/tls13-spec/issues/30
> - https://www.rfc-editor.org/errata/eid6142, via
> https://github.com/ekr/tls13-spec/issues/28
> - https://www.rfc-editor.org/errata/eid6136, via
> https://github.com/ekr/tls13-spec/issues/27
> - https://www.rfc-editor.org/errata/eid6123, via
> https://github.com/ekr/tls13-spec/issues/26
> - https://www.rfc-editor.org/errata/eid5868, via
> https://github.com/ekr/tls13-spec/issues/24
> - https://www.rfc-editor.org/errata/eid5682, via
> https://github.com/ekr/tls13-spec/issues/23
> - https://www.rfc-editor.org/errata/eid5483, via
> https://github.com/ekr/tls13-spec/issues/22
> Please let the WG know if you support adoption, and if so, are willing to
> contribute to the discussion and review changes going forward. If you
> oppose adoption, please explain why.
>

---

From: Ben Smyth <[email-masked]>
Date: Wed, 2 Sep 2020 19:01:46 +0200

I support adoption and I am willing to help work on this. (Eric has already
incorporated many of my suggestions, many thanks for that.)

---

From: David Schinazi <[email-masked]>
Date: Wed, 2 Sep 2020 12:52:01 -0700

I support adoption and am willing to help review.

In case anyone else finds it helpful, here's a diff from RFC 8446:
https://tools.ietf.org/tools/rfcdiff/rfcdiff.pyht?url1=rfc8446&url2=draft-rescorla-tls-rfc8446-bis-00

David

On Wed, Sep 2, 2020 at 10:02 AM Ben Smyth <[email-masked]> wrote:

> I support adoption and I am willing to help work on this. (Eric has
> already incorporated many of my suggestions, many thanks for that.)

---

From: Eric Rescorla <[email-masked]>
Date: Wed, 2 Sep 2020 13:04:34 -0700

> https://tools.ietf.org/tools/rfcdiff/rfcdiff.pyht?url1=rfc8446&url2=draft-rescorla-tls-rfc8446-bis-00

Thanks. I attempted to backport all the substantive changes made in RPC
processing. However, there are a number of places (tables, line breaks,
etc.) where the formatter behaved differently. In addition, some of the
references are different because of differences between
kramdown2629/xml2rfc's automatic reference processing and how the RPC does
things. If you find changes you believe are material, please send PRs.

-Ekr

David

---

From: Richard Barnes <[email-masked]>
Date: Wed, 2 Sep 2020 21:17:03 -0400

I agree that this is a worthwhile effort for the WG.

---

From: Christopher Patton <[email-masked]>
Date: Wed, 2 Sep 2020 18:31:46 -0700

I support adoption.

---

From: Daniel Migault <[email-masked]>
Date: Thu, 3 Sep 2020 22:03:23 -0400

I support adoption.

-- 
Daniel Migault
Ericsson

---

From: Loganaden Velvindron <[email-masked]>
Date: Fri, 4 Sep 2020 09:19:38 +0400

> I support this and will help work on it.
I also support adoption.

---

From: Benjamin Beurdouche <[email-masked]>
Date: Fri, 4 Sep 2020 07:29:39 +0200

I support adoption of this work.
B.

> On Sep 2, 2020, at 6:18 PM, Christopher Wood <[email-masked]> wrote:
>

---

From: "Christopher Wood" <[email-masked]>
Date: Sun, 20 Sep 2020 08:04:49 -0700

The adoption call is now complete. Thanks to everyone who chimed in!

It seems we have consensus to adopt this draft as a WG item. Ekr, can you please submit draft-ietf-tls-rfc8446-bis-00 when convenient?

Thanks,

On Wed, Sep 2, 2020, at 9:17 AM, Christopher Wood wrote:
> This email begins the adoption call for draft-rescorla-tls-rfc8446-bis. 
> As mentioned [1], this updates language and fixes some errata against 
> RFC8446 (as identified below). No other semantic changes were made.
> 
> Errata fixed:
> Please let the WG know if you support adoption, and if so, are willing 
> to contribute to the discussion and review changes going forward. If 
> you oppose adoption, please explain why. 
>