Subject: [TLS] Closing DTLS 1.3 PRs

From: "Christopher Wood" <[email-masked]>
Date: Mon, 04 Jan 2021 20:21:09 -0800

There are currently 12 open PRs [1] against the DTLS 1.3 specification generated in response to Ben's review [2]:

- Require that cipher suites define a record number encryption algorithm (#166)
- PMTU estimates (#168)
- Updates to cookie text (#169)
- Clarify buffering and retransmission requirements (#171)
- Relax age out text (#172)
- Records with bogus epochs should be discarded, not generate alerts (#177)
- RCID excessive (#179)
- Alerts are unreliable (#180)
- Rationale for spare CIDs (#185)
- Forbid going from an empty CID to a non-empty CID (#194)
- Clarify mixing sequence and length settings on the same connection (#195)
- Use DTLS style version values, even for DTLS 1.3 (#196)

Please have a look and provide feedback! Barring objections, we plan to merge these on Monday, January 18. We'll then cut a new version of the draft and move forward.

Best,
Chris, for the chairs

[1] https://github.com/tlswg/dtls13-spec/pulls?q=is%3Apr+is%3Aopen+label%3Aconsensus-needed
[2] https://mailarchive.ietf.org/arch/msg/tls/FJM6OHfvLJP_pF5uUcR86pzrdYo/

---

From: "Christopher Wood" <[email-masked]>
Date: Thu, 07 Jan 2021 13:33:36 -0800

Adding one more to this list:

- Added text regarding the legacy_session_id field (#202)

Best,
Chris

On Mon, Jan 4, 2021, at 8:21 PM, Christopher Wood wrote:
> There are currently 12 open PRs [1] against the DTLS 1.3 specification 
> generated in response to Ben's review [2]:
> 
> Please have a look and provide feedback! Barring objections, we plan to 
> merge these on Monday, January 18. We'll then cut a new version of the 
> draft and move forward.
> 
> Best,
> Chris, for the chairs
> 
> [1] 
> https://github.com/tlswg/dtls13-spec/pulls?q=is%3Apr+is%3Aopen+label%3Aconsensus-needed
> [2] 
> https://mailarchive.ietf.org/arch/msg/tls/FJM6OHfvLJP_pF5uUcR86pzrdYo/
> 
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>

---

From: "Christopher Wood" <[email-masked]>
Date: Wed, 20 Jan 2021 10:58:43 -0800

The consensus call is now complete. Thanks to everyone who left feedback and suggestions for improvement! 

All PRs have been merged and a new version of the draft was submitted. We'll continue moving this document through the publication process now.

Best,
Chris

---

From: Sean Turner <[email-masked]>
Date: Thu, 21 Jan 2021 11:44:10 -0500

Thanks from me as well. There are a couple of I-D pinned on this [1] and I have been pinged a couple of times on the publication date for references from other SDOs.

spt

[1] https://www.rfc-editor.org/cluster_info.php?cid=C321

> On Jan 20, 2021, at 13:58, Christopher Wood <[email-masked]> wrote:
>