Subject: [TLS] Comment on Section 6.1 Closure Alerts in draft-ietf-tls-rfc8446bis-00

From: John Mattsson <[email-masked]>
Date: Fri, 29 Jan 2021 14:28:59 +0000

Hi,

I think Section 6.1 Closure Alerts is a bit unclear:

First it is stated the user_canceled SHOULD be followed by close_notify

   "This alert SHOULD be followed by a "close_notify"." 

Then it is stated that it MUST be followed by close_notify

   "Each party MUST send a "close_notify" alert before closing its write side of the connection,
   unless it has already sent some error alert."

And in the same section is is stated that any data folloing user_canceled MUST be ignored.

   "Any data received after a closure alert has been received MUST be ignored."

This seems quite contradicting to me. I don't know what the correct behavior would be,
but unless I misunderstood something, it looks like it should be addressed in rfc8446bis.

Cheers,
John

---

From: Eric Rescorla <[email-masked]>
Date: Fri, 29 Jan 2021 06:48:04 -0800

Good catch. I have filed https://github.com/tlswg/tls13-spec/issues/1208 to
address it.

-Ekr

On Fri, Jan 29, 2021 at 6:29 AM John Mattsson <john.mattsson=
[email-masked]> wrote:

> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>