Subject: [TLS] Moving the ECH interop target

From: "Christopher Wood" <[email-masked]>
Date: Wed, 24 Feb 2021 10:07:37 -0800

The WG previously decided to make draft-ietf-tls-esni-09 the official target for interop. The diff between this version and the current editor's copy of the draft is below:

   https://tools.ietf.org/rfcdiff?url1=https://tools.ietf.org/id/draft-ietf-tls-esni.txt&url2=https://tlswg.github.io/draft-ietf-tls-esni/draft-ietf-tls-esni.txt

Given the size of the diff, and the recent update to HPKE to prepare it for IRSG review, I'd like to propose that we cut -10 (when the datatracker opens) and use that as the new interop target. This will resolve the moving HPKE target going forward and let that part of the protocol stabilize.

What do other implementers think?

Thanks,
Chris (no hat)

---

From: Rob Sayre <[email-masked]>
Date: Wed, 24 Feb 2021 10:49:17 -0800

>From the Rustls perspective, I think it's fine. The project has been
refactoring its handshake code, one benefit of which will be to make
ECH integration easier.

Ring [1], the crypto library the project uses, hasn't yet added HPKE (that
work is just starting...) so now would be a good time to update the interop
target. I've been using rust-hpke[2] to prototype, but that dependency
won't be in the final version.

thanks,
Rob

[1] https://github.com/briansmith/ring
[2] https://github.com/rozbb/rust-hpke

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 24 Feb 2021 21:13:18 +0000

Hiya,

> What do other implementers think?

That's generally ok, but from my POV it would be
better to give it another week or two before we
do that, e.g. maybe just after IETF-110 or so.

Reason is I've nearly but not quite got -09
interop between (currently mega-hacked;-) OpenSSL
code and the NSS client, and then hopefully
the CF server and would prefer have that done
before we start moving the target again.

OTOH, if the CF -09 server were to remain
available for a bit, then I'd be fine with
this change at any time.

Cheers,
S.

> 
> Thanks,
> Chris (no hat)
> 
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>

---

From: Christopher Patton <[email-masked]>
Date: Wed, 24 Feb 2021 13:30:07 -0800

Hey Stephen, I'd imagine the CF server will stay at ECH-10 through IETF 110.

Best,
Chris P.

On Wed, Feb 24, 2021 at 1:13 PM Stephen Farrell <[email-masked]>
wrote:

> > The WG previously decided to make draft-ietf-tls-esni-09 the official
> target for interop. The diff between this version and the current editor's
> copy of the draft is below:
> >
> >
> > Given the size of the diff, and the recent update to HPKE to prepare it
> for IRSG review, I'd like to propose that we cut -10 (when the datatracker
> opens) and use that as the new interop target. This will resolve the moving
> HPKE target going forward and let that part of the protocol stabilize.
> >

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 24 Feb 2021 21:38:25 +0000

> Hey Stephen, I'd imagine the CF server will stay at ECH-10 through

Great. If I don't get it working by then I
probably never will:-)

So, formally anointing -10 is ok whenever.

Cheers,
S.

> 
> Best, Chris P.
> 
> On Wed, Feb 24, 2021 at 1:13 PM Stephen Farrell
> <[email-masked]> wrote:
> 
>> 
>> Hiya,
>> 
>> target for interop. The diff between this version and the current
>> editor's copy of the draft is below:
>>> 
>>> 
>> for IRSG review, I'd like to propose that we cut -10 (when the
>> datatracker opens) and use that as the new interop target. This
>> will resolve the moving HPKE target going forward and let that part
>> of the protocol stabilize.
>>> 
>> That's generally ok, but from my POV it would be better to give it
>> another week or two before we do that, e.g. maybe just after
>> IETF-110 or so.
>> 
>> Reason is I've nearly but not quite got -09 interop between
>> (currently mega-hacked;-) OpenSSL code and the NSS client, and then
>> hopefully the CF server and would prefer have that done before we
>> start moving the target again.
>> 
>> OTOH, if the CF -09 server were to remain available for a bit, then
>> I'd be fine with this change at any time.
>> 
>> Cheers, S.
>> 
>> 
>>> 
>>> Thanks, Chris (no hat)
>>> 
>>> _______________________________________________ TLS mailing list 
>>> [email-masked] https://www.ietf.org/mailman/listinfo/tls
>>> 
>> _______________________________________________ TLS mailing list 
>> [email-masked] https://www.ietf.org/mailman/listinfo/tls
>> 
>

---

From: Ben Schwartz <[email-masked]>
Date: Wed, 24 Feb 2021 16:43:48 -0500

Maybe tag the git revision that you intend to publish as -10?