Subject: [TLS] SNIP: simplified negotiation of incompatible protocols

From: "Martin Thomson" <[email-masked]>
Date: Wed, 07 Jul 2021 14:44:35 +1000

I've updated my version of the draft we discussed a while back.  After time to reflect, I was convinced by feedback from Benjamin Schwartz suggesting that the more complicated bits of the proposal could be simplifed greatly.  So I did that.

Hopefully this is a little easier to comprehend, implement, and deploy.

https://www.ietf.org/archive/id/draft-thomson-tls-snip-02.html

[*] Yes, the title in the doc differs.

---

From: Ben Schwartz <[email-masked]>
Date: Wed, 7 Jul 2021 11:56:22 -0400

I think this draft is solid and likely worth pursuing in essentially this
form.

On Wed, Jul 7, 2021 at 12:45 AM Martin Thomson <[email-masked]> wrote:

> I've updated my version of the draft we discussed a while back.  After
> time to reflect, I was convinced by feedback from Benjamin Schwartz
> suggesting that the more complicated bits of the proposal could be
> simplifed greatly.  So I did that.
>
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>