Subject: [TLS] Adoption call for "Secure Negotiation of Incompatible Protocols in TLS"

From: "Christopher Wood" <[email-masked]>
Date: Thu, 29 Jul 2021 11:20:58 -0700

Based on positive feedback during this week's meeting, we'd like to start an adoption call for "Secure Negotiation of Incompatible Protocols in TLS." The document may be found here:

   https://datatracker.ietf.org/doc/draft-thomson-tls-snip/

And the source may be found here:

   https://github.com/martinthomson/snip

This call for adoption will conclude on August 13.

Thanks, 
Chris, for the chairs

---

From: Ben Schwartz <[email-masked]>
Date: Thu, 29 Jul 2021 14:32:12 -0400

I support adoption.

On Thu, Jul 29, 2021 at 2:21 PM Christopher Wood <[email-masked]>
wrote:

> Based on positive feedback during this week's meeting, we'd like to start
> an adoption call for "Secure Negotiation of Incompatible Protocols in TLS."
> The document may be found here:
>
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>

---

From: Benjamin Beurdouche <[email-masked]>
Date: Thu, 29 Jul 2021 22:59:25 +0400

I support adoption.
B.

> On Jul 29, 2021, at 10:22 PM, Christopher Wood <[email-masked]> wrote:
>

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 29 Jul 2021 12:14:37 -0700

I support adoption

On Thu, Jul 29, 2021 at 12:00 PM Benjamin Beurdouche <
[email-masked]> wrote:

> > Based on positive feedback during this week's meeting, we'd like to
> start an adoption call for "Secure Negotiation of Incompatible Protocols in
> TLS." The document may be found here:
> >

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 29 Jul 2021 19:44:07 +0000

>   Based on positive feedback during this week's meeting, we'd like to start an adoption call for "Secure Negotiation of Incompatible Protocols in TLS." The document may be found here:

I support this.  I will read and review, and perhaps make a PR that eventually adds this to OpenSSL.

---

From: "Martin Thomson" <[email-masked]>
Date: Fri, 30 Jul 2021 10:32:45 +1000

On Fri, Jul 30, 2021, at 04:20, Christopher Wood wrote:
> start an adoption call for "Secure Negotiation of Incompatible 
> Protocols in TLS." The document may be found here:
> 

Yeah, I think we should do this.  Just in case there was any doubt.

---

From: David Schinazi <[email-masked]>
Date: Fri, 30 Jul 2021 09:49:17 -0700

I support adoption.
David