Subject: Re: [TLS] Implementations of draft-ietf-tls-flags and draft-ietf-tls-cross-sni-resumption

From: Christopher Wood <[email-masked]>
Date: Wed, 2 Feb 2022 18:08:54 -0800

Hi Jens,

> On Jan 28, 2022, at 9:14 AM, Jens Guballa <[email-masked]> wrote:
> 
> Am 27.01.22 um 17:35 schrieb Christopher Wood:
>> In preparing to move draft-ietf-tls-flags and draft-ietf-tls-cross-sni-resumption forward in the process, I’m curious if anyone is aware of implementations of either specification. If you know of an implementation, can you please share it here?
>> 
> I am not sure what your intention is. In case you are looking for a counterpart to test a server implementation, you can have a look at https://gitlab.com/guballa/tlsmate. With that tool you can create and execute arbitrary TLS handshake scenarios against TLS servers. The TLS-flags extension is not supported (yet), but setting up (or checking) any extension as a bytestring is possible. Basic python knowledge is required, though.

Thanks for sharing tlsmate!

To clarify the original request, we are asking about _existing_ implementations of draft-ietf-tls-flags or draft-ietf-tls-cross-sni-resumption. While one could implement either using tlsmate, that has not yet been done (as you point out).

Best,
Chris

---

From: Sean Turner <[email-masked]>
Date: Thu, 3 Feb 2022 11:46:07 -0500

> On Feb 2, 2022, at 21:08, Christopher Wood <[email-masked]> wrote:
> 
> Hi Jens,
> 

When the chairs shift the I-Ds out of the WG to the AD (Area Director) [0], we also need to submit a write-up [0] that our AD and the rest of the IESG will review. One of the questions is whether there are existing implementations.

Cheers,
spt

[0] https://www.ietf.org/chairs/document-writeups/

---

From: Jens Guballa <[email-masked]>
Date: Thu, 3 Feb 2022 18:49:25 +0100

Am 03.02.22 um 17:46 schrieb Sean Turner:
>> On Feb 2, 2022, at 21:08, Christopher Wood<[email-masked]>  wrote:
>>
>> Hi Jens,
>>
>>> On Jan 28, 2022, at 9:14 AM, Jens Guballa<[email-masked]>  wrote:
>>>
>>> I am not sure what your intention is. In case you are looking for a counterpart to test a server implementation, you can have a look athttps://gitlab.com/guballa/tlsmate. With that tool you can create and execute arbitrary TLS handshake scenarios against TLS servers. The TLS-flags extension is not supported (yet), but setting up (or checking) any extension as a bytestring is possible. Basic python knowledge is required, though.
Thanks for the clarification. Is there a value reserved for the 
tls-flags extension? I couldn't find one, neither in the draft nor in 
the IANA registry.

Thanks,
Jens
>
> Cheers,
> spt
>
> [0]https://www.ietf.org/chairs/document-writeups/

---

From: Christopher Wood <[email-masked]>
Date: Thu, 3 Feb 2022 09:53:16 -0800

> On Feb 3, 2022, at 9:49 AM, Jens Guballa <[email-masked]> wrote:
> 
> 
> 
>>>> I am not sure what your intention is. In case you are looking for a counterpart to test a server implementation, you can have a look at https://gitlab.com/guballa/tlsmate
>>>> . With that tool you can create and execute arbitrary TLS handshake scenarios against TLS servers. The TLS-flags extension is not supported (yet), but setting up (or checking) any extension as a bytestring is possible. Basic python knowledge is required, though.
>>>> 
> Thanks for the clarification. Is there a value reserved for the tls-flags extension? I couldn't find one, neither in the draft nor in the IANA registry.

Nope, not yet. We still need to get a codepoint for the extension. We can probably do that now. =)

Best,
Chris

---

From: Ilari Liusvaara <[email-masked]>
Date: Wed, 16 Feb 2022 11:22:14 +0200

On Thu, Feb 03, 2022 at 09:53:16AM -0800, Christopher Wood wrote:
> > tls-flags extension? I couldn't find one, neither in the draft
> > nor in the IANA registry.
> 

On assigning the value, I noticed the draft talks about including the
flags extension in literially every TLS message with extension block.
However, the IANA assignment request only has "CH,SH,EE" (in both -08
and Git HEAD). I think that should be "CH,HRR,SH,EE,CR,CT,NST" (or
however those should be ordered).

-Ilari

---

From: Christopher Wood <[email-masked]>
Date: Thu, 17 Feb 2022 09:59:10 -0800

> On Feb 16, 2022, at 1:22 AM, Ilari Liusvaara <[email-masked]> wrote:
> 

Thanks for flagging this, Ilari! Here’s a PR to correct the issue:

   https://github.com/tlswg/tls-flags/pull/18

Best,
Chris