Subject: Re: [TLS] DTLS for Delegated Credentials (draft-ietf-tls-subcerts)?

From: Sean Turner <[email-masked]>
Date: Tue, 1 Mar 2022 09:21:02 -0500

Thanks to all that responded.

I have create this issue:
https://github.com/tlswg/tls-subcerts/issues/94
And this PR to address the issue:
https://github.com/tlswg/tls-subcerts/pull/95

spt

> On Feb 23, 2022, at 05:12, Hannes Tschofenig <[email-masked]> wrote:
> 
> Hi Sean, Hi all,
> 
> I think the document should also include a reference to DTLS since there is no reason that sub-certs do not apply to DTLS as well.
> 
> Ciao
> Hannes
> 
> 
> -----Original Message-----
> From: TLS <[email-masked]> On Behalf Of Sean Turner
> Sent: Wednesday, February 16, 2022 9:26 PM
> To: TLS List <[email-masked]>
> Subject: [TLS] DTLS for Delegated Credentials (draft-ietf-tls-subcerts)?
> 
> Hi
> 
> During Ben Kaduk’s AD review of draft-ietf-tls-subcerts, he noted that we need to address whether the I-D can also apply to DTLS. This might be useful for WebRTC, for example.
> 
> Right now the I-D exclusively mentions TLS. The fix might be as easy as a global replace of TLS with (D)TLS. Can anybody think of a reason to preclude DTLS?
> 
> We also need to say one way or the other becase we need to tell IANA to what to put in the “DTLS-Only” column when registering the “delegated_credentials” extension.
> 
> Cheers,
> spt (for the chairs)
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
> IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Ilari Liusvaara <[email-masked]>
Date: Tue, 1 Mar 2022 17:56:05 +0200

> https://github.com/tlswg/tls-subcerts/pull/95

I do not think the TLS context string should be changed. That breaks
compatiblity, and this extension already has seemingly permanent IANA
registration. So I think that change is far from harmless.

-Ilari

---

From: Christopher Wood <[email-masked]>
Date: Tue, 1 Mar 2022 09:12:38 -0800

> On Mar 1, 2022, at 7:56 AM, Ilari Liusvaara <[email-masked]> wrote:
> 

Oh, thanks for flagging that. That didn’t register to me when looking at the diff. I would agree that changing the context string doesn’t really help here.

Best,
Chris