Subject: Re: [Tm-rid] Proposed WG Charter v2

From: Michael Richardson <[email-masked]>
Date: Mon, 02 Dec 2019 09:04:37 -0500

I am enthusiatic about this work, although I don't anticipate being able to
be more than a bystandard on this.

Robert Moskowitz <[email-masked]> wrote:
    > TM-RID will build upon the Host Identity Tag (HIT) from the Host Identity
    > Protocol (HIP) as an RID and augment it and supporting HIP and other IETF
    > technologies to add trustworthiness to the ASTM messaging suite. 

I think that this sentence needs editing.  Too many ".. and"

    > The goal is
    > to provide trustworthiness both in an Internet connected environment and
    > emergency, unconnected situations within the highly constrained environment
    > of UAS.

I think that a reference for the nature of the constrained environment might
be in order.

    > The Host Identity Tag (HIT) is ideally, in fact uniquely, suited to work
    > within this RID effort.  The Host Identity (HI) behind the HIT can be used to
    > sign Broadcast Authentication Messages, thus proving ownership of the RID
    > (HIT) and signed messages.  HITs provide significantly superior privacy
    > compared to other allowed RID types while providing greater assurance to
    > authorized observers that they are accessing the proper PII for the UA.

This wanders into solution space, and I think it would be better to omit this.

    > TM-RID will create specifications for HIP-augmented ASTM RID messages. 
    > Initially this will consist of additional RID Authentication Messages that
    > use the HI in public key signing operations: to prove UAS ownership of a
    > Hierarchical HIT (HHIT); to authenticate other claims made via RID, such as
    > position and velocity, as having been made by the owner of that HHIT; and to
    > provide observers lacking current Internet connectivity with locally
    > verifiable UAS proof-of-registration objects.

removing some of the solutions, leaving the requirements:

TM-RID will create specifications to prove UAS ownership of a
Hierarchical HIT (HHIT); providing a framework to authenticate other claims, such as
position and velocity, as having been made by the owner of that HHIT; and to
provide observers lacking current Internet connectivity with locally
verifiable UAS proof-of-registration objects.

I would have written this as numbered points.

    > For this, HIP would be amended to be used effectively in this environment:

I think you could put a period instead of : and omit the next three paragraphs.

    > HHITs are envisioned to identify all components in the UAS/UTM (UAS Traffic
    > Management) environment: UA, Command Consoles, Observer devices, and
    > Registries.  This will entail further work as experience is gained in using
    > HIP for UAS RID.  For example, some (UTM) systems envision using OAuth for
    > Ground Control Systems (GCS) and authorized safety personnel.  HIP as an
    > OAuth method may help in merging HIP into these systems.

    > The workgroup will need to liaison with the various SDOs working in the UAS
    > regulation space.

Please if you could list those SDOs?
Do we need to do liason agreements with them?  I would be happier if that was
part of the plan.

How will we engage with implementers?  I.e. how are we going to get running-code?

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: "Card, Stu" <[email-masked]>
Date: Mon, 2 Dec 2019 12:31:13 -0500

I will try wordsmithing this week.

On Mon, Dec 2, 2019, 09:04 Michael Richardson <[email-masked]> wrote:

>     > TM-RID will create specifications for HIP-augmented ASTM RID
> messages..
> Tm-rid mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tm-rid
>