Subject: [Tm-rid] Making progress to the TMRID charter

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Thu, 6 Feb 2020 15:54:09 +0000

There was some discussions among the IESG, IAB and TM-RID BoF chairs about the charter during today IESG telechat. The latest version is below but we need to wait until Monday when Magnus will have time to review it and probably clear his BLOCK (Ben has promised to have a look at the revised draft before our interim meeting).

Let’s discuss it later today.

-éric

----
Civil Aviation Authorities (CAAs) worldwide have initiated rule making for Unmanned Aircraft Systems (UAS) Remote Identification (RID). CAAs currently promulgate performance-based regulations that do not mandate specific techniques, but rather cite industry-consensus technical standards as acceptable means of compliance. One key standard is ASTM (formerly the American Society for Testing and Materials) WK65041 [1]. This specification defines the baseline design, construction, and verification requirements for an UAS. Network RID defines a set of information for UAS to make available globally via the Internet. Broadcast RID defines a set of messages for UAS to send locally one-way over Bluetooth or Wi-Fi. But WK65041 does not address how to populate/query registries, how to ensure trustworthiness of information, nor how to make the information useful.

TMRID’s goal is to specify how RID can be made available in both Internet and local-only connected scenarios, especially in emergency situations. Some UAS operate in environments where the network or the devices or both are severely constrained [2] in terms of processing, bandwidth (e.g., Bluetooth 4 packet is 21 byte long), or battery life, and TMRID aims to function in these environments. The specifications produced by the WG will need to balance public safety authorities’ need to know trustworthy information with UAS operators’ privacy.

The working group will primarily leverage Internet standards (including HIP, EPP, RDAP and DNS) and infrastructure as well as domain name registration business models. The WG will track the requirements being developed by regulatory authorities including the US Federal Aviation Administration (US FAA) and the European Union Civil Aviation Authority CAA) and will aim to align with those requirements (e.g., [3]).

The working group will work on the following items:
* Requirements: The WG is expected to provide an information document that lists the requirements the UAS Remote Identification (UAS RID) - that is the system for identifying UA during flight by other parties must meet. Requirements will also include those associated to the UAS Identifier that need to both meet some constraints as well as some specific properties.
* Architecture: The WG will propose a standard document that describes the architecture that address the requirements and that will re-use protocols or architectures already standardized at the IETF.
* Protocol design: While the primary purpose of TM-RID WG is to leverage on existing protocols, the specificities of the UAS environment is likely to require existing protocols to be extended or new protocols to be designed. The WG will be focused on standardizing this protocols or extensions.

List of candidate drafts:
- draft-card-tmrid-uas-reqs
- draft-card-tmrid-uas-arch
- draft-wiethuechter-tmrid-auth
- draft-moskowitz-hip-new-crypto
- draft-moskowitz-orchid-cshake
- draft-moskowitz-hip-hierarchical-hit
- draft-moskowitz-hip-hhit-registries

References:
[1] ASTM International F38 Committee Work Item WK65041 “Standard Specification for UAS Remote ID and Tracking” https://www.astm.org/DATABASE.CART/WORKITEMS/WK65041.htm
[2] UAS Identification and Tracking Aviation Rulemaking Committee Recommendations Final Report 2017 SEP 30 https://www.faa.gov/regulations_policies/rulemaking/committees/documents/media/UAS%20ID%20ARC%20Final%20Report%20with%20Appendices.pdf
[3] https://www.federalregister.gov/documents/2019/12/31/2019-28100/remote-identification-of-unmanned-aircraft-systems
----

---

From: Daniel Migault <[email-masked]>
Date: Thu, 6 Feb 2020 10:58:29 -0500

Thank you Eric for leading these charter discussions. Thank you also Magnus
and Benjamin for taking the time to provide the feed backs and
clarifications.
Yours,
Daniel

On Thu, Feb 6, 2020 at 10:54 AM Eric Vyncke (evyncke) <[email-masked]>
wrote:

> There was some discussions among the IESG, IAB and TM-RID BoF chairs about
> the charter during today IESG telechat. The latest version is below but we
> need to wait until Monday when Magnus will have time to review it and
> probably clear his BLOCK (Ben has promised to have a look at the revised
> draft before our interim meeting).
>
>
>
> Civil Aviation Authorities (CAAs) worldwide have initiated rule making for
> Unmanned Aircraft Systems (UAS) Remote Identification (RID). CAAs currently
> promulgate performance-based regulations that do not mandate specific
> techniques, but rather cite industry-consensus technical standards as
> acceptable means of compliance. One key standard is ASTM (formerly the
> American Society for Testing and Materials) WK65041 [1]. This specification
> defines the baseline design, construction, and verification requirements
> for an UAS. Network RID defines a set of information for UAS to make
> available globally via the Internet. Broadcast RID defines a set of
> messages for UAS to send locally one-way over Bluetooth or Wi-Fi. But
> WK65041 does not address how to populate/query registries, how to ensure
> trustworthiness of information, nor how to make the information useful.
>
>
>
> TMRID’s goal is to specify how RID can be made available in both Internet
> and local-only connected scenarios, especially in emergency situations.
> Some UAS operate in environments where the network or the devices or both
> are severely constrained [2] in terms of processing, bandwidth (e.g.,
> Bluetooth 4 packet is 21 byte long), or battery life, and TMRID aims to
> function in these environments. The specifications produced by the WG will
> need to balance public safety authorities’ need to know trustworthy
> information with UAS operators’ privacy.
>
>
>
> The working group will primarily leverage Internet standards (including
> HIP, EPP, RDAP and DNS) and infrastructure as well as domain name
> registration business models. The WG will track the requirements being
> developed by regulatory authorities including the US Federal Aviation
> Administration (US FAA) and the European Union Civil Aviation Authority
> CAA) and will aim to align with those requirements (e.g., [3]).
>
>
>
> * Requirements: The WG is expected to provide an information document that
> lists the requirements the UAS Remote Identification (UAS RID) - that is
> the system for identifying UA during flight by other parties must meet.
> Requirements will also include those associated to the UAS Identifier that
> need to both meet some constraints as well as some specific properties.
>
> * Architecture: The WG will propose a standard document that describes the
> architecture that address the requirements and that will re-use protocols
> or architectures already standardized at the IETF.
>
> * Protocol design: While the primary purpose of TM-RID WG is to leverage
> on existing protocols, the specificities of the UAS environment is likely
> to require existing protocols to be extended or new protocols to be
> designed. The WG will be focused on standardizing this protocols or
> extensions.
>
>
>
> [1] ASTM International F38 Committee Work Item WK65041 “Standard
> Specification for UAS Remote ID and Tracking”
> https://www.astm.org/DATABASE.CART/WORKITEMS/WK65041.htm
>
> [2] UAS Identification and Tracking Aviation Rulemaking Committee
> Recommendations Final Report 2017 SEP 30
> https://www.faa.gov/regulations_policies/rulemaking/committees/documents/media/UAS%20ID%20ARC%20Final%20Report%20with%20Appendices.pdf
>
> [3]
> https://www.federalregister.gov/documents/2019/12/31/2019-28100/remote-identification-of-unmanned-aircraft-systems
>
> ----
> --
> Tm-rid mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tm-rid
>

-- 
Daniel Migault
Ericsson

---

From: "Card, Stu" <[email-masked]>
Date: Thu, 6 Feb 2020 11:07:18 -0500

Clarification: "This specification defines the baseline design,
construction, and verification requirements for an UAS" needs "RID system"
appended, as the cited ASTM standard is exclusively about RID, not any
other aspect of UAS.

---

From: Benjamin Kaduk <[email-masked]>
Date: Thu, 6 Feb 2020 09:20:51 -0800

Hi Éric,

This revision addresses my blocking comment.

I do wonder whether there's a little more wordsmithing to do surrounding
the requirements document work item, to consider the relationship between
"what the IETF says are the requirements" and "what the actual legal
requirements in any given regulatory domain are".  E.g., the requirements
document would attempt to synthesize a common set of requirements that are
expected to generally reflect the problem space, and are shaped by the
various legal requirements, but may/may not directly reflect them.

Thanks,

Ben