Subject: [Tm-rid] Alissa Cooper's No Objection on charter-ietf-drip-00-01: (with COMMENT)

From: Alissa Cooper via Datatracker <[email-masked]>
Date: Wed, 19 Feb 2020 21:10:27 -0800

Alissa Cooper has entered the following ballot position for
charter-ietf-drip-00-01: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/charter-ietf-drip/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Two questions about this:

"* Requirements: the WG is expected to provide an informational document that
lists the technical requirements for applying IETF protocols to the UAS Remote
Identification (UAS RID) - that is the system for identifying UA during flight
by other parties. These requirements will also include those associated to the
UAS Identifier that need to both meet some constraints as well as some specific
properties."

Is UA distinct from UAS?

The last sentence doesn't parse properly for me. What is the subject of "need
to"? Is this saying "requirements ... need to ... meet some constraints ...
[and meet] some specific properties"? What does that mean?

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Thu, 20 Feb 2020 09:28:13 +0000

Alissa and Ben,

Thank you for your comments and let's work to fix all ambiguities... 

TM-RID list members can you please comment on Alissa & Ben's reviews ?
- Alissa: we need to expand UAS as "Unmanned Aircraft System" at first use even if only to avoid being ambiguous
- Alissa: what is the subject of the "need to": is it "these requirements" or "those associated to the UAS identifier" or "UAS identifier", let's be clear on this
- Ben: indeed milestone are quite optimistic... adoption should be target and request for publication 6 month later ?
- Ben: should RID be trustworthy (my guess is yes of course as this is the main purpose of this group)

The DRIP charter will be reviewed today at 15H00 UTC, so, a prompt reply from the proponents of the list will be appreciated

-éric

On 20/02/2020, 06:10, "Tm-rid on behalf of Alissa Cooper via Datatracker" <[email-masked] on behalf of [email-masked]> wrote:

    

    

    Is UA distinct from UAS?

    -- 
    Tm-rid mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/tm-rid

---

From: "Card, Stu" <[email-masked]>
Date: Thu, 20 Feb 2020 07:56:33 -0500

I agree that the last sentence could be reworded for clarity.

As to definitions...

UA is Unmanned Aircraft, the drone itself (the thing that actually flies).

UAS is Unmanned Aircraft System, which includes the UA and its
corresponding Ground Control Station (GCS).

The difference between the UA and the UAS is sometimes significant. For
example, some regulators specify that RID must be directly broadcast from
the UA, whereas others allow the GCS to be the proximate source of RID.

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Thu, 20 Feb 2020 16:04:03 +0000

BTW, the charter has been provisionally approved today by the IESG (Yeah!)  ***IF*** the charter fix the ambiguities below on Friday or on Monday. So, we have a little more time

-éric

On 20/02/2020, 10:28, "Eric Vyncke (evyncke)" <[email-masked]> wrote:

    Alissa and Ben,

    
    
    -éric

        

        

        
        Is UA distinct from UAS?

---

From: "Da Silva, Saulo" <[email-masked]>
Date: Thu, 20 Feb 2020 19:13:09 +0000

A small proposal on the entities involved in the coordination.
The charter says: 
"The WG will track and align with the requirements being
developed by regulatory authorities, e.g., the US Federal Aviation
Administration (US FAA) [3], and the European Union Aviation Safety Agency
(EASA) delegated [4] and implementing [5] Regulations."

I would add in the last sentence ", e.g., the International Civil Aviation Organization (ICAO), the US Federal Aviation
Administration (US FAA) [3] and the European Union Aviation Safety Agency
(EASA) delegated [4] and implementing [5] Regulations.

Saulo

-----Original Message-----
From: Tm-rid [mailto:[email-masked]] On Behalf Of Eric Vyncke (evyncke)
Sent: 20-Feb-20 4:28 AM
To: [email-masked]
Cc: [email-masked]; Alissa Cooper <[email-masked]>; Benjamin Kaduk <[email-masked]>
Subject: Re: [Tm-rid] Alissa Cooper's No Objection on charter-ietf-drip-00-01: (with COMMENT)

Alissa and Ben,

-éric

    

    The document, along with other ballot positions, can be found here:
    https://secure-web.cisco.com/1K6WvfIsQeVz7pjl8rINbBQRtAuXI7drLR02o5fTI2zvneVJrJyoGbJrCyeHQ7BourNQg68It-d6KTs0h1V3h39Y8iOENxGR_sj1gkk0IPyFVlRlXmaGcGqb8g-hW8QALBIPZHJW1d92D7zUfC4A8CbytOkIRfhgQPiOEqBVhBTKBiRFIbu_8J8xKAoufJ06i7Zv6IEkIyfhKOUF86WrzHTFIKVdf4BcITI2ix9uKSCAeRh_pIHjiS-dP7ST8TOOxpLnhIHYfZ7OaJD7_DV6QPKWaRZjwIgY67_Gx_Y0sTSk-ojbsXylZlhSMdhzh3gbz/https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fcharter-ietf-drip%2F

    

    Is UA distinct from UAS?

    -- 
    Tm-rid mailing list
    [email-masked]
    https://secure-web.cisco.com/1LSLnLR86BM50xzlzPr_Y0SqKhuYLJtLticd2L-Ro7doynfQj1BZ93Ka-6HFZaElAmb3xDJINp5zRD4SoxNlPVHX7w--sVkKJCRy0r6KULpt3o9bTzd4UB6Bqi3dw3sHb0OaU2Px6jruRf8jdq_D5SAWNVSdlhVHpMHrudvi-z_jUTltxonIoghdyEyHuCF8wMexJfcWhEbjunzD_ryiHQzFOoMDHw2AMJGr2GRJ2ThuX6Lz_Qs-XTjVz5IKy2izTng_py09tKmaO710kw9ezfmKFHKAkc5AffxmBUxNUeGdu11iRYhmRQahLeXGd7zoqlu_ftWThRSCO4TTmbEJ1xA/https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Ftm-rid

-- 
Tm-rid mailing list
[email-masked]
https://secure-web.cisco.com/1LSLnLR86BM50xzlzPr_Y0SqKhuYLJtLticd2L-Ro7doynfQj1BZ93Ka-6HFZaElAmb3xDJINp5zRD4SoxNlPVHX7w--sVkKJCRy0r6KULpt3o9bTzd4UB6Bqi3dw3sHb0OaU2Px6jruRf8jdq_D5SAWNVSdlhVHpMHrudvi-z_jUTltxonIoghdyEyHuCF8wMexJfcWhEbjunzD_ryiHQzFOoMDHw2AMJGr2GRJ2ThuX6Lz_Qs-XTjVz5IKy2izTng_py09tKmaO710kw9ezfmKFHKAkc5AffxmBUxNUeGdu11iRYhmRQahLeXGd7zoqlu_ftWThRSCO4TTmbEJ1xA/https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Ftm-rid

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Fri, 21 Feb 2020 21:48:34 +0000

Any taker to answer Alissa's second point ? about what is the subject (see below) ?

I would have loved to finalize the charter this week and this is the only open point left before approval

-éric

On 20/02/2020, 10:28, "Tm-rid on behalf of Eric Vyncke (evyncke)" <[email-masked] on behalf of [email-masked]> wrote:

    Alissa and Ben,

    
    
    -éric

        

        

        
        Is UA distinct from UAS?

---

From: "Wiethuechter, Adam" <[email-masked]>
Date: Fri, 21 Feb 2020 17:10:22 -0500

This (the second point) is mentioning that the UAS Identifier has its own
set of constraints and properties that it must hold - defined and regulated
by parties outside the IETF. For example UAS IDs are constrained to 20
bytes.

So the requirements documents produced by the WG will also specify other
identifiers, created new or adapted from an existing protocol (this is
exactly with the HHITs are from HIP), that conform and meet the
specifications to be certified as a UAS ID.

Probably not the exact words to use, but I think it clears up the confusion?

On Fri, Feb 21, 2020 at 4:48 PM Eric Vyncke (evyncke) <[email-masked]>
wrote:

> On 20/02/2020, 10:28, "Tm-rid on behalf of Eric Vyncke (evyncke)" <
> [email-masked] on behalf of [email-masked]> wrote:
>
>     Alissa and Ben,
>
>     - Alissa: we need to expand UAS as "Unmanned Aircraft System" at first
> use even if only to avoid being ambiguous
>     - Alissa: what is the subject of the "need to": is it "these
> requirements" or "those associated to the UAS identifier" or "UAS
> identifier", let's be clear on this
>     - Ben: indeed milestone are quite optimistic... adoption should be
> target and request for publication 6 month later ?
>     The DRIP charter will be reviewed today at 15H00 UTC, so, a prompt
> reply from the proponents of the list will be appreciated
>
>     -éric
>
>     On 20/02/2020, 06:10, "Tm-rid on behalf of Alissa Cooper via
> Datatracker" <[email-masked] on behalf of [email-masked]>
> wrote:
>

-- 
73's,
Adam T. Wiethuechter
AX Enterprize, LLC

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Fri, 21 Feb 2020 22:13:20 +0000

Adam

Would you mind proposing a sentence to replace the existing one ?

From: "Wiethuechter, Adam" <[email-masked]>
Date: Friday, 21 February 2020 at 23:10
To: Eric Vyncke <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, Michael Richardson <[email-masked]>, Robert Moskowitz <[email-masked]>
Subject: Re: [Tm-rid] Alissa Cooper's No Objection on charter-ietf-drip-00-01: (with COMMENT)

This (the second point) is mentioning that the UAS Identifier has its own set of constraints and properties that it must hold - defined and regulated by parties outside the IETF. For example UAS IDs are constrained to 20 bytes.

So the requirements documents produced by the WG will also specify other identifiers, created new or adapted from an existing protocol (this is exactly with the HHITs are from HIP), that conform and meet the specifications to be certified as a UAS ID.

On Fri, Feb 21, 2020 at 4:48 PM Eric Vyncke (evyncke) <[email-masked]<mailto:[email-masked]>> wrote:
Any taker to answer Alissa's second point ? about what is the subject (see below) ?

-éric

On 20/02/2020, 10:28, "Tm-rid on behalf of Eric Vyncke (evyncke)" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

    Alissa and Ben,

    -éric

    On 20/02/2020, 06:10, "Tm-rid on behalf of Alissa Cooper via Datatracker" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

        Is UA distinct from UAS?

        --
        Tm-rid mailing list
        [email-masked]<mailto:[email-masked]>
        https://www.ietf.org/mailman/listinfo/tm-rid

    --
    Tm-rid mailing list
    [email-masked]<mailto:[email-masked]>
    https://www.ietf.org/mailman/listinfo/tm-rid

--
Tm-rid mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tm-rid

--
73's,
Adam T. Wiethuechter
AX Enterprize, LLC

---

From: "Wiethuechter, Adam" <[email-masked]>
Date: Fri, 21 Feb 2020 17:20:33 -0500

OLD: "These requirements will also include those associated to the UAS
Identifier that need to both meet some constraints as well as some specific
properties."

NEW: "These requirements also include showing that new or adapted
identifiers from existing protocols conform and meet the specifications to
be certified as a UAS ID."

How is this everyone?

On Fri, Feb 21, 2020 at 5:13 PM Eric Vyncke (evyncke) <[email-masked]>
wrote:

> *From: *"Wiethuechter, Adam" <[email-masked]>
> *Date: *Friday, 21 February 2020 at 23:10
> *To: *Eric Vyncke <[email-masked]>
> *Cc: *"[email-masked]" <[email-masked]>, "[email-masked]" <
> [email-masked]>, Michael Richardson <[email-masked]>, Robert
> Moskowitz <[email-masked]>
> *Subject: *Re: [Tm-rid] Alissa Cooper's No Objection on
> charter-ietf-drip-00-01: (with COMMENT)
>
>
>

-- 
73's,
Adam T. Wiethuechter
AX Enterprize, LLC

---

From: "Card, Stu" <[email-masked]>
Date: Mon, 24 Feb 2020 08:32:25 -0500

Did Saulo DaSilva's suggestion about adding ICAO along with FAA and EASA
make the cut?
Did Adam's proposed sentence clarifying UAS RID identifier properties
satisfy everyone?
Does our charter now address all of the points that the commenters and IESG
wanted?
IOW, is our charter now fully accepted, so that our WG is not merely
_conditionally_ approved?
If so, should we move our mailing list from [email-masked] to [email-masked]
?

On Fri, Feb 21, 2020 at 5:20 PM Wiethuechter, Adam <
[email-masked]> wrote:

>> [email-masked]>, Michael Richardson <[email-masked]>,
>> Robert Moskowitz <[email-masked]>
>>     - Alissa: we need to expand UAS as "Unmanned Aircraft System" at
>> first use even if only to avoid being ambiguous
>>         email addresses included in the To and CC lines.. (Feel free to
>> cut this

---

From: Robert Moskowitz <[email-masked]>
Date: Mon, 24 Feb 2020 08:38:58 -0500

Stu,

Mailing list changes are done by the IETF admin and we will be notified 
of the change.  It will occur, most likely, when Eric finishes all your 
prior points.  :)

On 2/24/20 8:32 AM, Card, Stu wrote:
> Did Saulo DaSilva's suggestion about adding ICAO along with FAA and 
> EASA make the cut?
> Does our charter now address all of the points that the commenters and 
> IESG wanted?
> If so, should we move our mailing list from [email-masked] 
> <mailto:[email-masked]> to [email-masked] <mailto:[email-masked]>?
>
>
> On Fri, Feb 21, 2020 at 5:20 PM Wiethuechter, Adam 
> <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     OLD: "These requirements will also include those associated to the
>     UAS Identifier that need to both meet some constraints as well as
>     some specific properties."
>
>     identifiers from existing protocols conform and meet the
>     specifications to be certified as a UAS ID."
>
>     How is this everyone?
>
>     On Fri, Feb 21, 2020 at 5:13 PM Eric Vyncke (evyncke)
>     <[email-masked] <mailto:[email-masked]>> wrote:
>
>         Adam
>
>         *From: *"Wiethuechter, Adam"
>         <[email-masked]
>         <mailto:[email-masked]>>
>         *To: *Eric Vyncke <[email-masked] <mailto:[email-masked]>>
>         *Cc: *"[email-masked] <mailto:[email-masked]>"
>         <[email-masked] <mailto:[email-masked]>>,
>         "[email-masked] <mailto:[email-masked]>"
>         <[email-masked] <mailto:[email-masked]>>, Michael
>         Richardson <[email-masked]
>         <mailto:[email-masked]>>, Robert Moskowitz
>         <[email-masked] <mailto:[email-masked]>>
>         This (the second point) is mentioning that the UAS Identifier
>         has its own set of constraints and properties that it must
>         hold - defined and regulated by parties outside the IETF. For
>         example UAS IDs are constrained to 20 bytes.
>
>         So the requirements documents produced by the WG will also
>         specify other identifiers, created new or adapted from an
>         existing protocol (this is exactly with the HHITs are from
>         HIP), that conform and meet the specifications to be certified
>         as a UAS ID.
>
>         On Fri, Feb 21, 2020 at 4:48 PM Eric Vyncke (evyncke)
>         <[email-masked] <mailto:[email-masked]>> wrote:
>
>             I would have loved to finalize the charter this week and
>             this is the only open point left before approval
>
>             -éric
>
>             On 20/02/2020, 10:28, "Tm-rid on behalf of Eric Vyncke
>             (evyncke)" <[email-masked]
>             <mailto:[email-masked]> on behalf of
>             [email-masked] <mailto:[email-masked]>> wrote:
>
>                 Alissa and Ben,
>
>                 - Alissa: we need to expand UAS as "Unmanned Aircraft
>             System" at first use even if only to avoid being ambiguous
>                 - Alissa: what is the subject of the "need to": is it
>             "these requirements" or "those associated to the UAS
>             identifier" or "UAS identifier", let's be clear on this
>                 - Ben: indeed milestone are quite optimistic...
>             adoption should be target and request for publication 6
>             month later ?
>                 - Ben: should RID be trustworthy (my guess is yes of
>             course as this is the main purpose of this group)
>
>                 The DRIP charter will be reviewed today at 15H00 UTC,
>             so, a prompt reply from the proponents of the list will be
>             appreciated
>
>                 -éric
>
>                 On 20/02/2020, 06:10, "Tm-rid on behalf of Alissa
>             Cooper via Datatracker" <[email-masked]
>             <mailto:[email-masked]> on behalf of
>             [email-masked] <mailto:[email-masked]>> wrote:
>
>                     email addresses included in the To and CC lines..
>             (Feel free to cut this
>             [email-masked] <mailto:[email-masked]>
>             [email-masked] <mailto:[email-masked]>
>             [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Mon, 24 Feb 2020 14:03:33 +0000

Stu

Correct for all points, DRIP is now officially a WG.

The list will stay [email-masked]<mailto:[email-masked]> but we can add a forward from [email-masked]<mailto:[email-masked]> to [email-masked]<mailto:[email-masked]> (many WG have a mailing list whose name does not match the WG name: 6man, dprive, ...)

-éric

From: "Card, Stu" <[email-masked]>
Date: Monday, 24 February 2020 at 14:33
To: Eric Vyncke <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, Michael Richardson <[email-masked]>, "[email-masked]" <[email-masked]>, Robert Moskowitz <[email-masked]>, Adam Wiethuechter <[email-masked]>, "Da Silva, Saulo" <[email-masked]>
Subject: Re: [Tm-rid] Alissa Cooper's No Objection on charter-ietf-drip-00-01: (with COMMENT)

Did Saulo DaSilva's suggestion about adding ICAO along with FAA and EASA make the cut?
Did Adam's proposed sentence clarifying UAS RID identifier properties satisfy everyone?
Does our charter now address all of the points that the commenters and IESG wanted?
IOW, is our charter now fully accepted, so that our WG is not merely _conditionally_ approved?
If so, should we move our mailing list from [email-masked]<mailto:[email-masked]> to [email-masked]<mailto:[email-masked]>?

On Fri, Feb 21, 2020 at 5:20 PM Wiethuechter, Adam <[email-masked]<mailto:[email-masked]>> wrote:
OLD: "These requirements will also include those associated to the UAS Identifier that need to both meet some constraints as well as some specific properties."

NEW: "These requirements also include showing that new or adapted identifiers from existing protocols conform and meet the specifications to be certified as a UAS ID."

How is this everyone?

On Fri, Feb 21, 2020 at 5:13 PM Eric Vyncke (evyncke) <[email-masked]<mailto:[email-masked]>> wrote:
Adam

From: "Wiethuechter, Adam" <[email-masked]<mailto:[email-masked]>>
Date: Friday, 21 February 2020 at 23:10
To: Eric Vyncke <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Michael Richardson <[email-masked]<mailto:[email-masked]>>, Robert Moskowitz <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Tm-rid] Alissa Cooper's No Objection on charter-ietf-drip-00-01: (with COMMENT)

-éric

    Alissa and Ben,

    -éric

        When responding, please keep the subject line intact and reply to all
        email addresses included in the To and CC lines.. (Feel free to cut this
        introductory paragraph, however.)

        Is UA distinct from UAS?

--
73's,
Adam T. Wiethuechter
AX Enterprize, LLC

--
73's,
Adam T. Wiethuechter
AX Enterprize, LLC

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Mon, 24 Feb 2020 14:12:24 +0000

And I forgot to say that the charter is at https://datatracker.ietf.org/doc/charter-ietf-drip/

-éric

How is this everyone?

-éric

    Alissa and Ben,

    -éric

        Is UA distinct from UAS?

--
73's,
Adam T. Wiethuechter
AX Enterprize, LLC

--
73's,
Adam T. Wiethuechter
AX Enterprize, LLC

---

From: Michael Richardson <[email-masked]>
Date: Mon, 24 Feb 2020 12:11:26 -0500

> The list will stay [email-masked]<mailto:[email-masked]> but we can
    > add a forward from [email-masked]<mailto:[email-masked]> to
    > [email-masked]<mailto:[email-masked]> (many WG have a mailing list
    > whose name does not match the WG name: 6man, dprive, ...)

I was told that actually, we can't add the forwarding because of how the mail
archival system works.  (I'm sad/annoyed)

Given that, I would encourage changing the name of the ML, or creating a new
ML if we have to. (The first message on the new list can point to the
previous list archives)

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-