Subject: [Tm-rid] Comments about harmonization of U-space vs. ASTM/RID

From: "Jarvenpaa, Mika (Nokia - FI/Espoo)" <[email-masked]>
Date: Wed, 25 Mar 2020 22:27:27 +0000

Hi,

I'm a bit new to processes of IETF RID WG. I have followed development of both US RID NPRM & RID (ASTM) plus EASA regulations.

Things evolving fast and seems some material presented in today's meeting was already outdated.

New U-space regulation draft published in EU less than two weeks ago.
https://www.easa.europa.eu/document-library/opinions/opinion-012020

Also the results of pilot projects were published just recently.
https://www.sesarju.eu/news/sesar-u-space-projects-results-published

Best regards
Mika Järvenpää

---

From: Robert Moskowitz <[email-masked]>
Date: Wed, 25 Mar 2020 18:45:46 -0400

> https://www.easa.europa.eu/document-library/opinions/opinion-012020

This is going to take a bit to get the right pieces to browe.

> https://www.sesarju.eu/news/sesar-u-space-projects-results-published

I got this and did a quick search on broadcast.  They are only 
referencing ADS-B.  This would severely limit its availability to 
observing devices.  They said that further research is needed.

But I think the former docs will be more important that a project 
summary report.

---

From: "Jarvenpaa, Mika (Nokia - FI/Espoo)" <[email-masked]>
Date: Wed, 25 Mar 2020 22:59:57 +0000

Yep. This was the exact part referred:

Article 10: Network identification service

1. The network identification service shall continuously process the remote identification of the UAS throughout the whole duration of the flight and provide it to authorised users in an aggregated manner.

2. This service shall distribute messages with the following content:

(a) the UAS operator registration number;
(b) the unique physical serial number of the add-on compliant with standard
ANSI/CTA-2063;
(c) the geographical position of the unmanned aircraft and its height above the
surface or take-off point;
(d) the route course measured clockwise from true north and the ground speed of
the UA;
(e) the geographical position of the remote pilot or, if not available, the take-off
point;
(f) the emergency status of the UAS; and
(g) the time at which the messages were generated.

3. The identification service shall ensure the levels of access to authorised users based
on the credentials of the user. The levels of access established by the competent
authority in accordance with Article 21(1)(b) shall be complied with by the U-space
service providers based on the credentials of the user.

4. The identification service shall correlate identification and UAS traffic information.

5. U-space service providers shall be able to receive and exchange broadcast and
network e-identification information.

Regards
Mika

-----Original Message-----
From: Robert Moskowitz <[email-masked]> 
Sent: Thursday, March 26, 2020 12:46 AM
To: Jarvenpaa, Mika (Nokia - FI/Espoo) <[email-masked]>; [email-masked]
Subject: Re: [Tm-rid] Comments about harmonization of U-space vs. ASTM/RID

> https://www.sesarju.eu/news/sesar-u-space-projects-results-published

I got this and did a quick search on broadcast.  They are only referencing ADS-B.  This would severely limit its availability to observing devices.  They said that further research is needed.

But I think the former docs will be more important that a project summary report.

---

From: Robert Moskowitz <[email-masked]>
Date: Wed, 25 Mar 2020 19:12:49 -0400

> https://www.easa.europa.eu/document-library/opinions/opinion-012020

https://www.easa.europa.eu/sites/default/files/dfu/Opinion%20No%2001-2020.pdf

This article clarifies that the identification service proposed in the 
U-space framework is based on the
requirements for remote identification contained in Regulation (EU) 
2019/945 to avoid requiring
additional UAS equipment or capabilities.

So we have this information and note the conflicts it presents.

https://www.easa.europa.eu/sites/default/files/dfu/Appendix%20to%20Opinion%20No%2001-2020.pdf

I really like this one in Article 13:

— To comply with this rule, every USSP should deploy ground receiving 
antennas to guarantee the
coverage for the entire U-space airspace. Most service providers do not 
have technical systems
that would receive broadcast E-ID transmissions.

I don't see that should happening with allowing broadcast ID.

And finally:

https://www.easa.europa.eu/sites/default/files/dfu/Draft%20COMMISSION%20IMPLEMENTING%20REGULATION%20on%20a%20high-level%20regulatory%20fram....pdf

in GM1 to Article 10, I am confused.

and in order to avoid additional UAS equipment or
capabilities in particular for the ‘open’ category. In addition, it is 
now specified that both broadcast
and network information shall be received. This is consistent with the 
upcoming amendment to
Regulation (EU) 2019/945 and supports the redundancy under certain use 
cases, although limited to
certain cases of U-space airspace implementation

What does 'shall' mean above?  That the upcoming amendment will only be 
allow Network and Broadcast both as the FAA's NPRM says?

Or is the U-Space Service Provider that 'shall' receive both types of 
messages?  thus the onus is on the USSP, not the UAS.

thanks

-- 
Standard Robert Moskowitz
Owner
HTT Consulting
C:248-219-2059
F:248-968-2824
E:[email-masked]

There's no limit to what can be accomplished if it doesn't matter who 
gets the credit

---

From: Robert Moskowitz <[email-masked]>
Date: Wed, 25 Mar 2020 19:45:19 -0400

> (a) the UAS operator registration number;

If this is from the ASTM Operator ID message, as currently specified 
this is a serious privacy leakage.  But there are ways to fix it, 
requiring authorized registry lookups.

> (b) the unique physical serial number of the add-on compliant with standard

Serious fraud risk.  Why do you believe that UAV's claim for that serial 
number?  The Basic ID message is just the ID.  So it has to be carried 
in the Authentication Message, not as ASTM defines it but like Adam has, 
to be able the validate its claim.

Also this immutable, forever ID is a serious privacy leakage.

And how are they assigned to Maker UAV?  Probably there is some 
mechanism coming.

> surface or take-off point;

The loc/vec message has a 2 byte timestamp that allows for replay attacks.

> (e) the geographical position of the remote pilot or, if not available, the take-off

Have you seen the UPS demo?  The remote pilot releases the UAV while 
making one delivery and picks it up at the next delivery, so where is 
the pilot?  :)  There was a take-off point and a forecasted pick-up point.

> (g) the time at which the messages were generated.

If you look at the ASTM messages, time is relative except for the auth 
message.  So you are counting on the time from the receiver.  I deal 
with that in my CS-RID draft.

---

From: "Card, Stu" <[email-masked]>
Date: Mon, 30 Mar 2020 02:24:29 -0400

Indeed, things are evolving quickly, and as a US person, I am more familiar
with the FAA's activities than the EASA's.
U-Space appears to be a more comprehensive (ambitious?) EU attempt to not
just integrate but unify UTM, ATM and Urban Air Mobility than we yet see in
the US.
The DRIP WG needs European participants who can track this and other
developments with which our US participants are insufficiently familiar...
:-)

On Wed, Mar 25, 2020 at 6:30 PM Jarvenpaa, Mika (Nokia - FI/Espoo) <
[email-masked]> wrote:

> Hi,
>
> I'm a bit new to processes of IETF RID WG. I have followed development of
> both US RID NPRM & RID (ASTM) plus EASA regulations.
>
> Tm-rid mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tm-rid
>

---

From: Robert Moskowitz <[email-masked]>
Date: Mon, 30 Mar 2020 08:19:13 -0400

On 3/30/20 2:24 AM, Card, Stu wrote:
> Indeed, things are evolving quickly, and as a US person, I am more 
> familiar with the FAA's activities than the EASA's.
> U-Space appears to be a more comprehensive (ambitious?) EU attempt to 
> not just integrate but unify UTM, ATM and Urban Air Mobility than we 
> yet see in the US.

But seems to be very ATM centric.  In that what works for ATM we can get 
to work for UAS.  This is just my bias opinion from a quick read-through 
of the u-space docs I downloaded.

> developments with which our US participants are insufficiently 
> familiar... :-)
>
> On Wed, Mar 25, 2020 at 6:30 PM Jarvenpaa, Mika (Nokia - FI/Espoo) 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     Hi,
>
>     I'm a bit new to processes of IETF RID WG. I have followed
>     development of both US RID NPRM & RID (ASTM) plus EASA regulations.
>
>     [email-masked] <mailto:[email-masked]>

---

From: "Jarvenpaa, Mika (Nokia - FI/Espoo)" <[email-masked]>
Date: Tue, 31 Mar 2020 22:28:19 +0000

Also good to remember it is just the first opinion for the U-space regulation so it is subject to the changes until getting accepted as a new regulation. So, not too late for commenting and trying to get things done in more harmonized (consolidating different view points) both US and EU (rest of the world can follow). The performance based problems to be solved both EU and US are anyway essentially the same (if not taking some weird things on some states into account).

Best regards
Mika

From: Robert Moskowitz <[email-masked]>
Sent: Monday, March 30, 2020 3:19 PM
To: Card, Stu <[email-masked]>; Jarvenpaa, Mika (Nokia - FI/Espoo) <[email-masked]>
Cc: [email-masked]
Subject: Re: [Tm-rid] Comments about harmonization of U-space vs. ASTM/RID

On 3/30/20 2:24 AM, Card, Stu wrote:
Indeed, things are evolving quickly, and as a US person, I am more familiar with the FAA's activities than the EASA's.
U-Space appears to be a more comprehensive (ambitious?) EU attempt to not just integrate but unify UTM, ATM and Urban Air Mobility than we yet see in the US.

But seems to be very ATM centric.  In that what works for ATM we can get to work for UAS.  This is just my bias opinion from a quick read-through of the u-space docs I downloaded.

The DRIP WG needs European participants who can track this and other developments with which our US participants are insufficiently familiar... :-)

On Wed, Mar 25, 2020 at 6:30 PM Jarvenpaa, Mika (Nokia - FI/Espoo) <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Best regards
Mika Järvenpää

--
Tm-rid mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tm-rid

--
Robert Moskowitz
Owner
HTT Consulting
C:      248-219-2059
F:      248-968-2824
E:      [email-masked]<mailto:[email-masked]>

There's no limit to what can be accomplished if it doesn't matter who gets the credit