Subject: Re: [Tm-rid] I-D Action: draft-card-tmrid-uas-arch-00.txt(Internet mail)

From: "shuaiizhao(Shuai Zhao)" <[email-masked]>
Date: Wed, 18 Mar 2020 04:45:58 +0000

Dear Stuart,

Thanks for providing this draft. It is very informative. Just couple of recommendations:

  *   Most drafts in the DRIP WG using the terms NETDP/NETSP. That is not consistent with draft-card-tmrid-uas-01, which use RID SP/DP.
  *   It might be helpful to provide some introduction about USS and UTM and add context how UTM might interact with USS or GCS and etc.
  *   FAA has launched the LAANC program, which I believe you knew that already.   The TM-RID might very well use some functionalities provide by LANNC or being used by LANNC for AAA purpose. Is that worth mentioning here in the draft?
  *   I still have a bit difficult to understand how CS-RID works with SDSP/finder, which was specified in draft-moskowitz-drip-crowd-sourced-rid-01. I believe we can talk more during IETF virtual meeting. ☺

Best,
Shuai Zhao

From: I-D-Announce <[email-masked]> on behalf of "[email-masked]" <[email-masked]>
Reply-To: "[email-masked]" <[email-masked]>
Date: Wednesday, February 5, 2020 at 23:49
To: "[email-masked]" <[email-masked]>
Subject: I-D Action: draft-card-tmrid-uas-arch-00.txt(Internet mail)

A New Internet-Draft is available from the on-line Internet-Drafts directories.

        Title           : Unmanned Aircraft System Remote Identification Architecture
        Authors         : Stuart W. Card
                          Adam Wiethuechter
                          Robert Moskowitz
                Filename        : draft-card-tmrid-uas-arch-00.txt
                Pages           : 13
                Date            : 2020-02-05

Abstract:
   This document defines an architecture for Trustworthy Multipurpose
   Remote Identification (tm-rid) protocols and services to support
   Unmanned Aircraft System Remote Identification (UAS RID), including
   its building blocks and their interfaces, all to be standardized.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-card-tmrid-uas-arch/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-card-tmrid-uas-arch-00
https://datatracker.ietf.org/doc/html/draft-card-tmrid-uas-arch-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
I-D-Announce mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: "Stuart W. Card" <[email-masked]>
Date: Sun, 22 Mar 2020 20:57:35 -0400

Shuai Zhao --

Thank you for reviewing draft-card-tmrid-uas-arch-00.

My responses are interleaved.

On 3/18/2020 12:45 AM, shuaiizhao(Shuai Zhao) wrote:
> ...
> recommendations:
> 
>     * Most drafts in the DRIP WG using the terms NETDP/NETSP. That is
>       not consistent with draft-card-tmrid-uas-01, which use RID SP/DP.

draft-card-tmrid-uas was my initial draft Applicability Statement.

It was suggested to split it into separate -reqs and -arch drafts, which
I did. I do not plan to continue work on the original document, unless
the DRIP Working Group decides that is the way to proceed.

At about that same time, the nomenclature was changing. What ASTM had
called a "Network Remote ID Service Provider (Net-RID SP)" the US FAA
called a "Remote Identification UAS Service Supplier (Remote ID USS)";
what ASTM called a "Network Remote ID Display Provider" the FAA did not
recognize as a distinct entity (it is unclear architecturally where this
function will be provided in the FAA's vision). The abbreviations
"NETSP" and "NETDP" that I used in the -reqs and -arch drafts came from
variable names in the evolving Open Drone ID open source code; I can't
even find them there any more. We need to choose some nomenclature that
is readily mapped to/from the ASTM, ICAO, US FAA, EU EASA, et al terms
and then use it consistently. I am open to suggestions. :-)

>     * It might be helpful to provide some introduction about USS and UTM
>       and add context how UTM might interact with USS or GCS and etc.

Agreed, but I don't want to embed a tutorial on UAS Traffic Management
(UTM) etc. into what is hoped to become a RFC. I will try to provide
brief UTM context in the next rev of -reqs and/or -arch.

>     * FAA has launched the LAANC program, which I believe you knew that
>       already.   The TM-RID might very well use some functionalities
>       provide by LANNC or being used by LANNC for AAA purpose. Is that
>       worth mentioning here in the draft?

Yes. Will do. Thanks for the good suggestion!

>     * I still have a bit difficult to understand how CS-RID works with
>       SDSP/finder, which was specified in
>       draft-moskowitz-drip-crowd-sourced-rid-01. I believe we can talk
>       more during IETF virtual meeting.

Agreed. I'm not sure whether any of that belongs in the -reqs or -arch
drafts, as CS-RID is an additional layer of functionality, beyond the
basic DRIP contemplated for trustworthy UAS RID. Bob Moskowitz will
doubtless present his CS-RID concept this coming Wednesday.

- -- 
- -----------------------------------------
Stuart W. Card, PhD, Principal Engineer
AX Enterprize, LLC  www.axenterprize.com
4947 Commercial Drive, Yorkville NY 13495

---

From: "shuaiizhao(Shuai Zhao)" <[email-masked]>
Date: Mon, 23 Mar 2020 01:17:03 +0000

Thanks Stuart for your reply, please see comments inline.

Best,
Shuai Zhao

From: "Stuart W. Card" <[email-masked]>
Date: Sunday, March 22, 2020 at 17:58
To: "[email-masked]" <[email-masked]>
Cc: "shuaiizhao(Shuai Zhao)" <[email-masked]>
Subject: Re: [Tm-rid] I-D Action: draft-card-tmrid-uas-arch-00.txt(Internet mail)

Shuai Zhao --

At about that same time, the nomenclature was changing. What ASTM had
called a "Network Remote ID Service Provider (Net-RID SP)" the US FAA
called a "Remote Identification UAS Service Supplier (Remote ID USS)";
what ASTM called a "Network Remote ID Display Provider" the FAA did not
recognize as a distinct entity (it is unclear architecturally where this
function will be provided in the FAA's vision). The abbreviations
"NETSP" and "NETDP" that I used in the -reqs and -arch drafts came from
variable names in the evolving Open Drone ID open source code; I can't
even find them there any more. We need to choose some nomenclature that
is readily mapped to/from the ASTM, ICAO, US FAA, EU EASA, et al terms
and then use it consistently. I am open to suggestions. :-)
            [Shuai] Tencent recently joined ASTM, So we are on the same page about what terms ASTM used ☺
            And I agree, all of the terms represents pretty much the same, without exhausted use cases.
            It might be not a big deal at this moment, we can improve it along the way.

Agreed, but I don't want to embed a tutorial on UAS Traffic Management
(UTM) etc. into what is hoped to become a RFC. I will try to provide
brief UTM context in the next rev of -reqs and/or -arch.
            [Shuai] I see what you mean and I agreed. Some brief tutorial is very helpful. When we worked on RTP
            Payload format for VVC, we put a section to explain what RTP protocol “looks like”.
            But I also agree, the terminology and workflows among NASA,FAA and ASTM are all using different variants.

Yes. Will do. Thanks for the good suggestion!
            [Shuai] glad this is useful

[Shuai] Yes, I will be learning more from him then ☺

            And I believe it’s also worth mentioning to include a comprehensive knowledge domain from trustworthy SDOs who is involved in UAS domain.
            ATIS is missing and they have few white papers out.  Even though ATIS is more focusing cellular domain, the RID concept is the same if I am not mistaken.
            I will share the summary once I finish the research
Here is link https://www.atis.org/01_strat_init/uav/

Wish we have a great first DRIP meeting.
- --