Subject: [Tm-rid] DRIP, EPP, RDAP, and the DNS

From: "Hollenbeck, Scott" <[email-masked]>
Date: Mon, 6 Apr 2020 13:54:15 +0000

I mentioned this in Jabber during the IETF-107 virtual meeting, but I'll mention it on-list as well: if this group gets around to talking about how EPP, RDAP, and the DNS can be used in a DRIP context, there are people who have expertise in those technologies who are following the work here and are willing to help. How can we help, and at what point do you think that help will be needed?

Scott

---

From: Robert Moskowitz <[email-masked]>
Date: Mon, 6 Apr 2020 10:10:03 -0400

> I mentioned this in Jabber during the IETF-107 virtual meeting, but I'll mention it on-list as well: if this group gets around to talking about how EPP, RDAP, and the DNS can be used in a DRIP cont…

So of the DNS pieces I attempt to cover in:

draft-moskowitz-hip-hierarchical-hit

And I would really like input on this, as it also has some impact on how 
the RAA bits are divvied up.

Basically it is next on my list.  But I may have to pitch in on the arch 
and req drafts, if Stu is out for a while...

Bob

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Fri, 10 Apr 2020 13:46:11 +0000

> -----Original Message-----
> From: Robert Moskowitz <[email-masked]>
> Sent: Monday, April 6, 2020 10:10 AM
> To: Hollenbeck, Scott <[email-masked]>; [email-masked]
> Subject: [EXTERNAL] Re: [Tm-rid] DRIP, EPP, RDAP, and the DNS
> 
> 
> 
> > I mentioned this in Jabber during the IETF-107 virtual meeting, but I'll
> mention it on-list as well: if this group gets around to talking about how EPP,
> RDAP, and the DNS can be used in a DRIP context, there are people who
> have expertise in those technologies who are following the work here and
> are willing to help. How can we help, and at what point do you think that help
> will be needed?
> >
> > Scott
> 
> And I would really like input on this, as it also has some impact on how the
> RAA bits are divvied up.

Bob, I'd like to check my understanding before making any suggestions. Do I have this correct?

The HHIT includes a field (the HID) that's used to identify two administrative domains, the RAA and the HDA. The RAA is kind of like a DNS root, except that in this model there can be more than one. The RAA maintains a DNS zone used to discover HDA rendezvous servers (RVS).

The HDA is assigned an identifier by an RAA. The HDA sounds a bit like a TLD registry. It operates rendezvous servers and HIP DNS extension servers.

Is this all correct? If so, is the thought that EPP could be used to register an HDA within an RAA and HIP DNS extension information with an HDA?

Scott

---

From: "Card, Stu" <[email-masked]>
Date: Fri, 10 Apr 2020 12:01:33 -0400

My thoughts on this are not yet fully coherent, but here are some of them...

I think of a HHIT as a name, but it is also an ORCHID, thus a valid IPv6
address. So it could be added to the real DNS (with the main root) for
reverse lookup in <nibble-reversed>.ip6. It is aggregatable only in its
upper 64 bits (RRA, HDA), the lower 64 are a flat address space, so there
could be scalability challenges, but only within the scope of a registry
(HDA). To short-cut the PTR then HIP RR (or PTR then AAAA RR) lookup
sequence latency, we could even register <low64>.<hda-domain-name> (or
something like that) as a FQDN.

As the HHIT is a name needing to be registered, we can use internet domain
name protocols (e.g. EPP), services, infrastructure & business models to do
registration. For it to be a legal UAS ID in a given Civil Aviation
Administration (e.g. US FAA) jurisdiction, the registrar would have to
collect whatever information that CAA requires (international harmonization
is recognized as an issue by the CAAs). Some registrars would offer (and
over time develop reputations regarding) better vetting of this
information, thus could be selected by organizations for reference in the
trust policies that will be followed by their observers, e.g. : observer
receives Broadcast from Alice proving she is in Bob's registry, thus trusts
(to some extent) Alice; same observer receives Broadcast certificate from
Carol proving she is in Doug's registry, thus does not trust Carol.

The use of RDAP/XACML would be on subsequent access controlled lookups of
the Whois PII from the HHIT, whereas minimal strictly public info could be
in DNS.

I say all this from the perspective of someone who has configured DNS
servers to do tricks but never worked for a registrar much less a registry
operator, thus I need further education. :-)

Thanks!

On Fri, Apr 10, 2020, 09:47 Hollenbeck, Scott <shollenbeck=
[email-masked]> wrote:

> The HHIT includes a field (the HID) that's used to identify two
> administrative domains, the RAA and the HDA. The RAA is kind of like a DNS
> root, except that in this model there can be more than one. The RAA
> maintains a DNS zone used to discover HDA rendezvous servers (RVS).
>
> The HDA is assigned an identifier by an RAA. The HDA sounds a bit like a
> TLD registry. It operates rendezvous servers and HIP DNS extension servers.
>
> Is this all correct? If so, is the thought that EPP could be used to
> register an HDA within an RAA and HIP DNS extension information with an HDA?
>
> Scott
> --
> Tm-rid mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tm-rid
>